Multicast Question

From: Nathan Chessin (nchessin@cisco.com)
Date: Mon Dec 09 2002 - 00:30:17 GMT-3


Hi All,

I have a simple multicast topology set up and I am having trouble.

I can't ping the multicast group from router 4.

R1(s0/2)-------------(s0/2)R3(s0/1)--------------(s0/1)r4

All the interfaces have a "ip pim spare-mode" and all routers have ip
multicast-routing enabled.

On all routers I have "ip pim rp-address 10.1.1.1" which is the loopback
address of R1 and is reachable by all routers. The loopback also has ip pim
sparse-mode, and on R1 I have "ip igmp join 225.2.2.40" under s0/2.

I can't ping 225.2.2.40 from r4, but I can from R3. Any ideas?

Configs below.

Thanks,
Nate

hostname R1
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
lane client flush
cns event-service server
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
 ip pim sparse-mode
!
interface Loopback10
 ip address 11.1.1.1 255.255.255.0
!
interface Loopback20
 ip address 12.1.1.1 255.255.255.0
!
interface Loopback30
 ip address 13.1.1.1 255.255.255.0
!
interface Loopback40
 ip address 14.1.1.1 255.255.255.0
!
interface Ethernet0/1
 ip address 44.1.1.1 255.255.255.0
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial0/2
 ip address 1.1.1.1 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 225.2.2.40
!
ip classless
no ip http server
ip pim rp-address 10.1.1.1
---------------------
hostname R3
!
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
lane client flush
cns event-service server
!
!
interface Ethernet0/1
 ip address 44.1.1.3 255.255.255.0
!
interface Serial0/1
 ip address 3.1.1.3 255.255.255.0
 ip pim sparse-mode
 clockrate 64000
!
interface Serial0/2
 ip address 1.1.1.3 255.255.255.0
 ip pim sparse-mode
 clockrate 64000
!
!
router ospf 100
 redistribute rip subnets
 network 3.1.1.0 0.0.0.255 area 0
 network 44.1.1.0 0.0.0.255 area 0
!
router rip
 redistribute ospf 100
 network 1.0.0.0
 default-metric 5
!
ip classless
no ip http server
ip pim rp-address 10.1.1.1
!
-------------------------------------

hostname R4
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip multicast-routing
ip audit notify log
ip audit po max-events 100
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface Loopback10
 ip address 110.1.1.1 255.255.255.0
!
interface Loopback20
 ip address 120.1.1.1 255.255.255.0
!
interface Loopback30
 ip address 130.1.1.1 255.255.255.0
!
interface Loopback40
 ip address 140.1.1.1 255.255.255.0
!
interface Ethernet0/0
 no ip address
 shutdown
!
!
interface Serial0/1
 ip address 3.1.1.4 255.255.255.0
 ip pim sparse-mode
!
!
interface FastEthernet2/0
 ip address 44.1.1.4 255.255.255.0
 duplex auto
 speed auto
!
!
router ospf 100
 log-adjacency-changes
 network 3.1.1.0 0.0.0.255 area 0
 network 44.1.1.0 0.0.0.255 area 0
 network 100.1.1.0 0.0.0.255 area 0
 network 110.1.1.0 0.0.0.255 area 0
 network 120.1.1.0 0.0.0.255 area 0
 network 130.1.1.0 0.0.0.255 area 0
!
ip classless
ip http server
ip pim rp-address 10.1.1.1
!
.



This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:41 GMT-3