RE: Only 1 protocol per interface

From: Brian McGahan (brian@cyscoexpert.com)
Date: Tue Nov 26 2002 - 00:58:32 GMT-3


        Since EIGRP uses periodic hellos to establish adjacency,
passive-interface is sufficient in this case. Since passive-interface
in EIGRP suppresses the generation of hellos out an interface, adjacency
cannot be established, and therefore there can be no exchange of routes.

        An even easier method of choosing which specific interfaces are
running EIGRP is to use a wildcard mask when you use the network
statement. The 'network' statement in IGP does not actually mean what
networks you are advertising, it means what interfaces you are running
the protocol on. If you only want to run EIGRP on your Serial 1
interface with an address of 172.16.1.5, use the following syntax:

Router eigrp 2001
 Network 172.16.1.5 0.0.0.0
!

        This means that only the interface 172.16.1.5 is running EIGRP.
The opposite of this most specific syntax would be:

Router eigrp 2001
 Network 0.0.0.0 255.255.255.255
!

        This means that all interfaces are running EIGRP.

        With RIP, the case is different than EIGRP. Since RIP does not
use periodic hellos like EIGRP, OSPF, or IS-IS, passive-interface simply
means that you will not send any routing updates out an interface. This
does not mean that you will not receive routing updates in that
interface. To prevent learning routes in an interface using RIP, you
could use a distribute-list that denies everything (which would also
work for EIGRP), or use an access-list that denies RIP altogether. Take
the following examples:

Access-list 1 deny any
!
 router rip
  network 172.16.0.0
  distribute-list 1 in serial 1
!

or

access-list 100 deny udp any eq rip any eq rip
access-list 100 permit ip any any
!
interface serial 1
 ip access-group 100 in

Both would accomplish the same goal.

For more information on distribute-list:

http://www.cisco.com/warp/public/105/34.html

HTH

Brian McGahan, CCIE #8593
Director of Design and Implementation
brian@cyscoexpert.com

CyscoExpert Corporation
Internetwork Consulting & Training
Voice: 847.674.3392
Fax: 847.674.2625

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> syv
> Sent: Monday, November 25, 2002 5:50 PM
> To: ccielab@groupstudy.com
> Subject: Only 1 protocol per interface
>
> Hi,
>
> I have 1 router rip RIP & EIGRP
>
> Interface IP-Address OK? Method Status Prot
> Serial0 172.16.5.5 YES manual up up
> Serial1 172.16.1.5 YES manual up up
>
> S0 should be RIP only
> s1 should be EIGRP only
>
> How do I do that? Right now both protocols are running on
> both interfaces. RIP should not listen to broadcasts on S1
> and EIGRP should not listen to multicasts on S0:
>
> c2502#pr
> Routing Protocol is "rip"
> Sending updates every 30 seconds, next due in 25 seconds
> Invalid after 180 seconds, hold down 180, flushed after 240
> Outgoing update filter list for all interfaces is not set
> Incoming update filter list for all interfaces is not set
> Redistributing: rip
> Default version control: send version 1, receive any version
> Interface Send Recv Triggered RIP Key-chain
> Serial0 1 1 2
> Automatic network summarization is in effect
> Maximum path: 4
> Routing for Networks:
> 172.16.0.0
> Passive Interface(s):
> Serial1
> TokenRing0
> Routing Information Sources:
> Gateway Distance Last Update
> 172.16.5.8 120 00:00:03
> Distance: (default is 120)
>
> Routing Protocol is "eigrp 2001"
> Outgoing update filter list for all interfaces is not set
> Incoming update filter list for all interfaces is not set
> Default networks flagged in outgoing updates
> Default networks accepted from incoming updates
> EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
> EIGRP maximum hopcount 100
> EIGRP maximum metric variance 1
> Redistributing: eigrp 2001
> Automatic network summarization is in effect
> Maximum path: 4
> Routing for Networks:
> 172.16.0.0
> Passive Interface(s):
> Serial0
> TokenRing0
> Routing Information Sources:
> Gateway Distance Last Update
> 172.16.1.1 90 01:08:22
> Distance: internal 90 external 170
>
> Here is the config:
>
> interface Serial0
> bandwidth 1000
> ip address 172.16.5.5 255.255.255.0
> no fair-queue
> clockrate 1000000
> !
> interface Serial1
> ip address 172.16.1.5 255.255.255.0
> encapsulation frame-relay
> frame-relay map ip 172.16.1.1 111 broadcast
> no frame-relay inverse-arp
> !
> interface TokenRing0
> no ip address
> shutdown
> !
> router eigrp 2001
> passive-interface Serial0
> passive-interface TokenRing0
> network 172.16.0.0
> auto-summary
> no eigrp log-neighbor-changes
> !
> router rip
> passive-interface Serial1
> passive-interface TokenRing0
> network 172.16.0.0
> !
>
>
> --
> Thanks
> syv@911networks.com



This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:23:10 GMT-3