RE: dialer watch help

From: frank.yu@japan.bnpparibas.com
Date: Thu Nov 14 2002 - 23:51:11 GMT-3


Nate,

  Thanks again for the help, it works now. I noticed one problem, if I only
watch one route 135.5.13.0/24 the watch group works correctly, but if I
watch those three routes together, even though R2 lost all of those three
routes, it will still consider primary interface up.(I can tell from debug
dialer). Odd, but I will keep in mind that just watch one route at a time.
:-)

Frank

Internet
nkleven@intellinet.ws@groupstudy.com - 11/15/2002 12:10 AM

Please respond to nkleven@intellinet.ws

Sent by: nobody@groupstudy.com

To: Frank Yu

cc: CCIElab

Subject: RE: dialer watch help

It looks like you are watching the following routes:

135.5.13.0 255.255.255.0
135.5.3.0 255.255.255.0
135.5.1.0 255.255.255.0

In order to get the BRI on R2 to dial R1 when it looses one of these
routes,
you need to put dialer map statements under the BRI for each of them. Add
this and it should work:

dialer map ip 135.5.13.0 name R1 broadcast 0352051089
dialer map ip 135.5.3.0 name R1 broadcast 0352051089
dialer map ip 135.5.1.0 name R1 broadcast 0352051089

Before you put these in, run a debug dialer, you should get something like
this after the route to 135.5.13.0 is lost from R2:

14:52:50: DDR: Dialer Watch: watch-group = 1
14:52:50: DDR: network 135.5.13.0/255.255.255.0 DOWN,
14:52:50: DDR: primary DOWN
14:52:50: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
14:52:50: DDR: Dialer Watch watch-group 1 - dialer map/string not present
on
BR0/0

HTH

__________

Nate Kleven

Senior Network Engineer, CCNP Voice Access, MCSE

Expanets

6020 So 190th ST

Kent, WA 98032

(206)219.6135

"Experienced at Networked Solutions"

-----Original Message-----
From: frank.yu@japan.bnpparibas.com [mailto:frank.yu@japan.bnpparibas.com]
Sent: Wednesday, November 13, 2002 11:07 PM
To: nkleven@intellinet.ws
Subject: RE: dialer watch help

Thank you very much for the help Nate , the attchment is the config.

Frank
(See attached file: dial watch config.txt)

Internet
nkleven@intellinet.ws - 11/14/2002 02:59 PM

To: Frank Yu

cc:

Subject: RE: dialer watch help

Can you send me the configs one more time? They got jumbled up in the last
email.

__________

Nate Kleven

Senior Network Engineer, CCNP Voice Access, MCSE

Expanets

6020 So 190th ST

Kent, WA 98032

(206)219.6135

"Experienced at Networked Solutions"

-----Original Message-----
From: frank.yu@japan.bnpparibas.com [mailto:frank.yu@japan.bnpparibas.com]
Sent: Wednesday, November 13, 2002 9:34 PM
To: cciemail@intellinet.ws
Subject: RE: dialer watch help

Nate,

   Thanks for the concern, as I mentioned in the previous e-mail, the ISDN
config seems to be allright. As I can ping the other side through ISDN
circuit. But I ISDN line just don't come up even R2 lost the route
specified
in watch-list. I wonder if I should put more dialer maps just for the route
specified in dialer watch. Any comment?

Frank

Frank

Internet
cciemail@intellinet.ws - 11/14/2002 01:09 AM

To: Frank Yu

cc:

Subject: RE: dialer watch help

Have you verified that your ISDN works in a vanilla configuration? I
haven't had a chance to look at your configs yet, but I would start by just
programming your BRI's with dialer strings and IP addresses and try to ping
the other sides. A lot of the issues with ISDN are often at the lower
levels. Just a thought, before you start pulling apart your configs.

__________

Nate Kleven

Senior Network Engineer, CCNP Voice Access, MCSE

Expanets

6020 So 190th ST

Kent, WA 98032

(206)219.6135

"Experienced at Networked Solutions"

-----Original Message-----
From: frank.yu@japan.bnpparibas.com [mailto:frank.yu@japan.bnpparibas.com]
Sent: Wednesday, November 13, 2002 4:36 AM
To: ccielab@groupstudy.com
Subject: dialer watch help

Group,

   Being work on dailer watch for a while, for some reason it doesn't work
for me. All routers using 12.1(17) IP only version. ISDN circuit between R1
and R2, serial connection between R1 and R3.
  DDR is working fine I can ping from each other on R1 and R2, dialer watch
has been enabled on R2, but when ospf route 135.5.13.0/24 lost on R2, ISDN
is not up? What am I doing wrong? Can someone please take a look?
   Thanks in advance.

R1#sh run
Building configuration...

Current configuration : 1285 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
username R2 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type ntt
!
!
!
interface Loopback0
 ip address 135.5.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0
 ip address 135.5.21.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 60
 dialer fast-idle 10000
 dialer map ip 135.5.21.2 name R2 broadcast 0352051090 dialer-group 1 isdn
switch-type ntt ppp authentication pap ppp pap sent-username R1 password
7
05080F1C2243 ! interface Serial0/0 ip address 135.5.13.1 255.255.255.0 no
fair-queue clockrate 64000 ! interface FastEthernet0/1 no ip address
shutdown duplex auto speed auto ! router ospf 110 router-id 135.5.1.1
log-adjacency-changes network 135.5.1.0 0.0.0.255 area 0 network
135.5.13.0 0.0.0.255 area 0 network 135.5.21.0 0.0.0.255 area 0 ! ip
classless ip http server !
access-list 100 deny ospf any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
end

R2#sh run
Building configuration...

Current configuration : 1490 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
username R1 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type ntt
!
!
!
interface Loopback0
 ip address 135.5.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 135.5.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0
 ip address 135.5.21.2 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 60
 dialer fast-idle 1000
 dialer map ip 135.5.13.0 name R1 broadcast 0352051089
 dialer map ip 135.5.21.1 name R1 broadcast 0352051089
 dialer watch-group 10
 dialer-group 1
 isdn switch-type ntt
 ppp authentication pap
 ppp pap sent-username R2 password 7 121A0C041104
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 110
 router-id 135.5.2.2
 log-adjacency-changes
 network 135.5.2.0 0.0.0.255 area 0
 network 135.5.21.0 0.0.0.255 area 0
 network 135.5.23.0 0.0.0.255 area 0
!
ip classless
ip http server
!
access-list 100 deny ospf any any
access-list 100 permit ip any any
dialer watch-list 10 ip 135.5.1.0 255.255.255.0
dialer watch-list 10 ip 135.5.3.0 255.255.255.0
dialer watch-list 10 ip 135.5.13.0 255.255.255.0
dialer-list 1 protocol ip list 100
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
end

R3#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Loopback0
 ip address 135.5.3.3 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 135.5.23.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 135.5.13.3 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 110
 router-id 135.5.3.3
 network 135.5.3.0 0.0.0.255 area 0
 network 135.5.13.0 0.0.0.255 area 0
 network 135.5.23.0 0.0.0.255 area 0
!
ip classless
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
!
end

Frank

This message and any attachments (the "message") is
intended solely for the addressees and is confidential.
If you receive this message in error, please delete it and immediately
notify the sender. Any use not in accord with its purpose, any
dissemination
or disclosure, either whole or partial, is prohibited except formal
approval. The internet can not guarantee the integrity of this message. BNP
PARIBAS (and its subsidiaries) shall (will) not therefore be liable for the
message if modified.

                ---------------------------------------------

Ce message et toutes les pieces jointes (ci-apres le
"message") sont etablis a l'intention exclusive de ses destinataires et
sont
confidentiels. Si vous recevez ce message par erreur, merci de le detruire
et d'en avertir immediatement l'expediteur. Toute utilisation de ce message
non conforme a sa destination, toute diffusion ou toute publication, totale
ou partielle, est interdite, sauf autorisation expresse. L'internet ne
permettant pas d'assurer l'integrite de ce message, BNP PARIBAS (et ses
filiales) decline(nt) toute responsabilite au titre de ce message, dans
l'hypothese ou il aurait ete modifie.

This message and any attachments (the "message") is
intended solely for the addressees and is confidential.
If you receive this message in error, please delete it and immediately
notify the sender. Any use not in accord with its purpose, any
dissemination
or disclosure, either whole or partial, is prohibited except formal
approval. The internet can not guarantee the integrity of this message. BNP
PARIBAS (and its subsidiaries) shall (will) not therefore be liable for the
message if modified.

                ---------------------------------------------

Ce message et toutes les pieces jointes (ci-apres le
"message") sont etablis a l'intention exclusive de ses destinataires et
sont
confidentiels. Si vous recevez ce message par erreur, merci de le detruire
et d'en avertir immediatement l'expediteur. Toute utilisation de ce message
non conforme a sa destination, toute diffusion ou toute publication, totale
ou partielle, est interdite, sauf autorisation expresse. L'internet ne
permettant pas d'assurer l'integrite de ce message, BNP PARIBAS (et ses
filiales) decline(nt) toute responsabilite au titre de ce message, dans
l'hypothese ou il aurait ete modifie.

This message and any attachments (the "message") is
intended solely for the addressees and is confidential.
If you receive this message in error, please delete it and
immediately notify the sender. Any use not in accord with
its purpose, any dissemination or disclosure, either whole
or partial, is prohibited except formal approval. The internet can not
guarantee the integrity of this message.
BNP PARIBAS (and its subsidiaries) shall (will) not
therefore be liable for the message if modified.

                ---------------------------------------------

Ce message et toutes les pieces jointes (ci-apres le
"message") sont etablis a l'intention exclusive de ses
destinataires et sont confidentiels. Si vous recevez ce
message par erreur, merci de le detruire et d'en avertir
immediatement l'expediteur. Toute utilisation de ce
message non conforme a sa destination, toute diffusion
ou toute publication, totale ou partielle, est interdite, sauf
autorisation expresse. L'internet ne permettant pas
d'assurer l'integrite de ce message, BNP PARIBAS (et ses
filiales) decline(nt) toute responsabilite au titre de ce
message, dans l'hypothese ou il aurait ete modifie.

This message and any attachments (the "message") is
intended solely for the addressees and is confidential.
If you receive this message in error, please delete it and
immediately notify the sender. Any use not in accord with
its purpose, any dissemination or disclosure, either whole
or partial, is prohibited except formal approval. The internet
can not guarantee the integrity of this message.
BNP PARIBAS (and its subsidiaries) shall (will) not
therefore be liable for the message if modified.

                ---------------------------------------------

Ce message et toutes les pieces jointes (ci-apres le
"message") sont etablis a l'intention exclusive de ses
destinataires et sont confidentiels. Si vous recevez ce
message par erreur, merci de le detruire et d'en avertir
immediatement l'expediteur. Toute utilisation de ce
message non conforme a sa destination, toute diffusion
ou toute publication, totale ou partielle, est interdite, sauf
autorisation expresse. L'internet ne permettant pas
d'assurer l'integrite de ce message, BNP PARIBAS (et ses
filiales) decline(nt) toute responsabilite au titre de ce
message, dans l'hypothese ou il aurait ete modifie.



This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:23:00 GMT-3