From: Adam Crisp (adam.crisp@totalise.co.uk)
Date: Mon Nov 04 2002 - 10:32:07 GMT-3
hello,
I have a cat 2924XL connected to a 3550.
the terminology for the 2924XL is "port group"
the terminology for the 3550 is "ether-channel port-channel"
port fast 0/15 on the 2924XL is connected to fast 0/15 on the 3550
port fast 0/16 on the 2924XL is connected to fast 0/16 on the 3550
I have chosen to use 802.1Q trunking - because I prefer is personally - It's
much better ;-)
how to config:
2924XL:
!
cat2924xl#show run int fast 0/15
Building configuration...
Current configuration:
!
interface FastEthernet0/15
duplex full
speed 100
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
end
cat2924xl#show run int fast 0/16
Building configuration...
Current configuration:
!
interface FastEthernet0/16
duplex full
speed 100
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
end
cat2924xl#show port gr
cat2924xl#show port group
Group Interface Transmit Distribution
----- --------------------- ---------------------
1 FastEthernet0/15 source address
1 FastEthernet0/16 source address
cat2924xl#!
cat2924xl#show mac-address-table
Dynamic Address Count: 22
Secure Address Count: 0
Static Address (User-defined) Count: 0
System Self Address Count: 50
Total MAC addresses: 72
Maximum MAC addresses: 8192
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
0000.0c76.3504 Dynamic 20 FastEthernet0/7
0002.4bd3.16e1 Dynamic 50 FastEthernet0/19
0004.27ef.27fe Dynamic 254 FastEthernet0/24
000a.8af2.7d00 Dynamic 30 FastEthernet0/16
000a.8af2.7d00 Dynamic 90 FastEthernet0/15
000a.8af2.7d00 Dynamic 254 FastEthernet0/16
000a.8af2.7d0f Dynamic 1 FastEthernet0/16
000a.8af2.7d10 Dynamic 1 FastEthernet0/15
0010.4bfe.f5bf Dynamic 90 FastEthernet0/16
0010.5a36.c69f Dynamic 30 FastEthernet0/15
0010.7b80.43b3 Dynamic 10 FastEthernet0/3
0010.7b81.1f53 Dynamic 10 FastEthernet0/2
0010.7b81.86a6 Dynamic 50 FastEthernet0/17
0010.7b81.86a7 Dynamic 40 FastEthernet0/13
0050.5477.9080 Dynamic 254 FastEthernet0/22
0050.5477.9090 Dynamic 10 FastEthernet0/1
0050.7347.5480 Dynamic 1 FastEthernet0/5
0050.7347.5481 Dynamic 1 FastEthernet0/9
0050.7347.5481 Dynamic 30 FastEthernet0/9
0050.7347.5481 Dynamic 90 FastEthernet0/9
00d0.bbd4.3c61 Dynamic 50 FastEthernet0/18
cat2924xl#
As you can see destination MAC's are spread accross the "port group"
Now for the 3550
!
interface FastEthernet0/15
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet0/15
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
end
Cat3550#show run int fast 0/16
Building configuration...
Current configuration : 159 bytes
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
end
Cat3550#
Cat3550#show etherchannel port-channel
Channel-group listing:
-----------------------
Group: 1
----------
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 00d:00h:10m:59s
Logical slot/port = 1/0 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Ports in the Port-channel:
Index Load Port EC state
------+------+------+------------
0 00 Fa0/15 on
0 00 Fa0/16 on
Time since last port bundled: 00d:00h:10m:27s Fa0/15
Cat3550#
Cat3550#show mac-address-table dynamic
Mac Address Table
------------------------------------------
Vlan Mac Address Type Ports
---- ----------- ---- -----
30 0010.5a36.c69f DYNAMIC Fa0/2
30 0030.7176.8610 DYNAMIC Po1
30 0050.7347.5481 DYNAMIC Po1
90 0010.4bfe.f5bf DYNAMIC Fa0/1
90 0030.7176.8610 DYNAMIC Po1
90 0050.7347.5481 DYNAMIC Po1
110 00d0.bbd4.3c62 DYNAMIC Fa0/21
1 0030.7176.860f DYNAMIC Po1
1 0030.7176.8610 DYNAMIC Po1
1 0050.7347.5480 DYNAMIC Po1
1 0050.7347.5481 DYNAMIC Po1
10 0010.7b80.43b3 DYNAMIC Po1
10 0010.7b81.1f53 DYNAMIC Po1
10 0030.7176.8610 DYNAMIC Po1
10 0050.5477.9090 DYNAMIC Po1
20 0000.0c76.3504 DYNAMIC Po1
20 0030.7176.8610 DYNAMIC Po1
40 0010.7b81.86a7 DYNAMIC Po1
40 0030.7176.8610 DYNAMIC Po1
50 0002.4bd3.16e1 DYNAMIC Po1
50 0010.7b81.86a6 DYNAMIC Po1
50 0030.7176.8610 DYNAMIC Po1
50 00d0.bbd4.3c61 DYNAMIC Po1
60 0030.7176.8610 DYNAMIC Po1
70 0030.7176.8610 DYNAMIC Po1
80 0030.7176.8610 DYNAMIC Po1
100 0030.7176.8610 DYNAMIC Po1
254 0004.27ef.27fe DYNAMIC Po1
254 0030.7176.8600 DYNAMIC Po1
254 0030.7176.8610 DYNAMIC Po1
254 0050.5477.9080 DYNAMIC Po1
Total Mac Addresses for this criterion: 31
Cat3550#
!
!
As you can see destination MAC's are spread over the "Po1" ie the 'Po'rt
channel 1
As soon as you type the words " channel-group 1 mode on "
then a new virtual interface is created thus:
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
!
If you conf t into this interface then you are presented with limited
switchport options
Hope this helps
Adam
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Angelo De Guzman
Sent: 04 November 2002 12:11
To: ccielab@groupstudy.com
Subject: 3550 (etherchannel) trunking
Hi,
Does 3550 supports etherchannel trunking?
I can't make this work? I'm using two 3550 routers.
A config would be fine..
Thanks,
Angelo
This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:22:52 GMT-3