From: Banlan Chen (banlan.chen@lycos.com)
Date: Wed Oct 16 2002 - 11:49:40 GMT-3
Hi Allen,
Thank you for your reply. I also think it should be working. But it does not work in my lab. Could you help me out?
Part of my lab scenario as follow:
r1-----r3-----r5
FR HDLC
hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
ip address 172.16.2.3 255.255.255.0
encapsulation frame-relay
ip ospf message-digest-key 1 md5 7 cisco
ip ospf network non-broadcast
frame-relay map ip 172.16.2.4 321 broadcast
frame-relay map ip 172.16.2.1 321 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1
ip address 192.168.2.2 255.255.255.0 (ip unnumbered Ethernet0)
!
router ospf 3
log-adjacency-changes
area 0 authentication message-digest
area 2 virtual-link 5.5.5.5 message-digest-key 1 md5 7 cisco
network 3.3.3.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 2
network 192.168.3.0 0.0.0.255 area 2
neighbor 172.16.2.1 priority 100
!
ip kerberos source-interface any
ip classless
no ip http server
hostname R5
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
cns event-service server
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface Ethernet0
ip address 192.168.5.1 255.255.255.0
no keepalive
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
fair-queue
clockrate 4000000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0 (ip unnumbered Serial0)
clockrate 4000000
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
!
router ospf 5
log-adjacency-changes
area 0 authentication message-digest
area 2 virtual-link 4.4.4.4 message-digest-key 1 md5 7 cisco
area 2 virtual-link 3.3.3.3 message-digest-key 1 md5 7 cisco
network 192.168.1.0 0.0.0.255 area 2
network 192.168.2.0 0.0.0.255 area 2
network 192.168.5.0 0.0.0.255 area 3
!
ip kerberos source-interface any
ip classless
no ip http server
After I chang the int to ip unnumbered,
On R3:
R3#sh ip ospf virtual-links
Virtual Link OSPF_VL0 to router 5.5.5.5 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 2, via interface Serial1, Cost of using 128
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Message digest authentication enabled
Youngest key id is 1
On R5:
R5#sh ip ospf virtual-links
Virtual Link OSPF_VL1 to router 4.4.4.4 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 2, via interface Serial0, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:04
Adjacency State FULL (Hello suppressed)
Index 2/4, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
Message digest authentication enabled
Youngest key id is 1
Virtual Link OSPF_VL0 to router 3.3.3.3 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 2, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
From R3, I can see the routes from R5, so the unnumbered link is working.
Thank very much
Banlan
--On Tue, 15 Oct 2002 15:38:11 McClure, Allen wrote: >I believe you can since VL's use the RID's as "endpoints" and the >neighbor relationship can be established. The only thing odd is that it >uses the MIBII ifIndex as the router link data in the Router Link LSA. > >Check this out >http://www.cisco.com/en/US/customer/tech/tk648/tk365/technologies_white_ >paper09186a00800943a5.shtml > >Nothing specific about Virtual Links, but it stands to reason that they >would work fine. > >I may try this if I get time. > >Allen McClure >MCSE, CCNP, CCDP >YUM! Brands, Inc. >Sr. Network Analyst >NEW E-Mail - mailto:allen.mcclure@yum.com >972-338-7494 > > >-----Original Message----- >From: Banlan Chen [mailto:banlan.chen@lycos.com] >Sent: Tuesday, October 15, 2002 2:54 PM >To: ccielab@groupstudy.com >Subject: ip unnumber and virtual link > > >Hi Group, > >Can I use ip unnumbered link as an OSPF virtual link? > >Thanks advance. > >Banlan > > >____________________________________________________________ >Watch a championship game with Elway or McGwire. >Enter Now at http://champions.lycos.com > > >This communication is confidential and may be legally privileged. If you are not the intended recipient, (i) please do not read or disclose to others, (ii) please notify the sender by reply mail, and (iii) please delete this communication from your system. Failure to follow this process may be unlawful. Thank you for your cooperation. >
This archive was generated by hypermail 2.1.4 : Tue Nov 05 2002 - 08:35:48 GMT-3