Re: Help! ipx irb over serial link

From: ying c (bf5tgh1@yahoo.com)
Date: Tue Oct 08 2002 - 11:01:08 GMT-3


Hi Donny,

Thanks for taking time to check my problem. There's
nothing wrong in my config, it's one of these things
that I have to throw my hands up. Please see below
which I just created this morning with 4 different
routers, works as I expected:

toplogy:

r1(irb)--bg1--r2(bridge)--bg1--r3(bridge)--bg1--r4
        
r1: irb, have netw 123, 100
r2, r3: bridges
r4: router, have netw 123, 400

r1 and r2 are in vlan 12
r2 and r3 are interconnected by atm pvc 3/33
r3 and r4 are in vlan 34

Goal: ping between r1 and r4 across bridge network

r1# (irb router)

version 12.1
!
hostname r1
!
ipx routing 0001.0001.0001
!
!
bridge irb
!
!
interface Loopback0
 no ip address
 ipx network 100
!
interface FastEthernet0/0
 mac-address 0001.0001.0001
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface BVI1
 no ip address
 ipx network 123
!
!
bridge 1 protocol ieee
 bridge 1 route ipx
--------------------------------
r2# (bridge #1, no ipx routing)
!
version 12.1
!
hostname r2
!
interface FastEthernet0/0
 mac-address 0002.0002.0002
 no ip address
 duplex half
 bridge-group 1
!
!
interface ATM6/0
 no ip address
 atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc 3/33
 !
 bridge-group 1
!
bridge 1 protocol ieee
!
-------------------------
r3# (bridge #2, no ipx routing)
!
version 12.2
!
hostname r3
!
!
interface FastEthernet0/0
 mac-address 0003.0003.0003
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface ATM3/0
 no ip address
 atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc 3/33
 !
 bridge-group 1
!
bridge 1 protocol ieee
!
-----------------------------
r4# (end router)
version 12.2
!
hostname r4
!
ipx routing 0004.0004.0004
!
call rsvp-sync
!
!
interface Loopback0
 no ip address
 ipx network 400
!
interface FastEthernet0/0
 mac-address 0004.0004.0004
 no ip address
 duplex auto
 speed auto
 ipx network 123
!
---------------------------
output:
r1#ping 123.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to
123.0004.0004.0004, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/2/4 ms
r1#ping 400.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to
400.0004.0004.0004, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/4/4 ms
r1#sh span

 Bridge group 1 is executing the ieee compatible
Spanning Tree protocol
  Bridge Identifier has priority 32768, address
0001.0001.0001
  Configured hello time 2, max age 20, forward delay
15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 10 last change occurred
00:02:20 ago
          from FastEthernet0/0
  Times: hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 1, topology change 0, notification 0,
aging 300

 Port 3 (FastEthernet0/0) of Bridge group 1 is
forwarding
   Port path cost 19, Port priority 128, Port
Identifier 128.3.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0001.0001.0001
   Designated port id is 128.3, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 33912, received 22

r1#sh bridge

Total of 300 station blocks, 299 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX
count TX count
0004.0004.0004 forward FastEthernet0/0 0
15 10
r1#
r2#sh span

 Bridge group 1 is executing the ieee compatible
Spanning Tree protocol
  Bridge Identifier has priority 32768, address
0002.0002.0002
  Configured hello time 2, max age 20, forward delay
15
  Current root has priority 32768, address
0001.0001.0001
  Root port is 3 (FastEthernet0/0), cost of root path
is 38
  Topology change flag not set, detected flag not set
  Number of topology changes 5 last change occurred
00:02:31 ago
          from ATM6/0
  Times: hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0,
aging 300

 Port 3 (FastEthernet0/0) of Bridge group 1 is
forwarding
   Port path cost 19, Port priority 128, Port
Identifier 128.3.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0002.4b28.11c1
   Designated port id is 128.13, designated path cost
19
   Timers: message age 3, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 6, received 33786

 Port 7 (ATM6/0) of Bridge group 1 is forwarding
   Port path cost 39, Port priority 128, Port
Identifier 128.7.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0002.0002.0002
   Designated port id is 128.7, designated path cost
38
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 33513, received 3

r2#sh bridge

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX
count TX count
0001.0001.0001 forward FastEthernet0/0 0
14 11
0004.0004.0004 forward ATM6/0 0
14 10
r2#
r3#sh span

 Bridge group 1 is executing the ieee compatible
Spanning Tree protocol
  Bridge Identifier has priority 32768, address
0003.0003.0003
  Configured hello time 2, max age 20, forward delay
15
  Current root has priority 32768, address
0001.0001.0001
  Root port is 7 (ATM3/0), cost of root path is 77
  Topology change flag not set, detected flag not set
  Number of topology changes 4 last change occurred
00:03:00 ago
          from FastEthernet0/0
  Times: hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0,
aging 300

 Port 4 (FastEthernet0/0) of Bridge group 1 is
forwarding
   Port path cost 19, Port priority 128, Port
Identifier 128.4.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0003.0003.0003
   Designated port id is 128.4, designated path cost
77
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 642, received 30

 Port 7 (ATM3/0) of Bridge group 1 is forwarding
          
r3#term len 0
r3#sh span

 Bridge group 1 is executing the ieee compatible
Spanning Tree protocol
  Bridge Identifier has priority 32768, address
0003.0003.0003
  Configured hello time 2, max age 20, forward delay
15
  Current root has priority 32768, address
0001.0001.0001
  Root port is 7 (ATM3/0), cost of root path is 77
  Topology change flag not set, detected flag not set
  Number of topology changes 4 last change occurred
00:03:07 ago
          from FastEthernet0/0
  Times: hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0,
aging 300

 Port 4 (FastEthernet0/0) of Bridge group 1 is
forwarding
   Port path cost 19, Port priority 128, Port
Identifier 128.4.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0003.0003.0003
   Designated port id is 128.4, designated path cost
77
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 645, received 30

 Port 7 (ATM3/0) of Bridge group 1 is forwarding
   Port path cost 39, Port priority 128, Port
Identifier 128.7.
   Designated root has priority 32768, address
0001.0001.0001
   Designated bridge has priority 32768, address
0002.0002.0002
   Designated port id is 128.7, designated path cost
38
   Timers: message age 4, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 31, received 642

r3#sh bridge

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX
count TX count
0001.0001.0001 forward ATM3/0 0
15 11
0004.0004.0004 forward FastEthernet0/0 0
14 10
r3#
r4#sh ipx route
Codes: C - Connected primary network, c - Connected
secondary network
       S - Static, F - Floating static, L - Local
(internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A -
Aggregate
       s - seconds, u - uses, U - Per-user static

3 Total IPX routes. Up to 1 parallel paths and 16 hops
allowed.

No default route known.

C 123 (NOVELL-ETHER), Fa0/0
C 400 (UNKNOWN), Lo0
R 100 [03/01] via 123.0001.0001.0001,
39s, Fa0/0
r4#ping 123.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to
123.0001.0001.0001, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/3/4 ms
r4#ping 100.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to
100.0001.0001.0001, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/3/4 ms
r4#sh bridge
r4#sh span

No spanning tree instances exist.

r4#

--- Donny MATEO <donny.mateo@sg.ca-indosuez.com>
wrote:
> not sure,
> but try to configure bridge irb on rtr6 as well,
> and configure the appropriate no bridge 1 route
> ipx, bridge1 bridge ipx command and see where that
> lend you.
> let us know.
>
> Donny
>
>
>
>
>
> ying c
>
>
> <bf5tgh1@yahoo.co To:
> ccielab@groupstudy.com
>
> m> cc:
>
>
> Sent by:
> Subject: Help! ipx irb over serial link
>
> nobody@groupstudy
>
>
> .com
>
>
>
>
>
>
>
>
> 08-10-2002 08:28
>
>
> Please respond to
>
>
> ying c
>
>
>
>
>
>
>
>
>
>
>
>
> Hi,
>
> I thought I had this worked a while back, but I'm no
> longer sure as I'm completely blind now. Below is
> the
> topology and the configs.
>
> Thanks,
> Chang
>
> Topology
>
> R8---serial bg2-R6---ether bg2----r9--bvi2
>
> R8: just a router simulate an end station
> R6: bridge, no ipx routing
> R9: irb
> Goal: ping from R8's s1/0 to R9's BVI
> =============================================
>
> Router configs
>
> R8 - end station:
>
> ipx routing 0008.0008.0008
> !
> interface Serial1/0
> ipx network 800
> !
> !
>
>
> R6 - bridge:
>
> !
> interface Ethernet0
> bridge-group 2
> !
> interface Serial0
> bridge-group 2
> !
>
> R9 - irb router:
>
> ipx routing 00e0.1ea9.bf64
> !
> bridge irb
> !
> interface Ethernet0
> bridge-group 2
> !
> interface BVI2
> ipx network 800
> !
> !
> bridge 2 route ipx
> ---------------------------
> Output:
>
> R8:
> r8#sh ipx int s1/0
> Serial1/0 is up, line protocol is up
> IPX address is 800.0008.0008.0008 [up]
> ============================
> R6:
> r6#sh span
>
> Bridge group 2 is executing the IEEE compatible
> Spanning Tree protocol
> Bridge Identifier has priority 32768, address
> 0000.0c07.ac01
> Configured hello time 2, max age 20, forward delay
> 15
> We are the root of the spanning tree
> Port Number size is 9
> Topology change flag not set, detected flag not
> set
> Times: hold 1, topology change 35, notification 2
> hello 2, max age 20, forward delay 15
> Timers: hello 0, topology change 0, notification 0
> bridge aging time 300
>
> Port 2 (Ethernet0) of Bridge group 2 is forwarding
> Port path cost 100, Port priority 128
> Designated root has priority 32768, address
> 0000.0c07.ac01
> Designated bridge has priority 32768, address
> 0000.0c07.ac01
> Designated port is 2, path cost 0
> Timers: message age 0, forward delay 0, hold 0
> BPDU: sent 1464, received 1
>
> Port 6 (Serial0) of Bridge group 2 is forwarding
> Port path cost 647, Port priority 128
> Designated root has priority 32768, address
> 0000.0c07.ac01
> Designated bridge has priority 32768, address
> 0000.0c07.ac01
> Designated port is 6, path cost 0
> Timers: message age 0, forward delay 0, hold 0
> BPDU: sent 1466, received 2
>
> r6#sh ipx int brief
> %IPX not running
> r6#sh bridge
>
> Total of 300 station blocks, 297 free
> Codes: P - permanent, S - self
>
> Bridge Group 2:
>
> Address Action Interface Age RX
> count TX count
> 0000.0c38.888e forward Ethernet0 0
> 214 0
> 0060.2f19.b439 forward Ethernet0 0
> 150 0
> r6#
> ==================================================
> r9#sh bridge
>
> Total of 300 station blocks, 297 free
> Codes: P - permanent, S - self
>
> Bridge Group 2:
>
> Address Action Interface Age RX
> count TX count
> 0000.0c38.888e forward Ethernet0 5
> 239 0
> 0000.0c07.ac01 forward Ethernet0 5
> 99 0
> r9#ping 800.8.8.8
>
> Type escape sequence to abort.
> Sending 5, 100-byte IPX Novell Echoes to
> 800.0008.0008.0008, timeout is 2 seconds:
> .....
> Success rate is 0 percent (0/5)
> r9#
>
>
>
>
>
>
=== message truncated ===



This archive was generated by hypermail 2.1.4 : Tue Nov 05 2002 - 08:35:42 GMT-3