Re: It must be simple, but I need help: Frame Relay physical

From: Nick Shah (nshah@connect.com.au)
Date: Thu Sep 19 2002 - 21:54:20 GMT-3


Song

First step.. The hub config should be something like this (you got it
correct)

interface Serial0
 ip address 50.50.123.1 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 frame-relay map ip 50.50.123.4 100 broadcast
 frame-relay map ip 50.50.123.5 200 broadcast
 frame-relay map ip 50.50.123.6 300 broadcast
 no frame-relay inverse-arp

Spoke 1..

interface Serial0
 ip address 50.50.123.4 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
Frame-relay interface-dlci 104

Spoke 2 ..

interface Serial0
 ip address 50.50.123.5 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
Frame-relay interface-dlci 205

Spoke 3 ...

interface Serial0
 ip address 50.50.123.6 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
Frame-relay interface-dlci 306

On the Frame switch, you should have the following mappings ..

DLCI 100 --- 104
DLCI 200 --- 205
DLCI 300 --- 306

That way, you should be able to ping all spokes from the HUB, and the hub
from all spokes .. (you have to get to this stage atleast to proceed to the
next step)... If you cant ping the HUB from every spokes, you cant proceed
...

Step 2.

access-list 100 permit ip any 50.50.123.0 0.0.0.255

route-map POLICY permit 10
match ip address 100
set ip next-hop 50.50.123.1

ip local policy route-map POLICY

int s0
ip policy route-map POLICY

Perform step 2 on all the 'spoke' routers.

This will serve the purpose of 'map' statements.

ps. I have done all this typing from my 'head' so just check out if any
syntaxes are mistaken.

rgds
Nick
----- Original Message -----
From: "Song Mu" <songmu@yahoo.com>
To: <ccielab@groupstudy.com>
Sent: Friday, September 20, 2002 10:11 AM
Subject: It must be simple, but I need help: Frame Relay physical interface
config

> Hi,
>
> I run out of options for this:
>
> R1 is hub router with 3 Remote: R2, R3, R4.
> Requirments:
> 1. No map statement on any of the remotes
> 2. No subinterface on any of the routers
>
> Here is my hub and one of the remote configs:
> !
> interface Serial0
> ip address 50.50.123.1 255.255.255.0
> encapsulation frame-relay
> no ip route-cache
> no ip mroute-cache
> frame-relay map ip 50.50.123.4 100 broadcast
> frame-relay map ip 50.50.123.5 200 broadcast
> frame-relay map ip 50.50.123.6 300 broadcast
> no frame-relay inverse-arp (it should not be here since the map
> statements, but try it any way)
> no ip split-horizon (tried with it and without it)
> !
> interface Serial0/0
> ip address 50.50.123.4 255.255.255.0
> encapsulation frame-relay
> no fair-queue
> clockrate 800000
> no ip split-horizon (tried with it and without it)
> frame-relay interface-dlci 100
> !
> I always can ping the remotes (all pvcs are active), but not the host
> from any of the remotes. No any routing protocols on these routers.
> Turned on both debug ip icmp and debug ip packet during the ping from
> remotes and no any information on both host and remote (meaning no
> packet been send to the host and no receive from the host neither).
>
> Thanks,
>
> Song
>
> __________________________________________________
> Do you Yahoo!?
> New DSL Internet Access from SBC & Yahoo!
> http://sbc.yahoo.com



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:43:57 GMT-3