Strange IGRP behaivour of not?

From: Dimitris Vassilopoulos (Dimitris.Vassilopoulos@eurodyn.com)
Date: Thu Sep 12 2002 - 07:32:45 GMT-3


Hello all,

The whole issue is about the RIP/IGRP sending and accepting routes...

Here is the topology:

  R1 ------- R2 -------- R4
 (rip) (rip&igrp) (igrp)

R1

!
interface Loopback0
 ip address 200.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface Loopback10
 description SIM TOK-RING
 ip address 150.50.18.1 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 150.50.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 150.50.17.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!!
router rip
 redistribute connected metric 2
 network 150.50.0.0
 distribute-list 1 out Serial0
!
ip classless
!
access-list 1 permit 150.50.200.0 0.0.0.255
access-list 1 permit 150.50.18.0 0.0.0.255
access-list 1 permit 200.0.0.0 0.0.0.255
!

R2

!
interface Loopback0
 ip address 200.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface Serial0/0
 ip address 150.50.17.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 148000
!
interface Serial0/1
 bandwidth 128
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 2000000
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial0/1.24 point-to-point
 ip address 150.50.24.2 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 104
!
interface Serial0/1.256 multipoint
 ip address 150.50.100.2 255.255.255.224
 no ip directed-broadcast
 frame-relay map ip 150.50.100.5 105 broadcast
 frame-relay map ip 150.50.100.6 106 broadcast
!
router rip
 redistribute connected metric 3
 network 150.50.0.0
!
router igrp 10
 redistribute connected metric 1000 100 1 255 1500
 network 150.50.0.0
!
ip classless
!

R4

interface Loopback0
 ip address 200.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.4 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 150.50.24.4 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
frame-relay map ip 150.50.24.2 401 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FR-ATM20
 no ip address
 no ip directed-broadcast
 shutdown
!
router igrp 10
 redistribute connected metric 100 1 225 1 1500
 network 150.50.0.0
 distribute-list 1 out Serial0
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 200.0.0.0 0.0.0.255

Looking at the routing tables, I see:
======================================================
R1#sh ip rou
.
.

Gateway of last resort is not set

     200.0.0.0/32 is subnetted, 1 subnets
C 200.0.0.1 is directly connected, Loopback0
     150.50.0.0/24 is subnetted, 4 subnets
C 150.50.200.0 is directly connected, Ethernet0
C 150.50.17.0 is directly connected, Serial0
C 150.50.18.0 is directly connected, Loopback10
R 150.50.24.0 [120/1] via 150.50.17.2, 00:00:27, Serial0
R1#
======================================================
R2#sh ip rou
.
.

Gateway of last resort is not set

     200.0.0.0/24 is variably subnetted, 2 subnets, 2 masks
I 200.0.0.0/24 [100/80625] via 150.50.24.4, 00:00:04, Serial0/1.24

C 200.0.0.2/32 is directly connected, Loopback0
I 10.0.0.0/8 [100/80225] via 150.50.24.4, 00:00:04, Serial0/1.24
     150.50.0.0/16 is variably subnetted, 5 subnets, 2 masks
R 150.50.200.0/24 [120/1] via 150.50.17.1, 00:00:05, Serial0/0
C 150.50.17.0/24 is directly connected, Serial0/0
R 150.50.18.0/24 [120/1] via 150.50.17.1, 00:00:05, Serial0/0
C 150.50.24.0/24 is directly connected, Serial0/1.24
C 150.50.100.0/27 is directly connected, Serial0/1.256
R2#
======================================================
R4#sh ip rou
.
.

Gateway of last resort is not set

     200.0.0.0/24 is variably subnetted, 2 subnets, 2 masks
I 200.0.0.0/24 [100/8976] via 150.50.24.2, 00:01:30, Serial0
C 200.0.0.4/32 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0
     150.50.0.0/24 is subnetted, 2 subnets
I 150.50.17.0 [100/12100] via 150.50.24.2, 00:00:19, Serial0
C 150.50.24.0 is directly connected, Serial0
R4#
======================================================

My question is:

Since both R1 and R4 get an advertisement about 200.0.0.0 from R2, and
both have
loopbacks with ip addresses on 200.0.0.0, why RIP (correctly) drops the
200.0.0.0/24
route, while IGRP installs it in it's routing table?

Thanks.

Dimitris



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:43:49 GMT-3