From: Colin Barber (Colin.Barber@xxxxxxxxxxxxxx)
Date: Mon Aug 26 2002 - 05:39:22 GMT-3
You don't appear to have pim enabled on the loopback interfaces.
Colin
-----Original Message-----
From: Bruce Williams [mailto:bwilliams175@comcast.net]
Sent: 26 August 2002 03:32
To: D. J. Jones; Bruce Williams; Ccielab@Groupstudy. Com
Subject: RE: Multicast Problems
Here is the output of sh ip mroute on r1 and I pasted the relevant configs
for r1, r2, r3 and r4. I see what you mean about the prune flag. I also
noticed that r1 is not even forwarding multicasts to the point to point
interface to r3.
Let me know what you think. Thanks!
sh ip mroute on R1
(*, 239.10.10.10), 00:00:10/00:02:59, RP 172.16.101.1, flags: SP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
(172.16.13.1, 239.10.10.10), 00:00:10/00:02:49, flags: P
Incoming interface: Serial1/0.13, RPF nbr 172.16.13.3, Registering
Outgoing interface list: Null
R1 CONFIG
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
ip ospf interface-retry 0
ip igmp join-group 239.10.10.10
!
!
i
!
interface Serial1/0.13 point-to-point
ip address 172.16.13.1 255.255.255.0
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
ip ospf network non-broadcast
ip ospf interface-retry 0
ip ospf priority 0
ipx network 13
frame-relay interface-dlci 103
!
interface Serial1/0.124 multipoint
ip address 172.16.124.1 255.255.255.0
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
ip ospf network non-broadcast
ip ospf interface-retry 0
ip ospf priority 100
ipx network 124
no ipx split-horizon eigrp 1
frame-relay map ipx 124.0200.0200.0200 102 broadcast
frame-relay map ipx 124.0400.0400.0400 104 broadcast
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.4 104 broadcast
!
router ospf 1
router-id 172.16.101.1
area 33 virtual-link 172.16.103.1
redistribute connected subnets route-map connected
redistribute igrp 1 subnets route-map igrp2ospf
network 172.16.12.0 0.0.0.255 area 12
network 172.16.13.0 0.0.0.255 area 33
network 172.16.101.0 0.0.0.255 area 0
network 172.16.124.0 0.0.0.255 area 0
neighbor 172.16.124.2
neighbor 172.16.124.4
!
router igrp 1
passive-interface default
network 172.16.0.0
distribute-list 1 in
distance 113
!
!
ip classless
ip pim rp-address 172.16.101.1
ip pim send-rp-announce Loopback0 scope 16 group-list 97
ip pim send-rp-discovery scope 16
!
access-list 97 permit 239.10.10.10
R2 CONFIG
interface Loopback0
ip address 172.16.102.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
ip ospf interface-retry 0
ip igmp join-group 239.10.10.10
!
interface Serial1/0
ip address 172.16.124.2 255.255.255.0
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf interface-retry 0
ip ospf priority 0
ipx input-sap-filter 1000
ipx network 124
frame-relay map ipx 124.0100.0100.0100 201 broadcast
frame-relay map ipx 124.0400.0400.0400 201 broadcast
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.4 201 broadcast
no frame-relay inverse-arp
!
!
router ospf 1
router-id 172.16.102.1
redistribute rip metric 1 subnets route-map rip2ospf
network 172.16.12.0 0.0.0.255 area 12
network 172.16.102.0 0.0.0.255 area 0
network 172.16.124.0 0.0.0.255 area 0
!
!
ip classless
ip pim rp-address 172.16.101.1
ip mroute 172.16.101.1 255.255.255.255 172.16.124.1
!
!
!
R3 CONFIG
!
interface Loopback0
ip address 172.16.103.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
ip ospf interface-retry 0
ip igmp join-group 239.10.10.10
!
interface Loopback255
ip address 172.16.255.1 255.255.255.240
no ip directed-broadcast
ip ospf network point-to-point
ip ospf interface-retry 0
!
!
i
interface Serial0
ip address 172.16.13.3 255.255.255.0
no ip directed-broadcast
ip nat outside
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf interface-retry 0
ip ospf priority 100
no ip mroute-cache
ipx network 13
no fair-queue
frame-relay map ip 172.16.13.1 301 broadcast
frame-relay map ipx 13.0100.0100.0100 301 broadcast
no frame-relay inverse-arp
!
!
router ospf 1
router-id 172.16.103.1
area 33 virtual-link 172.16.101.1
area 44 range 172.16.255.0 255.255.255.0
redistribute connected metric-type 1 subnets route-map connected
redistribute bgp 111
network 172.16.13.0 0.0.0.255 area 33
network 172.16.103.0 0.0.0.255 area 33
network 172.16.255.0 0.0.0.15 area 44
neighbor 172.16.13.1
!
ip pim rp-address 172.16.101.1
ip mroute 172.16.101.1 255.255.255.255 172.16.13.1
R4 CONFIG
!
interface Loopback0
ip address 172.16.104.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
ip ospf interface-retry 0
ip igmp join-group 239.10.10.10
!
interface Serial0/0
ip address 172.16.124.4 255.255.255.0
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf interface-retry 0
ip ospf priority 0
no ip mroute-cache
ipx network 124
no fair-queue
frame-relay map ipx 124.0100.0100.0100 401 broadcast
frame-relay map ipx 124.0200.0200.0200 401 broadcast
frame-relay map ip 172.16.124.1 401 broadcast
frame-relay map ip 172.16.124.2 401 broadcast
no frame-relay inverse-arp
!
!
router ospf 1
router-id 172.16.104.1
redistribute rip metric 1 subnets route-map rip2ospf
network 172.16.104.0 0.0.0.255 area 0
network 172.16.124.0 0.0.0.255 area 0
!
router rip
redistribute ospf 1 metric 1 match internal external 1 external 2 route-map
osp
f2rip
passive-interface default
network 172.16.0.0
neighbor 172.16.26.6
neighbor 172.16.26.2
distance 109 0.0.0.0 0.0.0.0 26
ip classless
ip pim rp-address 172.16.124.1
ip mroute 172.16.101.1 255.255.255.255 172.16.124.1
!
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
D. J. Jones
Sent: Sunday, August 25, 2002 9:16 PM
To: Bruce Williams; Ccielab@Groupstudy. Com
Subject: Re: Multicast Problems
Please post your config. I note that yu have a duplicate ip address on r3
and r4? I also see
that the Pruned flag is set indicating the outgoing interfaces are Null for
your (S,G) entries.
What do you show on r1?
----- Original Message -----
From: "Bruce Williams" <bruce@williamsnetworking.com>
To: "Ccielab@Groupstudy. Com" <ccielab@groupstudy.com>
Sent: Sunday, August 25, 2002 4:55 PM
Subject: Multicast Problems
> I am trying to configure sparse mode over frame relay.
>
> r1
>
> framerelay
>
> r2 r4 r3
>
> R1 is the rp. The loopbacks on r2, r3 and r4 all have joined group
> 239.10.10.10. I configured ip pim sparse on all the framerelay interfaces.
I
> also configured r1 to be the mapping agent and to announce itself as the
rp
> for the designated group. I see the rp for the correct group on each
router,
> but none of the routers are forwarding multicast to the loopbacks. I
always
> struggle with multicast and I have read Doyle II, but I dont see what I am
> doing wrong. The sho ip mroute shows the same on each router:
>
> R2
> (172.16.124.1, 239.10.10.10), 00:01:39/00:01:20, flags: PFT
> Incoming interface: Serial1/0, RPF nbr 0.0.0.0
> Outgoing interface list: Null
>
> R3
> (172.16.13.1, 239.10.10.10), 00:02:49/00:00:10, flags: PFT
> Incoming interface: Serial0, RPF nbr 0.0.0.0, Registering
> Outgoing interface list: Null
>
> R4
> (172.16.13.1, 239.10.10.10), 00:00:19/00:02:40, flags: PFT
> Incoming interface: Serial0, RPF nbr 0.0.0.0, Registering
> Outgoing interface list: Null
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:37 GMT-3