From: Albert Pak (dejavu3@xxxxxxx)
Date: Wed Aug 14 2002 - 17:42:11 GMT-3
Hello All!
I have an interesting experience with this PPP callback feature on Cisco
2600 routers.
I had setup a simple PPP callback with CHAP with IOS version 12.1.5 on both
Cisco 2600s. When I tried to ping the callback server from the client, the
server does not dial back to the client. It dials back only if I have "debug
dialer" turns on on the client. Here are my configurations on both routers:
The Callback server:
hq#sh run
Building configuration...
version 12.1
!
hostname hq
!
username remote password 0 cisco
!
interface BRI1/2
ip address 172.16.1.1 255.255.255.0
encapsulation ppp
dialer callback-secure
dialer enable-timeout 5
dialer map ip 172.16.1.2 name remote class callback 9851004
dialer hold-queue 100 timeout 10
dialer-group 1
isdn switch-type basic-5ess
isdn spid1 73298510030101
isdn spid2 73298510030102
ppp callback accept
ppp authentication chap
!
map-class dialer callback
dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
end
###############################################################
The Callback client:
remote#sh run
Building configuration...
version 12.1
!
hostname remote
!
username hq password 0 cisco
!
isdn switch-type basic-5ess
!
interface BRI0/0
ip address 172.16.1.2 255.255.255.0
encapsulation ppp
dialer wait-for-carrier-time 10
dialer map ip 172.16.1.1 name hq 9851003
dialer hold-queue 100 timeout 10
dialer-group 1
isdn switch-type basic-5ess
isdn spid1 73298510040101
isdn spid2 73298510040102
ppp callback request
ppp authentication chap
!
dialer-list 1 protocol ip permit
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
end
######################################################################
Here is the debug output:
remote#no debug all
All possible debugging has been turned off
remote#p 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
01:02:148195378344: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:02:34: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 9851003 hq
01:02:146028888068: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to
down.....
Success rate is 0 percent (0/5)
remote#debug dialer
Dial on demand events debugging is on
remote#p 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
01:03:10: BR0/0 DDR: Dialing cause ip (s=172.16.1.2, d=172.16.1.1)
01:03:10: BR0/0 DDR: Attempting to dial 9851003
01:03:45116163240: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up.
01:03:12: BR0/0:1 DDR: Callback negotiated - Disconnecting now
01:03:12: BR0/0:1 DDR: disconnecting call
01:03:12: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 9851003 hq
01:03:12: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 9851003
hq, call lasted 2 seconds
01:03:51539607556: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
01:03:51539607552: DDR: Callback client for hq 9851003 created
01:03:55834574847: BR0/0:1 DDR: disconnecting call..!!
Success rate is 40 percent (2/5), round-trip min/avg/max = 32/741/1451 ms
remote#
01:03:17: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
remote#
01:03:17: BR0/0:1 DDR: Callback received from hq 9851003
01:03:17: DDR: Freeing callback to hq 9851003
01:03:17: BR0/0:1 DDR: dialer protocol up
01:03:17: BR0/0:1 DDR: Call connected, 4 packets unqueued, 4 transmitted, 0
discarded
01:03:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed
state to up
remote#
01:03:23: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 9851003 hq
Hope you would shed some light on this problem.
Thanks,
Albert
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:25 GMT-3