From: ying c (bf5tgh1@xxxxxxxxx)
Date: Sat Aug 10 2002 - 23:29:35 GMT-3
Hi,
I have the following which works fine, but I'm
confused about how to test it properly:
234.5.6.7-e0->r1---fr--->r3---eth--->r5
/
loopback
234.1.1.1-/
234.5.6.7 is a mcaster source. I also created
234.1.1.1 in loopback0. There's no problem to ping
either group from r3, the response always come right
back. But ping from r5 is kind of strange, if I let it
idle for a while, the group will be prunned back, but
if I ping from r3 again and then ping from r5,
everything would be just fine. Is this normal? Adding
'ip igmp join 234.x.x.x' in r5 did not make any
differences, I also truned off ip mroute-cache on all
interfaces.
Thanks,
Chang
============================================
Configurations:
R1:
interface Loopback100
ip address 100.1.1.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 234.1.1.1
!
interface Serial0.1 multipoint
ip address 172.16.10.1 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0
ip address 172.16.32.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 234.5.6.7
ip cgmp
!
ip pim rp-address 100.1.1.1
ip pim accept-rp 100.1.1.1
ip pim send-rp-announce Loopback100 scope 16
ip pim send-rp-discovery Loopback100 scope 16
R3:
!
interface Serial0
ip address 172.16.10.3 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet1
ip address 172.16.35.3 255.255.255.248
ip pim sparse-dense-mode
ip cgmp
R5:
!!
interface Ethernet0/0
ip address 172.16.35.5 255.255.255.248
ip pim sparse-dense-mode
ip cgmp
=====================================================
Output:
r5#ping 234.5.6.7
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.5.6.7, timeout
is 2 seconds:
.
r5#ping 234.1.1.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.1.1.1, timeout
is 2 seconds:
.
r3#ping 234.5.6.7
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.5.6.7, timeout
is 2 seconds:
Reply to request 0 from 172.16.10.1, 88 ms
Reply to request 0 from 172.16.10.1, 148 ms
Reply to request 0 from 172.16.10.1, 132 ms
r3#ping 234.1.1.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.1.1.1, timeout
is 2 seconds:
Reply to request 0 from 172.16.10.1, 100 ms
Reply to request 0 from 172.16.10.1, 148 ms
Reply to request 0 from 172.16.10.1, 132 ms
r3#
r5#ping 234.5.6.7
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.5.6.7, timeout
is 2 seconds:
Reply to request 0 from 172.16.10.1, 137 ms
Reply to request 0 from 172.16.10.1, 165 ms
Reply to request 0 from 172.16.10.1, 153 ms
r5#ping 234.1.1.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.1.1.1, timeout
is 2 seconds:
Reply to request 0 from 172.16.10.1, 108 ms
Reply to request 0 from 172.16.10.1, 136 ms
Reply to request 0 from 172.16.10.1, 120 ms
r5#
================================================
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:22 GMT-3