RE: OSPF Virtual Link Authentication

From: yakout esmat (yesmat@xxxxxxxxxxxxxx)
Date: Wed Jul 31 2002 - 01:49:29 GMT-3


   
When you are authenticating area 0 (which is what you are doing) you need to
authenticate the virtual link to match area 0 authentication type and
password.

In your scenario you are using plain text area 0 authentication, but at the
same time using MD5 virtual link authentication, you will get mismatch
authentication type.

it should be

 area 1 virtual-link 135.4.4.4 authentication-key cisco

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Armand D
Sent: Wednesday, July 31, 2002 2:13 PM
To: ccielab@groupstudy.com
Subject: OSPF Virtual Link Authentication

Hello,

I have two router that need to run ospf MD5
authentication. One of these routers is connected to
area 0 and has a virtual link connected. The Virtual
link needs to run plaintext authentication. However, I
keep getting erros "Rcv pkt from 135.4.34.4, Serial0/0
: Mismatch Authentication Key - Message Digest Key 1"

Does anyone know why I would get these errors ?

Thanks,

Armand

R1
!
interface Loopback0
 ip address 135.4.6.6 255.255.255.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 secure
!
interface Serial0/0
 ip address 135.4.34.6 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf message-digest-key 1 md5 password
 ip ospf network broadcast
   frame-relay map ip 135.4.34.4 604 broadcast
 frame-relay lmi-type cisco
!
router ospf 1
 network 135.4.6.6 0.0.0.0 area 1
 network 135.4.34.0 0.0.0.7 area 1
  area 0 authentication
 area 1 authentication message-digest
 area 1 virtual-link 135.4.4.4 message-digest-key 1
md5 password

==============================

R2

interface Loopback0
 ip address 135.4.4.4 255.255.255.0
 ip ospf message-digest-key 1 md5 password
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0/0.1 multipoint
 ip address 135.4.34.4 255.255.255.248
  ip ospf message-digest-key 1 md5 password
    frame-relay map ip 135.4.34.6 406 broadcast
!
interface Ethernet0/1
  ip address 135.4.24.4 255.255.255.224
 ip ospf authentication-key cisco
!
router ospf 1
 area 0 authentication
 area 1 authentication message-digest
 area 1 virtual-link 135.4.6.6 message-digest-key 1
md5 secure
 network 135.4.4.4 0.0.0.0 area 1
 network 135.4.24.0 0.0.0.31 area 0
 network 135.4.34.0 0.0.0.7 area 1



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:49 GMT-3