From: Peter van Oene (pvo@xxxxxxxxxxxx)
Date: Tue Jul 30 2002 - 14:06:49 GMT-3
I assume you are talking about R3 having trouble reaching networks on R2,
not R1 since R1 and R3 share a common link. If this is the case than you
can either static route R2 toward R1 for the R1/R3 link, or add R1's R1-R3
link into the IGP (usually passively) or have R3 (or R1 for that matter)
advertise the /30 in BGP. I've seen all but the static option in the real
world.
Pete
At 05:01 PM 7/30/2002 +0100, Raj Bahad wrote:
>Hi group,
>
>I'm having trouble with the following scenario:
>
>R2--------R1
> |
> |
> R3
>
>R1 & R2 are in the same AS (100) and R3 is in AS 300. Essentially, when I
>include the link between R1 - R3 in the IGP, R2 has no problems reaching all
>networks on R3. However, if I remove this option and use a "next hop self"
>command pointing to R2, this also is fine. The problem is when R3 tries to
>ping networks on R1...because R1 does not know of the link (192.168.0.0)
>network via its IGP, it is unable to reply to pings. This is because the
>packet leaving R3 has its serial interface (192.168.0.0) as the source
>address. Using extended pings (specifying loopback as source) R3 has full
>reachability with R1.
>
>Is there a way I can get R1 to respond to pings coming from R3 (serial
>interface), without R1 including the R1 - R3 subnet in its IGP?
>
>The config for all three routers has been listed below:
>
>R1#sh run
>
>hostname R1
>!
>interface Loopback0
> ip address 10.10.10.1 255.255.255.255
>!
>interface Ethernet0
> no ip address
>!
>interface Serial0
> ip address 172.16.20.1 255.255.255.252
> clockrate 125000
>!
>interface Serial1
> ip address 192.168.10.1 255.255.255.252
> clockrate 125000
>!
>interface BRI0
> no ip address
> shutdown
>!
>router eigrp 10
> passive-interface Serial1
> network 10.0.0.0
> network 172.16.0.0
> no auto-summary
> no eigrp log-neighbor-changes
>!
>router bgp 100
> no synchronization
> bgp log-neighbor-changes
> network 10.10.10.1 mask 255.255.255.255
> network 172.16.20.0 mask 255.255.255.252
> neighbor 10.10.10.2 remote-as 100
> neighbor 10.10.10.2 update-source Loopback0
> neighbor 10.10.10.2 next-hop-self
> neighbor 192.168.10.2 remote-as 300
>!
>
>R2#sh run
>Building configuration...
>!
>hostname R2
>!
>interface Loopback0
> ip address 10.10.10.2 255.255.255.255
>!
>interface Ethernet0
> no ip address
>!
>interface Serial0
> ip address 172.16.20.2 255.255.255.252
> no ip mroute-cache
>!
>interface Serial1
> no ip address
> shutdown
>!
>interface BRI0
> no ip address
> shutdown
>!
>router eigrp 10
> network 10.0.0.0
> network 172.16.0.0
> no auto-summary
> no eigrp log-neighbor-changes
>!
>router bgp 100
> no synchronization
> bgp log-neighbor-changes
> network 10.10.10.2 mask 255.255.255.255
> neighbor 10.10.10.1 remote-as 100
> neighbor 10.10.10.1 update-source Loopback0
>!
>ip classless
>
>R3#sh run
>Building configuration...
>!
>hostname R3
>!
>interface Loopback0
> ip address 10.10.10.3 255.255.255.255
>!
>interface Loopback1
> ip address 123.123.123.123 255.255.255.0
>!
>interface Loopback2
> ip address 111.111.1.111 255.255.255.0 secondary
> ip address 111.111.2.111 255.255.255.0 secondary
> ip address 111.111.3.111 255.255.255.0 secondary
> ip address 111.111.4.111 255.255.255.0 secondary
> ip address 111.111.5.111 255.255.255.0 secondary
> ip address 111.111.6.111 255.255.255.0 secondary
> ip address 111.111.7.111 255.255.255.0 secondary
> ip address 111.111.8.111 255.255.255.0 secondary
> ip address 111.111.9.111 255.255.255.0 secondary
> ip address 111.111.10.111 255.255.255.0 secondary
> ip address 111.111.0.111 255.255.255.0
>!
>interface Ethernet0
> no ip address
>!
>interface Serial0
> no ip address
> no ip mroute-cache
> shutdown
> no fair-queue
>!
>interface Serial1
> ip address 192.168.10.2 255.255.255.252
>!
>interface BRI0
> no ip address
> shutdown
>!
>router eigrp 10
> passive-interface Serial1
> network 10.0.0.0
> network 192.168.10.0
> no auto-summary
> no eigrp log-neighbor-changes
>!
>router bgp 300
> no synchronization
> bgp log-neighbor-changes
> network 10.10.10.3 mask 255.255.255.255
> network 111.111.0.0 mask 255.255.255.0
> network 111.111.1.0 mask 255.255.255.0
> network 111.111.2.0 mask 255.255.255.0
> network 111.111.3.0 mask 255.255.255.0
> network 111.111.4.0 mask 255.255.255.0
> network 111.111.5.0 mask 255.255.255.0
> network 111.111.6.0 mask 255.255.255.0
> network 111.111.7.0 mask 255.255.255.0
> network 111.111.8.0 mask 255.255.255.0
> network 111.111.9.0 mask 255.255.255.0
> network 111.111.10.0 mask 255.255.255.0
> network 123.123.123.0 mask 255.255.255.0
> neighbor 192.168.10.1 remote-as 100
> no auto-summary
>!
>ip classless
>
>Regards,
>
>Raj.
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:49 GMT-3