Re: Dlsw queueing methods

From: Darek Kuzma (darekk@xxxxxxxxxxxxx)
Date: Tue Jul 16 2002 - 20:41:28 GMT-3


   
If nothing has changed in newer IOSes match protocol dlsw can only be
used for direct encapsulation

If we use tcp we need to match on port 2065.

thanks,
Darek

Alex Paulino wrote:

> ok there, but suppose we should use the CBWFQ, what is the diference
> between the condition of match in CBWFQ class, using:
> Match protocol dlsw
> and
> match access-group 101
> access-list 101 permit tcp any any eq 2065 ??
>
> tks
>
> alex
> -----Original Message-----
> From: Darek Kuzma [mailto:darekk@optonline.net]
> Sent: Tuesday, July 16, 2002 7:20 PM
> To: ccielab@groupstudy.com
> Subject: Re: Dlsw queueing methods
>
> I haven't been reading e-mails for a while so my post is late, but I
> believe I have something to add to this interesting thread.
> Almost all which was said is correct.
> LLQ is used only during congestion so CBWFQ will not meet requirements
>
> to limit dlsw traffic when link is not congested.
> However using Class Based Policing we can accomplish our goal!
> According to Cisco:
>
> "Using police Command to Set a Maximum If a bandwidth or priority
> class
> should not exceed its allocated bandwidth during periods of no
> congestion, you can combine the priority command with the police
> command. This configuration imposes a maximum rate that is always
> active
> on the class. Choosing to configure a police statement in this
> configuration depends on the policy's objective."
>
> Please refer to:
> http://www.cisco.com/warp/public/105/priorityvsbw.html
>
> for more details.
>
> Thnaks,
> Darek Kuzma
>
> Gyuri Gabor wrote:
>
> > The provided CBWFQ example means: in all circumstances provide 3 meg
>
> > for dlsw
> > with lowest delay. If there is no other traffic, dlsw may consume
> the
> > whole
> > bandwith.
> > This way we prioritize the DLSW.
> >
> > The task mentioned is the opposite: never give more than 3 meg to
> > dlsw, even
> > if no one else want to use the link at the moment.
> > The solution for that is CAR, the correct syntax was given by
> others.
> >
> > Gabor
> >
> > > -----Original Message-----
> > > From: John White [mailto:jan_white7@hotmail.com]
> > > Sent: Saturday, July 06, 2002 11:01 PM
> > > To: dwclemons@msn.com
> > > Cc: elpingu@acedsl.com; ccielab@groupstudy.com
> > > Subject: Re: Dlsw queueing methods
> > >
> > >
> > > According to theory , this should work too. Priority queue uses
> tail
> >
> > > drops to keep proper bandwith. But on the other hand, isn't
> > > LLQ used only
> > > when there is congestion?I'm not sure
> > > In normal conditions I think we should use CAR
> > > Anybody?
> > >
> > >
> > > >From: "dwclemons" <dwclemons@msn.com>
> > > >Reply-To: "dwclemons" <dwclemons@msn.com>
> > > >To: "elping" <elpingu@acedsl.com>, "John White"
> > > <jan_white7@hotmail.com>
> > > >CC: <ccielab@groupstudy.com>
> > > >Subject: Re: Dlsw queueing methods
> > > >Date: Sat, 6 Jul 2002 16:27:06 -0400
> > > >
> > > >How about this config on a e0 10 Meg interface interface
> > > >
> > > >policy-map dlsw
> > > > class cisco
> > > > priority 3000
> > > >
> > > >class-map cisco
> > > > match access-group 101
> > > >
> > > >
> > > >access-list 101 permit tcp any any eq 2065
> > > >
> > > >int e0
> > > >service-policy output dlsw
> > > >
> > > >
> > > >----- Original Message -----
> > > >From: "elping" <elpingu@acedsl.com>
> > > >To: "John White" <jan_white7@hotmail.com>
> > > >Cc: <ccielab@groupstudy.com>
> > > >Sent: Saturday, July 06, 2002 3:49 PM
> > > >Subject: Re: Dlsw queueing methods
> > > >
> > > >
> > > > > ok...le me give it a shot.....please correct any mistakes
> > > > > .
> > > > > since the question asks allow dlsw 30% only lets's use CAR..
> > > > > total speed 10megbits
> > > > > allow 3mbits for dlsw
> > > > >
> > > > > normal burst= CIR [bps] * (1 byte)/(8 bits) * 1.5 seconds
> > > > > settting normal burst = BE disables bursting
> > > > >
> > > > > interface FastEthernet0/0
> > > > > ip address 192.168.1.34 255.255.255.255
> > > > > rate-limit output access-group 101 3000000 375000 375000
> > > conform-action
> > > > > continue exceed-action drop
> > > > > duplex half
> > > > > speed 10
> > > > >
> > > > > access-list 101 permit tcp any any eq 2065
> > > > >
> > > > >
> > > > > John White wrote:
> > > > >
> > > > > > That's fine. But which queueing method would you use,
> > > to restirict
> > > >dlsw
> > > >to
> > > > > > certain maximum bandwith? Is it custom queueing or
> > > policing-CAR. I'm
> > > >really
> > > > > > confused on issue
> > > > > > Jan
> > > > > >
> > > > > > >From: elping <elpingu@acedsl.com>
> > > > > > >Reply-To: elping <elpingu@acedsl.com>
> > > > > > >To: John White <jan_white7@hotmail.com>
> > > > > > >CC: ccielab@groupstudy.com
> > > > > > >Subject: Re: Dlsw queueing methods
> > > > > > >Date: Sat, 06 Jul 2002 11:56:41 -0400
> > > > > > >
> > > > > > >I was confused by this as well:
> > > > > > >to make it simple use
> > > > > > >
> > > > > > >only spcify port 2065 for dlsw...
> > > > > > >
> > > > > > >the other ports are used if you used priority
> > > > > > >
> > > > > > >John White wrote:
> > > > > > >
> > > > > > > > Hi guys,
> > > > > > > > I'm new to the group, so I started browsing
> > > archives recently.
> > > >There
> > > >is
> > > > > > >a
> > > > > > > > lot good stuff there.Some questions though seems to
> > > never recive
> > > > > > >answers.I
> > > > > > > > guess people use their privite e-mail accounts,
> > > instead of list.I
> > > >notice
> > > > > > >,
> > > > > > > > that in May 2002 there was discusion going on
> > > regarding bandwith
> > > > > > >allocation
> > > > > > > > for DLSw . The question was which method to use in order
>
> > to
> > > >allocate
> > > > > > >DlSw no
> > > > > > > > more than 30% of interface bandwith. (token or
> > > ehternet). Is it
> > > >custom
> > > > > > > > queueing or CAR or CBWFQ?.Does it require to
> > > specify all 4 ports
> > > >for
> > > > > > >traffic
> > > > > > > > or not (2065, 1981,1982,1983)
> > > > > > > > Thanks in advance
> > > > > > > > Jan
> > > > > > > >
> > > > > > > >



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:33 GMT-3