From: Prakash H Somani (pdsccie@xxxxxxxxxxxxxx)
Date: Fri Jul 12 2002 - 12:47:16 GMT-3
Hi friends,
I could simulate the stuff...here is the config.
-------------------
sh runn
Building configuration...
Current configuration : 1334 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
username imr2 password 0 cisco
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-net3
!
--More-- !
!
!
!
interface Loopback0
ip address 204.4.4.4 255.255.255.0
!
interface Ethernet0/0
no ip address
shutdown
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
backup delay 2 2
backup interface Dialer0
ip address 172.16.2.4 255.255.255.0
frame-relay interface-dlci 401
!
interface BRI0/0
no ip address
--More-- encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
ppp authentication chap
!
interface Serial0/1
no ip address
shutdown
!
interface ATM1/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Dialer0
bandwidth 64
ip address 172.16.3.4 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384030
dialer-group 1
ppp authentication chap
ppp chap hostname imr4
--More-- ppp chap password 7 121A0C041104
!
router ospf 100
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
network 204.4.4.0 0.0.0.255 area 0
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
end
R4#u
terminal#2
[Resuming connection 2 to r2 ... ]
02:
R2#sh runn
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
username imr4 password 0 cisco
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-net3
isdn voice-call-failure 0
cns event-service server
--More--
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
ip address 202.2.2.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
ip address 150.50.50.1 255.255.255.240
no ip directed-broadcast
shutdown
!
interface Serial0/0
no ip address
--More-- no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface BRI0/0
bandwidth 64
ip address 172.16.3.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
ip ospf demand-circuit
dialer map ip 172.16.3.4 name R4 broadcast 384010
dialer-group 1
isdn switch-type basic-net3
ppp chap hostname imr2
ppp chap password 7 00071A150754
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
--More-- log-adjacency-changes
network 150.50.0.0 0.0.255.255 area 0
network 172.16.0.0 0.0.255.255 area 0
network 202.2.2.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 101 deny ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
R2#sh ip s ospf neig
R2#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
204.4.4.4 1 FULL/ - - 172.16.3.4 BRI0/0
R2#u
terminal#3
[Resuming connection 3 to r4 ... ]
R4#sh ip ospf neig
R4#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
202.2.2.2 1 FULL/ - - 172.16.3.2 Dialer0
R4#sh dialer
R4#sh dialer
BRI0/0 - dialer type = ISDN
Dial String Successes Failures Last DNIS Last status
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.
BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=172.16.3.4, d=224.0.0.5)
Interface bound to
file Di0
Time until disconnect 24 secs
Current call connected 00:01:55
Connected to 384030 (imr2)
BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
Di0 - dialer type = DIALER PROFILE
--More-- Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 1
Dial String Successes Failures Last DNIS Last status
384030 2 0 00:01:59 successful Default
R4#
02:32:124554051588: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 3
84030 imr2, call lasted 119 seconds
02:32:126717278688: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
02:32:124554051584: %DIALER-6-UNBIND: Interface BR0/0:1 unbound from profile Di
0
02:32:30: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed sta
te to down
R4#
R4#sh ip ospf neig
R4#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
202.2.2.2 1 FULL/ - - 172.16.3.2 Dialer0
R4#
------------------
On Thu, 11 Jul 2002 Danny.Wang@alderwoods.com wrote :
>Hi Hemant,
>
>The actually requirements are:
>
>1. Use a form of authentication that does not send the password over the
>network in the clear where a sniffer might be
>able to intercept it. Use the hostname other than r1, and r2, but the
>router hostnames must be r1 and r2
>
>2. Do not allow OSPF hellos to keep the ISDN line up indefinitely, the ISDN
>line should only come up when the Ethernet
>connections fails
>
>3. Configure OSPF for the network. The ISDN link, the Ethernet , and
>loopback 0 should be placed on ospf area 0. loopback1
>on area 1 and so forth.
>
>4. config r2 such that the physical bri interface doesn't enter the standby
>mode in case you want to config ipx on these routers. r2 should wait for 2
>sec before bringing up the isdn line when the ethernet po
e ethernet port comes backup
>
>
>In case you're interested in trying.
>
>
>
>
>
> Hemant_Kumar@BERL
> EX.COM To: Danny.Wang@alderwood
s.com
> Sent by: cc: ccielab@groupstudy.c
om, Gyori Gabor
> nobody@groupstudy <Gabor.Gyori@lnx.hu>, nobody@
groupstudy.com, "P729"
> .com <p729@cox.net>, "Carlos G Men
dioroz" <tron@huapi.ba.ar>
> Subject: RE: ISDN and OSPF
>
> 07/10/2002 04:48
> PM
> Please respond to
> Hemant_Kumar
>
>
>
>
>
>
>If you read you requirements i think it is asking for backup interface
>rather ip ospf demand ckt.
>
>very simple scenario. R1 connected to R2 with both ISDN
> and Ethernet.
> > > > > > Requiment:
> > > > > >
> > > > > > 1. Configure OSPF for the network <--- ok run ospf on the
>ethernet interface
> > > > > > 2. Do not allow OSPF hello to keep the ISDN link up indefinitely
><-- configure passive interface for bri
> > > > > > 3. The ISDN line should only come up when the ethernet
>connections failed <-- backup interface bri
>
>HK
>
>
>
> "Logan,
>
> Harold"
>
> <loganh@mccfl To: Gyori Gabor <Gabor.Gyori@lnx.hu>
>
> .edu> "Carlos G Mendioroz"
><tron@huapi.ba.ar>
> Sent by: "P729" <p729@cox.net>
>
> nobody@groups cc: <ccielab@groupstudy.com>
>
> tudy.com Subject:
>
> RE: ISDN and OSPF
>
>
> 07/10/2002
>
> 09:55 PM
>
> Please
>
> respond to
>
> "Logan,
>
> Harold"
>
>
>
>
>
>
>
>I think the bandwidth changing on interface dialer0 is key. If the o
t, then when the bri channels go down,
>that represents a change in the ospf cost. If there's a change in cost,
>that needs to be advertised as a change in the link state database, which
>will bring up the DDR link. The only question left unanswered is why the
>link continued to flap in Danny's lab after he put an ospf cost on the
>dialer interfaces.
>
> > -----Original Message-----
> > From: Gyori Gabor [mailto:Gabor.Gyori@lnx.hu]
> > Sent: Tuesday, July 09, 2002 7:45 AM
> > To: Carlos G Mendioroz; P729
> > Cc: ccielab@groupstudy.com
> > Subject: RE: ISDN and OSPF
> >
> >
> > I have tried ppp multilink on single bri without dialer profiles.
> > The experiments:
> > - dialer load-treshold 1 works (opens the second channel infitely)
> > despite of documentation
> > - the bandwith shown on interface is allways 64K regardless of the
> > number of connected B channels.
> >
> > The results using dialer profiles:
> > - dialer load-treshold 1 works (opens the second channel infitely)
> > despite of documentation
> > - The bandwith of Dialer0 is changing
> > 56K when no channel is connected
> > 64K when one channel is connected
> > 128K when two channels are connected.
> >
> > Assigning bandwidth to Dialer interface is forbidden when the
> > multilink ppp is
> > active, so I think it is not recomened either (I had to
> > relead the router
> > after I have done this with no connected link).
> >
> > So when using native interface theres is no problem, using
> > Dialer profile,
> > ospf cost is the solution.
> >
> > I was using a 1603 with 12.1.14 on caller side, 2611 on
> > remote using same
> > IOS.
> >
> > Gabor
> >
> > > -----Original Message-----
> > > From: Carlos G Mendioroz [mailto:tron@huapi.ba.ar]
> > > Sent: Tuesday, July 09, 2002 3:01 AM
> > > To: P729
> > > Cc: ccielab@groupstudy.com
> > > Subject: Re: ISDN and OSPF
> > >
> > >
> > > Yup, I guess it will also do.
> > >
> > >
> > > P729 wrote:
> > > >
> > > > Carlos,
> > > >
> > > > I never ran into this particular problem. Do you think
>
> specifying the
> > > > 'bandwidth' parameter will have the same effect as fixing
> > > the ospf cost? Or
> > > > is something else going on?
> > > >
> > > > Regards,
> > > >
> > > > Mas Kato
> > > > https://ecardfile.com/id/mkato
> > > > ----- Original Message -----
> > > > From: "Carlos G Mendioroz" <tron@huapi.ba.ar>
> > > > To: <Danny.Wang@alderwoods.com>
> > > > Cc: <ccielab@groupstudy.com>
> > > > Sent: Monday, July 08, 2002 1:00 PM
> > > > Subject: Re: ISDN and OSPF
> > > >
> > > > > Danny,
> > > > > Short answer: fix the ospf cost of your ddr interfaces
> > > (via ip ospf
> > > > > cost).
> > > > >
> > > > > If you take a closer look, you should see that hellows
> > > are supressed for
> > > > > the
> > > > > DDR interfaces. The link is being set because of an LSU
> > > triggered by a
> > > > > change in
> > > > > cost of the link.
> > > > >
> > > > > HTH
> > > > >
> > > > > Danny.Wang@alderwoods.com wrote:
> > > > > >
> > > > > > Very simple scenario. R1 connected to R2 with both ISDN
> > > and Ethernet.
> > > > > >
> > > > > > Requiment:
> > > > > >
> > > > > > 1. Configure OSPF for the network
> > > > > > 2. Do not allow OSPF hello to keep the ISDN link up
> > indefinitely
> > > > > > 3. The ISDN line should only come up when the ethernet
> > > connections
> > > > failed
> > > > > >
> > > > > > But after i enable the 'ip ospf demand circuit' on the
> > > dialer interface
> > > > > > (one side only), the link still constantly up and down,
> > > just wonderring
> > > > if
> > > > > > i missed something or it's a Teltone simulator "bug" ;-j
> > > > > >
> > > > > > When i enable debuy ip packet and dialer packet, it
> > > shows the dialer
> > > > caused
> > > > > > by hello packet, source ip address from dialer 1 to
> > 224.0.0.5 ).
> > > > > >
> > > > > > when i modified the dialer-list on the R1, it's
> > > stopped, and leaving R2
> > > > as
> > > > > > is
> > > > > >
> > > > > > dialer list 1 protocol list 100
> > > > > > access-list 100 deny ospf any any
> > > > > > access-list 100 permit ip any any
>
R1------ISDN-------R2
> > > > > > \ /
> > > > > > \ /
> > > > > > Ethernet
> > > > > >
> > > > > > r1# sh run
> > > > > >
> > > > > > Building configuration...
> > > > > >
> > > > > > Current configuration : 1551 bytes
> > > > > > !
> > > > > > version 12.1
> > > > > > no service single-slot-reload-enable
> > > > > > service timestamps debug uptime
> > > > > > service timestamps log uptime
> > > > > > no service password-encryption
> > > > > > !
> > > > > > hostname r1
> > > > > > !
> > > > > > !
> > > > > > username CCIE2 password 0 cisco
> > > > > > username r2 password 0 cisco
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > ip subnet-zero
> > > > > > no ip domain-lookup
> > > > > > !
> > > > > > ip audit notify log
> > > > > > ip audit po max-events 100
> > > > > > isdn switch-type basic-ni
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > interface Loopback0
> > > > > > ip address 10.10.11.1 255.255.255.255
> > > > > > !
> > > > > > interface Loopback1
> > > > > > ip address 10.10.12.1 255.255.255.255
> > > > > > !
> > > > > > interface Loopback2
> > > > > > ip address 10.10.13.1 255.255.255.255
> > > > > > !
> > > > > > interface Ethernet0/0
> > > > > > no ip address
> > > > > > shutdown
> > > > > > !
> > > > > > interface Serial0/0
> > > > > > no ip address
> > > > > > shutdown
> > > > > > no fair-queue
> > > > > > !
> > > > > > interface BRI0/0
> > > > > > no ip address
> > > > > > encapsulation ppp
> > > > > > dialer pool-member 1
> > > > > > isdn switch-type basic-ni
> > > > > > isdn spid1 0835866101 8358661
> > > > > > isdn spid2 0835866301 8358663
> > > > > > ppp authentication chap
> > > > > > ppp multilink
> > > > > > !
> > > > > > interface Ethernet0/1
> > > > > > ip address 192.168.1.211 255.255.255.0
> > > > > > !
> > > > > > interface Dialer1
> > > > > > ip address 172.19.1.6 255.255.255.252
> > > > > > encapsulation ppp
> > >
pool 1
> > > > > > dialer remote-name CCIE2
> > > > > > dialer string 8358662
> > > > > > dialer-group 1
> > > > > > ppp authentication chap
> > > > > > ppp chap hostname CCIE1
> > > > > > ppp multilink
> > > > > >
> > > > > > !
> > > > > > router ospf 64
> > > > > > log-adjacency-changes
> > > > > > network 10.10.11.1 0.0.0.0 area 0
> > > > > > network 10.10.12.1 0.0.0.0 area 1
> > > > > > network 10.10.13.1 0.0.0.0 area 2
> > > > > > network 172.19.1.4 0.0.0.3 area 0
> > > > > > network 192.168.1.0 0.0.0.255 area 0
> > > > > > !
> > > > > > ip classless
> > > > > > ip http server
> > > > > > ip ospf name-lookup
> > > > > > !
> > > > > > dialer-list 1 protocol ip permit
> > > > > > !
> > > > > > !
> > > > > > alias exec r show run
> > > > > > alias exec c conf t
> > > > > > !
> > > > > > line con 0
> > > > > > exec-timeout 0 0
> > > > > > line aux 0
> > > > > > line vty 0 4
> > > > > > login
> > > > > > !
> > > > > > end
> > > > > >
> > > > > > r2#sh run
> > > > > > Building configuration...
> > > > > >
> > > > > > Current configuration : 1627 bytes
> > > > > > !
> > > > > > version 12.1
> > > > > > no service single-slot-reload-enable
> > > > > > service timestamps debug uptime
> > > > > > service timestamps log uptime
> > > > > > no service password-encryption
> > > > > > !
> > > > > > hostname r2
> > > > > > !
> > > > > > logging buffered 10000 debugging
> > > > > > !
> > > > > > username CCIE1 password 0 cisco
> > > > > > username r1 password 0 cisco
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > ip subnet-zero
> > > > > > no ip domain-lookup
> > > > > > !
> > > > > > isdn switch-type basic-ni
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > !
> > > > > > interface Loopback0
> > > > > > ip address 10.10.11.2 255.255.255.255
> > > > > > !
> > > > > > interface Loopback1
> > > > > > ip address 10.10.12.2 255.255.255.255
> > > > > > !
> > > > > > interface Loopback2
> > > > > > ip address 10.10.13.2 255.255.255.255
> > > > >
> > no ip address
> > > > > > shutdown
> > > > > > !
> > > > > > interface Serial0/0
> > > > > > no ip address
> > > > > > shutdown
> > > > > > no fair-queue
> > > > > > !
> > > > > > interface BRI0/0
> > > > > > no ip address
> > > > > > encapsulation ppp
> > > > > > dialer pool-member 1
> > > > > > isdn switch-type basic-ni
> > > > > > isdn spid1 0835866201 8358662
> > > > > > isdn spid2 0835866401 8358664
> > > > > > ppp authentication chap
> > > > > > ppp multilink
> > > > > > !
> > > > > > interface Ethernet0/1
> > > > > > backup delay 2 2
> > > > > > backup interface Dialer1
> > > > > > ip address 192.168.1.212 255.255.255.0
> > > > > > !
> > > > > > interface Dialer1
> > > > > > ip address 172.19.1.5 255.255.255.252
> > > > > > encapsulation ppp
> > > > > > dialer pool 1
> > > > > > dialer remote-name CCIE1
> > > > > > dialer string 8358661
> > > > > > dialer load-threshold 128 either
> > > > > > dialer-group 1
> > > > > > ppp authentication chap
> > > > > > ppp chap hostname CCIE2
> > > > > > ppp multilink
> > > > > > !
> > > > > > router ospf 64
> > > > > > log-adjacency-changes
> > > > > > network 10.10.11.2 0.0.0.0 area 0
> > > > > > network 10.10.12.2 0.0.0.0 area 12
> > > > > > network 10.10.13.2 0.0.0.0 area 13
> > > > > > network 172.19.1.4 0.0.0.3 area 0
> > > > > > network 192.168.1.0 0.0.0.255 area 0
> > > > > > !
> > > > > > ip classless
> > > > > > ip http server
> > > > > > !
> > > > > > dialer-list 1 protocol ip permit
> > > > > > !
> > > > > > !
> > > > > > alias exec r show run
> > > > > > alias exec c conf t
> > > > > >
> > > > > > line con 0
> > > > > > exec-timeout 0 0
> > > > > > line aux 0
> > > > > > line vty 0 4
> > > > > > login
> > > > > > !
> > > > > > end
> > > > > >
> > > > > > Debug output:
> > > > > >
> > > > > > 00:44:45: IP: s=192.168.1.211 (local), d=224.0.0.5
> > > (Ethernet0/1), len
> > > > 68,
> > > > > > sendin
> > > > > > g broad/multicast
> > > > > > 00:44:49: IP: s=192.168.1.212 (Ethernet0/1),
> > > d=224.0.0.5, len 68, rcvd 0
> > >
0.5
> > > (Dialer1), len 64,
> > > > sending
> > > > > > broad
> > > > > > /multicast
> > > > > > 00:44:54: Di1 DDR: ip (s=172.19.1.6, d=224.0.0.5), 64
> > > bytes, outgoing
> > > > > > interestin
> > > > > > g (ip PERMIT)
> > > > > > 00:44:54: IP: s=172.19.1.6 (local), d=224.0.0.5
> > > (BRI0/0), len 64,
> > > > > > encapsulation
> > > > > > failed
> > > > > > 00:44:55: IP: s=192.168.1.211 (local), d=224.0.0.5
> > > (Ethernet0/1), len
> > > > 68,
> > > > > > sendin
> > > > > > g broad/multicast
> > > > > > 00:44:55: %LINK-3-UPDOWN: Interface BRI0/0:1, changed
> > > state to up
> > > > > > 00:44:55: %DIALER-6-BIND: Interface BR0/0:1 bound to
> > profile Di1
> > > > > > 00:44:56: %ISDN-6-CONNECT: Interface BRI0/0:1 is now
> > > connected to
> > > > 8358662
> > > > > > 00:44:56: %ISDN-6-DISCONNECT: Interface BRI0/0:1
> > > disconnected from
> > > > 8358662
> > > > > >
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:28 GMT-3