CCbootcamp LAB 17 Question

From: Jaspreet Bhatia (jasbhati@xxxxxxxxx)
Date: Fri Jun 14 2002 - 13:20:01 GMT-3


   
Folks,
                I have just now completed Lab 17 . I do have one question.
In this lab , we are supposed to do theses things on the ISDN Line between
R5 and R6 :

1) PPP Multilink
2) PPP Callback
3) OSPF demand circuit
4) Also on R6 , IGRP is being redistributed into OSPF

I am using 12.1(2.3) on R5 and 12.1(13) on R6

Ok here is the problem . Initially I was under the impression that Callback
and PPP multilink cannot be implemented together . So I did not implement
the PPP Multilink feature initially . Everything was working nicely ,
CAllback is working and OSPF demand ckt is working and teh link is not
flapping . Now I decide to add ppp multilink feature on top of this pile..
Now my ISDN link is flapping ... I am including the configs ... Can anyone
help ?

R5

R5#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
username R6 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
clns routing
ipx routing 000e.000e.000e
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 5.5.5.5 255.255.255.255
  ipx network EE11
!
interface Loopback1
  ip address 15.15.5.5 255.255.255.0
  ip router isis
!
interface Ethernet0/0
  no ip address
  shutdown
!
interface TokenRing0/0
  no ip address
  shutdown
  ring-speed 16
!
interface BRI1/0
  ip address 10.1.35.5 255.255.255.252
  encapsulation ppp
  ip ospf cost 9999
  ip ospf demand-circuit
  dialer idle-timeout 45
  dialer fast-idle 15
  dialer string 8995201
  dialer load-threshold 1 either
  dialer-group 1
  isdn switch-type basic-ni
  isdn spid1 5401 8995401
  isdn spid2 5402 8995402
  no peer neighbor-route
  ppp callback request
  ppp authentication chap
  ppp chap hostname ccie
  ppp multilink
!
interface BRI1/1
  no ip address
  shutdown
!
interface BRI1/2
  no ip address
  shutdown
!
interface BRI1/3
  no ip address
  shutdown
!
interface BRI1/4
  no ip address
  shutdown
!
interface BRI1/5
  no ip address
  shutdown
!
interface BRI1/6
  no ip address
  shutdown
!
interface BRI1/7
  no ip address
  shutdown
!
interface Ethernet2/0
  no ip address
  shutdown
!
interface Ethernet2/1
  no ip address
  shutdown
!
interface Ethernet2/2
  no ip address
  shutdown
!
interface Ethernet2/3
  no ip address
  shutdown
!
interface Serial3/0
  no ip address
  shutdown
  no fair-queue
!
interface Serial3/1
  no ip address
  encapsulation frame-relay
  clockrate 64000
!
interface Serial3/1.1 point-to-point
  ip address 10.1.12.194 255.255.255.240
  ip router isis
  ipx network 1402
  frame-relay interface-dlci 401
!
interface Serial3/2
  no ip address
  shutdown
!
interface Serial3/3
  no ip address
  shutdown
!
router ospf 1
  log-adjacency-changes
  network 10.1.35.5 0.0.0.0 area 5
  distance 120
!
router isis
  distance 100 clns
  net 00.0001.1111.1111.1111.00
!
router bgp 100
  no synchronization
  neighbor 10.1.11.1 remote-as 100
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
!
!
ipx router eigrp 10
  network 1402
  network EE11
!
!
!
!
!
alias exec c config term
!
line con 0
  transport input none
line aux 0
line vty 0 4
!
end

R6

R6#sh run
Building configuration...

Current configuration : 2333 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
!
username ccie password 0 cisco
!
!
!
!
ip subnet-zero
!
ip multicast-routing
ipx routing 000a.000c.000b
ipx internal-network DAD2
isdn switch-type basic-ni
!
!
!
!
!
!
!
interface Loopback0
  ip address 15.15.6.6 255.255.255.0
  ip ospf network point-to-point
  ipx network ACB1
!
interface Ethernet0/0
  ip address 10.1.10.6 255.255.255.0
  ipx network 1408
  ipx nlsp enable
  ipx nlsp rip off
  ipx nlsp sap off
!
interface Ethernet0/1
  ip address 10.1.5.2 255.255.255.248
  ip pim dense-mode
  ip igmp join-group 224.10.1.2
  ip cgmp
  ipx network 1406
!
interface BRI1/0
  ip address 10.1.35.6 255.255.255.252
  encapsulation ppp
  ip ospf demand-circuit
  dialer callback-secure
  dialer idle-timeout 45
  dialer fast-idle 15
  dialer map ip 10.1.35.5 name ccie class myclass broadcast 8995401
  dialer load-threshold 1 either
  dialer-group 1
  isdn switch-type basic-ni
  isdn spid1 5201 8995201
  isdn spid2 5202 8995202
  no peer neighbor-route
  ppp callback accept
  ppp authentication chap
  ppp multilink
!
interface BRI1/1
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/2
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/3
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/4
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/5
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/6
  no ip address
  shutdown
  isdn switch-type basic-ni
!
interface BRI1/7
  no ip address
  shutdown
  isdn switch-type basic-ni
!
router ospf 1
  log-adjacency-changes
  area 10 virtual-link 15.15.14.14
  redistribute igrp 1 subnets route-map hello
  network 10.1.5.2 0.0.0.0 area 10
  network 10.1.35.6 0.0.0.0 area 5
  network 15.15.6.6 0.0.0.0 area 10
!
router igrp 1
  redistribute ospf 1 metric 1000 1 1 1 1500
  passive-interface Ethernet0/1
  passive-interface BRI1/0
  network 10.0.0.0
!
ip classless
ip default-network 200.20.20.0
ip http server
!
!
map-class dialer myclass
  dialer callback-server username
access-list 13 permit 10.1.35.4 0.0.0.3
dialer-list 1 protocol ip permit
route-map hello deny 10
  match ip address 13
!
route-map hello permit 20
!
!
!
!
ipx router nlsp
  area-address 0 0
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end



This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:33 GMT-3