ibgp problem?

From: chenyan (chenyan@xxxxxxxxxxxxxx)
Date: Wed Jun 12 2002 - 12:07:07 GMT-3


   
hi, I meet a problem of ibgp.
        Term-----R4-----R1-----R2-----R5-----R3
              | | | | |
             Net1 Net2 Net3 Net4 Net5
there R1 belonging one AS,R2/R3/R4/R5 belonging one AS,R6 belonging one AS, R2/
R3/R4/R5 configued with IBGP full meshed and no sync enabled, but I met a probl
em R2 cant be peering with R5 and the others can do well, and then the routing
table of R5 has the Net2 entry but every 0ne minute later is disapearing.
The configuration is the following:

term:
interface Loopback1
 ip address 192.168.250.1 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 ip address 192.168.1.210 255.255.255.252
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
router bgp 200
 network 192.168.250.0 mask 255.255.255.240
 neighbor 192.168.1.209 remote-as 100

R4:
interface Serial0
 ip address 192.168.12.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 192.168.1.209 255.255.255.252
 no ip directed-broadcast
 clockrate 2000000
!
router bgp 100
 no synchronization
 network 192.168.1.208 mask 255.255.255.252
 neighbor 192.168.1.210 remote-as 200
 neighbor 192.168.10.1 remote-as 100
 neighbor 192.168.11.2 remote-as 100
 neighbor 192.168.12.2 remote-as 100

R1:
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.10.2 255.255.255.0
!
interface Serial0/2
 ip address 192.168.12.2 255.255.255.0
 clockrate 2000000
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.10.0
 network 192.168.12.0
 neighbor 192.168.10.1 remote-as 100
 neighbor 192.168.11.2 remote-as 100
 neighbor 192.168.12.1 remote-as 100

R2:
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 no ip directed-broadcast
!
interface Serial0
 ip address 192.168.10.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 2000000
!
interface Serial1
 ip address 192.168.11.1 255.255.255.0
 no ip directed-broadcast
!
router bgp 100
 no synchronization
 network 192.168.10.0
 network 192.168.11.0
 neighbor 192.168.10.2 remote-as 100
 neighbor 192.168.11.2 remote-as 100
 neighbor 192.168.12.1 remote-as 100

R5:
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet2/0
 ip address 192.168.13.2 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!
interface Serial2/1
 ip address 192.168.11.2 255.255.255.0
 clockrate 2000000
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.13.0
 neighbor 192.168.10.2 remote-as 100
 neighbor 192.168.11.1 remote-as 100
 neighbor 192.168.12.1 remote-as 100
 neighbor 192.168.13.1 remote-as 300

R3:
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.13.1 255.255.255.0
!
router bgp 300
 bgp log-neighbor-changes
 neighbor 192.168.13.2 remote-as 100



This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:31 GMT-3