From: Nick Shah (nshah@xxxxxxxxxxxxxx)
Date: Wed Jun 05 2002 - 06:09:53 GMT-3
Alex,
both are correct.
You can use directly connected interface address or you can use loopback
interface, if you choose first one, you can use neighbor x.y.z.a (directly
connected address), if you use loopback interface, u use neighbor x.y.z.a
(remote loopback address). for eg.
Rtr (S0 - 192.168.1.1/30) ------directly connected to ------ RtrB(S0 -
192.168.1.2/30) then you will use the following commands ...
RtrA #
router bgp 100
neighbor 192.168.1.2 remote-as 200
RtrB#
router bgp 200
neighbor 192.168.1.1 remote-as 100
if you are using loopbacks then...
RtrA (loopback address 1.1.1.1) -------S0 --------S0 (of RtrB) --- (loopback
address 2.2.2.2)
RtrA #
ip route 2.2.2.2 255.255.255.255 s0
router bgp 100
neighbor 2.2.2.2 remote-AS 200
neighbor 2.2.2.2 update-source loopback0
neighbor 2.2.2.2 ebgp-multihop
RtrB#
ip route 1.1.1.1 255.255.255.255 S0
router bgp 200
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source loopback0
neighbor 1.1.1.1 ebgp-multihop 2
If you are using the same config (with loopbacks as update source) for IBGP
neighbors, then you dont specify ebgp-multihop (but you still specify update
sourece loopback0)
hth
Nick
-----Original Message-----
From: Alex Rhyubisef <foselkr@yahoo.co.kr>
To: ccielab@groupstudy.com <ccielab@groupstudy.com>
Date: Wednesday, 5 June 2002 6:36
Subject: about EBGP neighbor ip address
>hi, all
>
>i have a question about ebgp.
>when we configure ebgp,
>1. we use direct connected interface address
>2. we use loopback address with ebgp multihop 255
> and update source loopback0
>
>is #1 or #2 correct ?
>
>
>thanks in advance.
>
This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:25 GMT-3