Re: eigrp problem via nbma

From: p729@xxxxxxx
Date: Wed Jun 05 2002 - 02:35:10 GMT-3


   
Try adding the 'broadcast' keyword to your 'frame-relay map' statements in r5 a
nd r6.

Or, as an interesting experiment, try changing the EIGRP routing updates to uni
cast by using the 'neighbor' command under the EIGRP routing process in r5 and
r6 (instead of the 'broadcast' keyword on the map statements).

The reason it seems to be "working in one direction" is you do have broadcasts
enabled on your frame maps in r2. The multicasts make it out to r5 and r6 and t
he reliable part of EIGRP _unicasts_ the acknowledgements back to r2, so the 'b
roadcast' keyword isn't needed for that part to work.

Regards,

Mas Kato
https://ecardfile.com/id/mkato
============================================================
From: Danny.Wang@alderwoods.com
Date: 2002/06/04 Tue PM 09:12:51 EDT
To: ccielab@groupstudy.com
Subject: eigrp problem via nbma

r1 --- r2 (ethernet)
r2 --- r4 (frame-relay)
r2 --- r5 (FR)
r2 --- r6 (FR)
r5 --- r6 (ethernet)

r1- - - r2-- -- -- r4
       / \
     / \
   r5 - - - r6

eigrp on r1, r2, r5, r6.
igrp on r2, r4.

igrp works just fine, but i can't make the eigrp working.

>From r5, r6, the neighbor estabalished when "sh ip eig nei"

r5#sh ip eigrp nei
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
Type
                                        (sec) (ms) Cnt Num
1 150.50.100.2 Se0/0 13 00:01:11 1 5000 1 0
0 150.50.7.6 Et0/0 11 00:35:28 8 200 0 8

r6>sh ip eig nei
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
                                        (sec) (ms) Cnt Num
0 150.50.100.2 Se0 14 00:00:38 0 5000 1 0
1 150.50.7.5 Et0 12 00:36:21 20 200 0 18

also from r5, r6, I can ping r2

 r6>ping 150.50.100.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms

r5#ping 150.50.100.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/20 ms

I could ping r5, r6, from r2

r2>ping 150.50.100.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/20 ms
r2>ping 150.50.100.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/24 ms

but, when i " sh ip eigr nei" @ r2

IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
Type
                                        (sec) (ms) Cnt Num
0 150.50.17.1 Et0/0 12 00:22:14 125 750 0 41

Why?

sh run:

r2#r

Current configuration : 1715 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
!
!
!
interface Loopback0
 ip address 200.0.0.2 255.255.255.255
!
interface Ethernet0/0
 ip address 150.50.17.2 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay class cir_value
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial0/0.24 point-to-point
 ip address 150.50.24.2 255.255.255.0
 no arp frame-relay
 frame-relay interface-dlci 104
!
interface Serial0/0.256 multipoint
 ip address 150.50.100.2 255.255.255.224
 frame-relay map ip 150.50.100.5 105 broadcast
 frame-relay map ip 150.50.100.6 106 broadcast
!
interface Ethernet0/1
 no ip address
 shutdown
!
router eigrp 1
 redistribute igrp 2
 network 150.50.17.0 0.0.0.255
 network 150.50.100.0 0.0.0.31
 network 200.0.0.2 0.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router igrp 2
 passive-interface Ethernet0/0
 passive-interface Serial0/0.256
 network 150.50.0.0
!
ip classless
no ip http server
!
!
map-class frame-relay cir_value
 frame-relay cir in 56000
 frame-relay cir out 56000
 no frame-relay adaptive-shaping
!
!
alias exec r show run
alias exec c conf t
alias exec i show ip route
alias exec b show ip bgp
alias exec o show ip ospf
alias exec oi show ip ospf int
alias exec od show ip ospf int data
alias exec bn show ip bgp neigh
alias exec bri show ip int brie
alias exec fp show frame-relay pvc
alias exec fm show frame-relay map
!
line con 0
line aux 0
line vty 0 4
 login
!
end

r4#r
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Loopback0
 ip address 200.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.4 255.255.255.0
 no ip directed-broadcast
 no keepalive
!
interface Serial0
 ip address 150.50.24.4 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 ip split-horizon
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 frame-relay map ip 150.50.24.2 401 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router igrp 2
 redistribute connected
 passive-interface Ethernet0
 network 150.50.0.0
!
ip classless
!
alias exec bri show ip int brie
alias exec f show frame-relay pvc
alias exec r show run
alias exec c conf t
alias exec i show ip route
alias exec b show ip bgp
alias exec o show ip ospf
alias exec oi show ip ospf int
alias exec bn show ip bgp neigh
alias exec fp show frame-relay pvc
alias exec fm show frame-relay map
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r5#r
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
ip subnet-zero
no ip domain-lookup
!
lane client flush
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 200.0.0.5 255.255.255.255
!
interface Ethernet0/0
 ip address 150.50.7.5 255.255.255.128
!
interface Serial0/0
 ip address 150.50.100.5 255.255.255.224
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay map ip 150.50.100.2 501
 frame-relay map ip 150.50.100.6 501
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 frame-relay qos-autosense
!
interface Ethernet0/1
 no ip address
 shutdown
!
router eigrp 1
 redistribute connected
 network 150.50.0.0
 no auto-summary
!
ip classless
no ip http server
!
!
alias exec bri show ip int brie
alias exec f show frame-relay pvc
alias exec r show run
alias exec c conf t
alias exec i show ip route
alias exec b show ip bgp
alias exec o show ip ospf
alias exec oi show ip ospf int
alias exec bn show ip bgp neigh
alias exec fp show frame-relay pvc
alias exec fm show frame-relay map
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r6#r
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Loopback0
 ip address 200.0.0.6 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 150.50.7.6 255.255.255.128
 no ip directed-broadcast
!
interface Serial0
 ip address 150.50.100.6 255.255.255.2
 no ip directed-broadcast
 encapsulation frame-relay
 ip split-horizon
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 frame-relay map ip 150.50.100.2 601
 frame-relay map ip 150.50.100.5 601
 frame-relay lmi-type cisco
 frame-relay lmi-n391dte 255
 frame-relay lmi-n392dte 10
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router eigrp 1
 redistribute connected
 network 150.50.0.0
 no auto-summary
!
ip classless
!
alias exec bri show ip int brie
alias exec f show frame-relay pvc
alias exec r show run
alias exec c conf t
alias exec i show ip route
alias exec b show ip bgp
alias exec o show ip ospf
alias exec oi show ip ospf int
alias exec bn show ip bgp neigh
alias exec fp show frame-relay pvc
alias exec fm show frame-relay map
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r6#



This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:24 GMT-3