From: Carlos G Mendioroz (tron@xxxxxxxxxxx)
Date: Tue Jun 04 2002 - 14:58:55 GMT-3
OSPF just does that for loopbacks, but you can disable it
by using ospf network-type point-to-point in the loopback
interface. Then you'll get the /24 and everything like
you wanted.
(The default way of advertizing loopbacks is like a stub host,
i.e. just one address)
Nick Lesewski wrote:
>
> I've been playing with AD and I've got something confusing. I've got six
> routers layed out like this:
>
> R2---R3
> / \
> R1 R6
> \ /
> R4---R4
>
> Routers R2 and R3 are only running EIGRP.
> Routers R4 and R5 are only running OSPF.
> Routers R1 and R6 are running both.
> There is no redistribution between the two protocols.
> R6 has a loopback interface that is being advertised through a network
> statement in each of the two protocols.
>
> I would expect R1 to see the loopback on R6 through both protocols, but then
> selected EIGRP, since it has a lower AD. What happens is that OSPF provides
> a /32 route that takes precidence over the /24 route provided by EIGRP. It
> seems like OSPF is finding the specific address of the loopback interface,
> while EIGRP is finding the whole class-C network, so OSPF is taking control.
> My question is... why?
>
> Here are my configs...
>
> R1#show run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> no logging console
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> !
> interface Loopback0
> ip address 192.168.1.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial1/0
> ip address 192.168.14.1 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> no ip mroute-cache
> no fair-queue
> !
> interface Serial1/1
> ip address 192.168.12.1 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> !
> router eigrp 21
> network 192.168.1.0
> network 192.168.12.0
> !
> router ospf 12
> network 192.168.1.0 0.0.0.255 area 0
> network 192.168.14.0 0.0.0.255 area 0
> !
> ip classless
> no ip http server
> !
> alias exec i show ip route
> alias exec co config t
> !
> line con 0
> exec-timeout 0 0
> password cisco
> login
> transport input none
> line aux 0
> exec-timeout 0 0
> password cisco
> login
> line vty 0 4
> exec-timeout 0 0
> password cisco
> login
> !
> end
>
> R2#show run
> !
> interface Loopback0
> ip address 192.168.2.2 255.255.255.0
> !
> interface Serial0
> ip address 192.168.23.2 255.255.255.0
> encapsulation ppp
> no ip route-cache
> no ip mroute-cache
> clockrate 125000
> !
> interface Serial1
> ip address 192.168.12.2 255.255.255.0
> encapsulation ppp
> no ip route-cache
> no ip mroute-cache
> clockrate 125000
> !
> router eigrp 21
> network 192.168.2.0
> network 192.168.12.0
> network 192.168.23.0
> auto-summary
> no eigrp log-neighbor-changes
>
> R3#sh run
> !
> interface Loopback0
> ip address 192.168.3.3 255.255.255.0
> !
> interface Serial0
> ip address 192.168.23.3 255.255.255.0
> encapsulation ppp
> no ip route-cache
> no ip mroute-cache
> !
> interface Serial1
> ip address 192.168.36.3 255.255.255.0
> encapsulation ppp
> no ip route-cache
> no ip mroute-cache
> clockrate 125000
> !
> router eigrp 21
> redistribute connected
> network 192.168.23.0
> network 192.168.36.0
> default-metric 1000 10 1 255 1500
> auto-summary
> no eigrp log-neighbor-changes
>
> R4#sh run
> !
> interface Loopback0
> ip address 192.168.4.4 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial0
> ip address 192.168.14.4 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> no ip mroute-cache
> clockrate 125000
> !
> interface Serial1
> ip address 192.168.45.4 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> !
> router ospf 12
> network 192.168.4.0 0.0.0.255 area 0
> network 192.168.14.0 0.0.0.255 area 0
> network 192.168.45.0 0.0.0.255 area 0
>
> R5#sh run
> !
> interface Loopback0
> ip address 192.168.5.5 255.255.255.0
> !
> interface Serial0
> ip address 192.168.56.5 255.255.255.0
> encapsulation ppp
> clockrate 125000
> !
> interface Serial1
> ip address 192.168.45.5 255.255.255.0
> encapsulation ppp
> clockrate 19200
> !
> interface BRI0
> ip address 170.12.26.254 255.255.255.252
> encapsulation ppp
> !
> router ospf 12
> log-adjacency-changes
> redistribute connected metric 100 subnets
> network 192.168.45.0 0.0.0.255 area 0
> network 192.168.56.0 0.0.0.255 area 0
>
> R6#sh run
> !
> interface Loopback0
> ip address 192.168.6.6 255.255.255.0
> !
> interface Serial0
> ip address 192.168.56.6 255.255.255.0
> encapsulation ppp
> !
> interface Serial1
> ip address 192.168.36.6 255.255.255.0
> encapsulation ppp
> !
> interface BRI0
> ip address 170.12.26.253 255.255.255.252
> encapsulation ppp
> !
> router eigrp 21
> network 192.168.6.0
> network 192.168.36.0
> auto-summary
> no eigrp log-neighbor-changes
> !
> router ospf 12
> log-adjacency-changes
> network 192.168.6.0 0.0.0.255 area 0
> network 192.168.56.0 0.0.0.255 area 0
> !
>
> Any help in understanding what's going on is appreciated...
>
> Thanks...
>
> NIC
>
This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:23 GMT-3