RE: Route filtering

From: John Maliakal (john.maliakal@xxxxxxxxxxxxx)
Date: Tue Jun 04 2002 - 04:44:58 GMT-3


   
Hi Paul ,
I have a working solution for your problem..

Please go through the link which describes the entire information u need with r
espect to distribute lists used in rip.
http://www.cisco.com/warp/public/105/34.html

I also have a sample config which i tested out on my lab which will give you th
e entire solution.
works great ...
i should thank you for sending an interesting problem..

> Regards
> John F Maliakal

r1#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Loopback1
 ip address 200.200.1.1 255.255.255.0
!
interface Loopback2
 ip address 200.200.2.1 255.255.255.0
!
interface Loopback3
 ip address 200.200.3.1 255.255.255.0
!
interface Loopback4
 ip address 200.200.4.1 255.255.255.0
!
interface Loopback5
 ip address 200.200.5.1 255.255.255.252
!
interface Loopback6
 ip address 200.200.6.1 255.255.255.252
!
interface Serial0
 ip address 192.168.10.1 255.255.255.0
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router rip
 version 2
 redistribute static
 network 192.168.10.0
 network 200.200.1.0
 network 200.200.2.0
 network 200.200.3.0
 network 200.200.4.0
 network 200.200.5.0
 network 200.200.6.0
 no auto-summary
!
ip classless
ip route 200.200.128.0 255.255.192.0 Null0
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C 200.200.4.0/24 is directly connected, Loopback4
     200.200.5.0/30 is subnetted, 1 subnets
C 200.200.5.0 is directly connected, Loopback5
     200.200.6.0/30 is subnetted, 1 subnets
C 200.200.6.0 is directly connected, Loopback6
C 200.200.1.0/24 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Serial0
C 200.200.2.0/24 is directly connected, Loopback2
C 200.200.3.0/24 is directly connected, Loopback3
S 200.200.128.0/18 is directly connected, Null0
r1#

r2#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 192.168.10.2 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router rip
 version 2
 network 192.168.10.0
 distribute-list prefix ripfilter in Serial0
 distribute-list 1 in
 no auto-summary
!
ip classless
no ip http server
!
!
ip prefix-list ripfilter seq 5 permit 200.200.0.0/16 ge 24 le 24
access-list 1 permit 200.200.1.0 0.0.254.0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R 200.200.1.0/24 [120/1] via 192.168.10.1, 00:00:23, Serial0
C 192.168.10.0/24 is directly connected, Serial0
R 200.200.3.0/24 [120/1] via 192.168.10.1, 00:00:23, Serial0
r2#



This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:23 GMT-3