From: kym blair (kymblair@xxxxxxxxxxx)
Date: Sat Jun 01 2002 - 23:53:54 GMT-3
Several people suggested "broadcast" on the atm map statements, but I
already had it so that isn't the problem. Both routers are 4700's,
connected back-to-back, no atm switch. Here are my configs; eigrp is only
on R6's ATM link and token ring interface, and BB3's ATM and loopbacks:
ROUTER 6:
ip subnet-zero
no ip domain-lookup
!
interface TokenRing0
ip address 132.173.61.6 255.255.255.0
ring-speed 16
!
interface ATM0
ip address 132.173.66.6 255.255.255.224
pvc 4/61
protocol ip 132.173.66.1 broadcast
protocol ip 132.173.66.6 broadcast
encapsulation aal5snap
!
atm clock INTERNAL
no atm ilmi-keepalive
!
router eigrp 666
redistribute connected
redistribute ospf 64 match internal external 1 external 2 route-map oo2ee
passive-interface Loopback0
passive-interface Serial0
network 132.173.61.0 0.0.0.255
network 132.173.66.0 0.0.0.31
default-metric 1000 100 255 1 1500
no auto-summary
eigrp router-id 132.173.66.6
no eigrp log-neighbor-changes
!
ip classless
ROUTER BB3:
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.2.1 255.255.255.128
!
interface ATM0
ip address 132.173.66.1 255.255.255.224
pvc 4/61
protocol ip 132.173.66.1 broadcast
protocol ip 132.173.66.6 broadcast
encapsulation aal5snap
!
atm clock INTERNAL
no atm ilmi-keepalive
!
router eigrp 666
passive-interface Loopback0
passive-interface Loopback1
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.127
network 132.173.66.0 0.0.0.31
neighbor 132.173.66.6 ATM0
no auto-summary
eigrp router-id 132.173.66.1
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 132.173.66.6
The ATM link is alive:
BB3#ping 132.173.66.1
!!!!!
BB3#ping 132.173.66.6
!!!!!
When I install a tunnel, R6 and BB3 form eigrp adjacencies. But without the
tunnel, there are no eigrp routes getting to BB3:
BB3#sh ip route
Gateway of last resort is 132.173.66.6 to network 0.0.0.0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.2.0/25 is directly connected, Loopback1
C 10.1.1.0/24 is directly connected, Loopback0
132.173.0.0/27 is subnetted, 1 subnets
C 132.173.66.0 is directly connected, ATM0
S* 0.0.0.0/0 [1/0] via 132.173.66.6
Debugging shows sending and receiving eigrp hellos, but "ignore multicast
hello":
BB3#debug eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB,
SIAQUERY, SIAREPLY)
BB3#debug ip eigrp nei 666 132.173.66.6
IP Neighbor target enabled on AS 666 for 132.173.66.6
IP-EIGRP Neighbor Target Events debugging is on
BB3#
00:19:04: EIGRP: Sending HELLO on ATM0 nbr 132.173.66.6
00:19:04: AS 666, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
00:19:05: EIGRP: Received HELLO on ATM0 nbr 132.173.66.6
00:19:05: AS 666, Flags 0x0, Seq 0/0 idbQ 0/0
00:19:05: EIGRP: Ignore multicast Hello ATM0 132.173.66.6
00:19:05: EIGRP: Received HELLO on ATM0 nbr 132.173.66.6
00:19:05: AS 666, Flags 0x0, Seq 0/0 idbQ 0/0
00:19:05: EIGRP: Ignore multicast Hello ATM0 132.173.66.6
00:19:08: EIGRP: Sending HELLO on ATM0 nbr 132.173.66.6
00:19:08: AS 666, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
00:19:10: EIGRP: Received HELLO on ATM0 nbr 132.173.66.6
00:19:10: AS 666, Flags 0x0, Seq 0/0 idbQ 0/0
00:19:10: EIGRP: Ignore multicast Hello ATM0 132.173.66.6
Any ideas?
Thanks.
Kym
>From: "David Ham" <ccieau@hotmail.com>
>Reply-To: "David Ham" <ccieau@hotmail.com>
>To: kymblair@hotmail.com, ccielab@groupstudy.com
>Subject: Re: EIGRP over ATM
>Date: Sun, 02 Jun 2002 10:53:32 +1000
>
>Kym,
>
>Are you doning CLIP PVC.
>Then apply "broadcast" command under PVC x/y.
>Then it will work.
>
>Regards,
>
>David Ham
>OPTUS
>
>
>>From: "kym blair" <kymblair@hotmail.com>
>>Reply-To: "kym blair" <kymblair@hotmail.com>
>>To: ccielab@groupstudy.com
>>Subject: EIGRP over ATM
>>Date: Sun, 02 Jun 2002 00:08:10 +0000
>>
>>I cannot get EIGRP to form neighbor adjacencies over ATM. It may be
>>because it uses multicast (224.0.0.10), but I'm not sure. My work-around
>>solution is to install a tunnel across the atm link and add the tunnel
>>interface to my eigrp domain, then passive-int the atm0 (no sense
>>broadcasting hellos if no one is listening).
>>
>>I've tried eigrp neighbor statements since atm is nbma; didn't help. I
>>tried pim sparse-mode with pim nbma-mode; didn't help.
>>
>>Does anyone know the solution to get eigrp to work over atm?
>>
>>Thanks.
>>
>>Kym
>>
>>
>>
This archive was generated by hypermail 2.1.4 : Tue Jul 02 2002 - 08:12:20 GMT-3