From: Bola Adegbonmire (BolaAD@xxxxxxxxxxxxxxxxx)
Date: Thu May 30 2002 - 10:07:22 GMT-3
Hi,
Somebody posted this scenario earlier. Here is what I came up with in
the lab.
This are configs from three 2611 routers used to simulate this scenario.
I didn't post this earlier 'cos I wanted to be sure that if I actuall
had a PC behind one of the networks I will be able to get to it. Which
works.
The solution is to change the mask of the router connecting to the RIP
domain on the redristributing router to match that of the ospf domain.
That way the ospf routers learn the RIP routes with a /32 mask, but
since the routers have ip classless configured packtets get routed with
longest match rule. There should be no conflitcs as long as the rip
networks major networks if the ospf mask were used on the RIP domian are
not duplicated in the ospf domain. The ping outputs to 10.1.1.18 for the
PC attached to the R-RIP int e0/1.
Rip domain uses /28 mask while OSPF uses /24 mask. All are of the
10.0.0.0 major network.
If there are any assumptions anybody knows of I have made, pls let me
know. I want to learn. Or nay other way without using static routes.
Have fun
Network illustration.
R-ospf--------------------------------R-Red-----------------------------
----------R-RIP
Here are the configs.
For R-ospf
sh run
Building configuration...
Current configuration : 788 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R-ospf
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit po max-events 100
!
!
--More-- !
!
!
!
!
!
interface Loopback0
ip address 10.1.3.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
ip address 10.1.5.1 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/0
ip address 10.1.2.2 255.255.255.0
!
interface Ethernet0/1
ip address 10.1.4.1 255.255.255.0
no keepalive
!
router ospf 2
log-adjacency-changes
--More--
network 10.1.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
line con 0
exec-timeout 0 0
transport input none
line 33 40
line aux 0
line vty 0 4
!
no scheduler allocate
end
R-ospf#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.1.3.0/24 is directly connected, Loopback0
C 10.1.2.0/24 is directly connected, Ethernet0/0
O E1 10.1.1.0/24 [110/75] via 10.1.2.1, 00:15:41, Ethernet0/0
C 10.1.5.0/24 is directly connected, Loopback2
C 10.1.4.0/24 is directly connected, Ethernet0/1
O E1 10.1.1.16/32 [110/75] via 10.1.2.1, 00:06:35, Ethernet0/0
O E1 10.1.1.32/32 [110/75] via 10.1.2.1, 00:05:57, Ethernet0/0
O E1 10.1.1.48/32 [110/75] via 10.1.2.1, 00:05:58, Ethernet0/0
R-ospf#ping 10.1.1.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-ospf#ping 10.1.1.18
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-ospf#ping 10.1.1.33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.33, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms
R-ospf#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/4 ms
R-ospf#trace 10.1.1.18
Type escape sequence to abort.
Tracing the route to 10.1.1.18
1 10.1.2.1 0 msec 0 msec 4 msec
2 10.1.1.18 4 msec 0 msec 4 msec
R-ospf#ping 10.1.1.49
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.49, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R-ospf#
For R-RIP
sh run
Building configuration...
Current configuration : 740 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R-RIP
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit po max-events 100
!
!
--More--!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.240
!
interface Loopback2
ip address 10.1.1.33 255.255.255.240
!
interface Ethernet0/0
ip address 10.1.1.49 255.255.255.240
!
--More--
interface Ethernet0/1
ip address 10.1.1.17 255.255.255.240
!
router rip
network 10.0.0.0
!
ip classless
no ip http server
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
R-RIP#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/28 is subnetted, 8 subnets
R 10.1.3.0 [120/3] via 10.1.1.50, 00:00:02, Ethernet0/0
R 10.1.2.0 [120/1] via 10.1.1.50, 00:00:02, Ethernet0/0
C 10.1.1.0 is directly connected, Loopback0
R 10.1.5.0 [120/3] via 10.1.1.50, 00:00:02, Ethernet0/0
R 10.1.4.0 [120/3] via 10.1.1.50, 00:00:02, Ethernet0/0
C 10.1.1.16 is directly connected, Ethernet0/1
C 10.1.1.32 is directly connected, Loopback2
C 10.1.1.48 is directly connected, Ethernet0/0
R-RIP#ping 10.1.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R-RIP#ping 10.1.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-RIP#ping 10.1.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-RIP#
For R-Red
sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R-Red
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
cns event-service server
!
!
--More---
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
process-max-time 200
!
interface Ethernet0/0
ip address 10.1.1.50 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/1
ip address 10.1.2.1 255.255.255.0
no ip directed-broadcast
!
router ospf 2
redistribute rip metric 65 metric-type 1 subnets
--More--
network 10.1.2.0 0.0.0.255 area 0
!
router rip
redistribute ospf 2 metric 3
network 10.0.0.0
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
!
no scheduler allocate
end
R-Red#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O 10.1.3.0/24 [110/11] via 10.1.2.2, 00:26:33, Ethernet0/1
C 10.1.2.0/24 is directly connected, Ethernet0/1
C 10.1.1.0/24 is directly connected, Ethernet0/0
O 10.1.5.0/24 [110/11] via 10.1.2.2, 00:26:33, Ethernet0/1
O 10.1.4.0/24 [110/20] via 10.1.2.2, 00:26:33, Ethernet0/1
R 10.1.1.16/32 [120/1] via 10.1.1.49, 00:00:27, Ethernet0/0
R 10.1.1.32/32 [120/1] via 10.1.1.49, 00:00:27, Ethernet0/0
[120/1] via 10.1.1.17, 00:00:27, Ethernet0/0
R 10.1.1.48/32 [120/1] via 10.1.1.17, 00:00:28, Ethernet0/0
R-Red#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-Red#ping 10.1.1.18
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-Red#ping 10.1.1.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R-Red#
Bola Adegbonmire
WAN, Security and Network management
Resourcery Limited
18 Adeola Hopewell, Victoria Island.Lagos-Nigeria.
Tel:234-1-3200301, 4618281, 7740711-2
*************************************************Disclaimer*************
***************************************************
"The information contained in this email and any attached files is
strictly private and confidential. This email should be read by the
intended addressee only. If the recipient of this message is not the
intended addressee, please call Resourcery limited Lagos Nigeria, on
+234 1 7740711 and promptly delete this email and any attachments. The
intended recipient of this email may only use, reproduce, disclose or
distribute the information contained in this email and any attached
files with Resourcery's permission. If you are not the intended
addressee, you are strictly prohibited from using, reproducing,
disclosing or distributing the information contained in this email and
any attached files. Resourcery advises that this email and any attached
files should be scanned to detect viruses. Resourcery accepts no
liability for loss or damage (whether caused by negligence or not)
resulting from the use of any attached files."
************************************************************************
***************************************************
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:59:12 GMT-3