From: Ademola Osindero (osindero@xxxxxxxxxxxxxxxxx)
Date: Tue May 21 2002 - 11:35:29 GMT-3
Angelo,
Let's study the routes on R4 together. I haven't set up this in my lab but
I guess we could go through the theory together first.
Since the routes are not reding then the config on R4 is may not be alright.
Comparing R4's routing table with the routing protocols config
> 10.0.0.0/8 is variably subnetted, 4 subnets, 2
>masks
>R 10.1.1.0/24 [120/1] via 10.2.2.2, 00:00:11,
>Serial0/1
>C 10.3.3.0/27 is directly connected, Serial0/3
>C 10.2.2.0/24 is directly connected, Serial0/1
>O 10.3.3.32/27 [110/65] via 10.3.3.2, 00:12:39,
>Serial0/3
router ospf 100
log-adjacency-changes
summary-address 10.3.3.0 255.255.255.0
redistribute rip subnets
network 10.3.3.0 0.0.0.31 area 0
distribute-list 1 out
distance ospf external 140
!
router rip
redistribute ospf 100 metric 2
network 10.0.0.0
distribute-list 2 out
!
ip classless
ip http server
!
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.2.2.0 0.0.0.255
access-list 2 permit 10.3.3.0 0.0.0.255
Using distribute list to filter routing updates to avoid routing loop needs
to be done with extra care (though was just told by a colleague not to be
the best way to redistribute). But if you have to, before you create the
access-list, do sh ip route (routing-protocol) then create the access-list
for routing protocol. If you have done show ip route ospf, you would have
gotten
O 10.3.3.32/27 [110/65] via 10.3.3.2, 00:12:39, Serial0/
and you can then create an access-list 1 permit 10.3.3.32 0.0.0.31. But
this would still not work because the major network r4 and r7 is a /24
network. To fix it we need to use a static route on the rip router pointing
to the ospf domain.
READ THIS ARTICE - OSPF DESIGN GUIDE on cco
http://www.cisco.com/warp/public/104/1.html
However this route would still not be redistributed into the classful
network of RIP.
At 01:27 PM 5/21/2002 +0100, Bola Adegbonmire wrote:
>You did not apply a metric to your redristributed rip subnets in your
>OSPF, do that.
>
>-----Original Message-----
>From: Angelo De Guzman [mailto:ghie_pogi@yahoo.com]
>Sent: Tuesday, May 21, 2002 3:41 AM
>To: ccielab@groupstudy.com
>Subject: RIP FLSM and OSPF VLSM
>
>
>Hi Team,
> Need your advise on this. Please.
>
>R2<--->R4<-->R7
>
>R7 and R4 runs RIP with /24
>
>R4 and R2 runs OSPF with /27
>
>R4 performs mutual redistribution.
>
>I can't seem to make this work.
>
>Here is the config.
>
>Thanks in Advance.
>
>
>R7#sh run
>Building configuration...
>
>Current configuration : 487 bytes
>!
>version 12.1
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname R7
>!
>
>!
>ip subnet-zero
>!
>!
>interface Loopback100
> ip address 10.1.1.1 255.255.255.0
>!
>interface Ethernet0
> no ip address
>!
>interface Serial0
> no ip address
> shutdown
>!
>interface Serial1
> ip address 10.2.2.2 255.255.255.0
>!
>router rip
> network 10.0.0.0
>!
>ip classless
>ip http server
>!
>!
>!
>line con 0
>line aux 0
>line vty 0 4
> password cisco
> login
>!
>end
>
>R7#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M
>- mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA -
>OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
>external type 2
> E1 - OSPF external type 1, E2 - OSPF external
>type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
>level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static
>route, o - ODR
> P - periodic downloaded static route
>
>Gateway of last resort is not set
>
> 10.0.0.0/24 is subnetted, 2 subnets
>C 10.2.2.0 is directly connected, Serial1
>C 10.1.1.0 is directly connected, Loopback100
>R7#
>
>R2#sh run
>Building configuration...
>
>Current configuration : 1150 bytes
>!
>version 12.1
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>service udp-small-servers
>service tcp-small-servers
>!
>hostname R2
>!
>boot system flash c4500-js56i-mz.121-13.bin
>boot system flash
>!
>!
>!
>!
>!
>ip subnet-zero
>!
>!
>!
>!
>!
>!
>interface Loopback10
> no ip address
>!
>interface Loopback100
> ip address 10.3.3.33 255.255.255.224
> ip ospf network point-to-point
>!
>!
>interface Serial0
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
>!
>interface Serial1
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
>!
>interface Serial2
> ip address 10.3.3.2 255.255.255.224
> no ip route-cache
> no ip mroute-cache
>!
>interface Serial3
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
>!
>router ospf 100
> log-adjacency-changes
> network 10.3.3.0 0.0.0.31 area 0
> network 10.3.3.32 0.0.0.31 area 0
>!
>ip classless
>no ip http server
>!
>!
>!
>line con 0
>line aux 0
>line vty 0 4
> password cisco
> login
>!
>end
>
>R2#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M
>- mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA -
>OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
>external type 2
> E1 - OSPF external type 1, E2 - OSPF external
>type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
>level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static
>route, o - ODR
> P - periodic downloaded static route
>
>Gateway of last resort is not set
>
> 10.0.0.0/8 is variably subnetted, 4 subnets, 2
>masks
>O E2 10.2.2.0/24 [110/20] via 10.3.3.1, 00:12:13,
>Serial2
>O E2 10.1.1.0/24 [110/20] via 10.3.3.1, 00:12:13,
>Serial2
>C 10.3.3.0/27 is directly connected, Serial2
>C 10.3.3.32/27 is directly connected,
>Loopback100
>R2#
>
>R4#sh run
>Building configuration...
>
>Current configuration : 1205 bytes
>!
>version 12.1
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname R4
>!
>!
>!
>!
>!
>!
>ip subnet-zero
>no ip domain-lookup
>!
>!
>!
>interface Serial0/0
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> no fair-queue
>!
>interface Serial0/1
> ip address 10.2.2.1 255.255.255.0
> clockrate 64000
>!
>interface Serial0/2
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
>!
>interface Serial0/3
> ip address 10.3.3.1 255.255.255.224
> clockrate 64000
>!
>router ospf 100
> log-adjacency-changes
> summary-address 10.3.3.0 255.255.255.0
> redistribute rip subnets
> network 10.3.3.0 0.0.0.31 area 0
> distribute-list 1 out
> distance ospf external 140
>!
>router rip
> redistribute ospf 100 metric 2
> network 10.0.0.0
> distribute-list 2 out
>!
>ip classless
>ip http server
>!
>access-list 1 permit 10.1.1.0 0.0.0.255
>access-list 1 permit 10.2.2.0 0.0.0.255
>access-list 2 permit 10.3.3.0 0.0.0.255
>!
>!
>!
>line con 0
> exec-timeout 0 0
> logging synchronous
>line aux 0
>line vty 0 4
> password cisco
> login
>!
>end
>
>R4#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M
>- mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA -
>OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
>external type 2
> E1 - OSPF external type 1, E2 - OSPF external
>type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
>level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static
>route, o - ODR
> P - periodic downloaded static route
>
>Gateway of last resort is not set
>
> 10.0.0.0/8 is variably subnetted, 4 subnets, 2
>masks
>R 10.1.1.0/24 [120/1] via 10.2.2.2, 00:00:11,
>Serial0/1
>C 10.3.3.0/27 is directly connected, Serial0/3
>C 10.2.2.0/24 is directly connected, Serial0/1
>O 10.3.3.32/27 [110/65] via 10.3.3.2, 00:12:39,
>Serial0/3
>
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:59:03 GMT-3