From: Chuck Mason (romason0916@xxxxxxxxxxx)
Date: Thu May 16 2002 - 09:58:34 GMT-3
Do a show ip ospf database and make sure 4.4.4.4 and 5.5.5.5 are the
router-ids for each router. Just wondering if it grabbed one of the
loopbacks before you had the router-id specified.
cm
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Ludwig Morales
Sent: Thursday, May 16, 2002 9:08 PM
To: ccielab@groupstudy.com
Subject: Fw: OSPF Virtual link
Can anyone tell me why does this virtual link is not working,
everything seems to be in order
AREA0 --R5--AREA2----R4--AREA3
hostname R4
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback4
ip address 170.10.5.4 255.255.255.0
!
interface Ethernet0
ip address 170.10.128.4 255.255.255.192
ip ospf priority 0
!
interface Ethernet1
ip address 170.10.3.4 255.255.255.0
!
interface Serial0
ip address 170.10.2.4 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.19.15.4 255.255.255.0
!
router ospf 100
router-id 4.4.4.4
log-adjacency-changes
area 2 virtual-link 5.5.5.5
network 170.10.5.0 0.0.0.255 area 3
network 170.10.128.0 0.0.0.255 area 2
!
router rip
passive-interface Ethernet0
passive-interface Loopback4
passive-interface Serial0
passive-interface Serial1
network 170.10.0.0
!
router igrp 100
passive-interface Ethernet0
passive-interface Ethernet1
passive-interface Serial1
network 170.10.0.0
!
ip classless
ip http server
!
line con 0
line aux 0
line vty 0 4
!
end
R4#sh ip ospf virtual-links
Virtual Link OSPF_VL1 to router 5.5.5.5 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 2, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit
5
R4#
**********************
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback9
ip address 170.10.9.5 255.255.255.0
!
interface Ethernet0
ip address 170.10.128.5 255.255.255.0
ip ospf priority 100
!
interface Serial0
ip address 170.10.7.5 255.255.255.240
encapsulation frame-relay
ip ospf priority 50
frame-relay map ip 170.10.7.2 104 broadcast
frame-relay map ip 170.10.7.3 105 broadcast
!
interface Serial1
no ip address
shutdown
!
router ospf 100
router-id 5.5.5.5
log-adjacency-changes
area 2 virtual-link 4.4.4.4
network 170.10.7.0 0.0.0.255 area 0
network 170.10.9.0 0.0.0.255 area 2
network 170.10.128.0 0.0.0.255 area 2
neighbor 170.10.7.3
neighbor 170.10.7.2 priority 2
!
ip classless
ip http server
!
!
alias exec f show running-config | begin
!
line con 0
line 1 7
modem Host
transport input all
stopbits 1
line 8
modem InOut
transport input all
stopbits 1
line aux 0
line vty 0 4
login
!
end
R1#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:58 GMT-3