Re: Redistribute ospf external route into igrp

From: ying chang (ying_c@xxxxxxxxxxx)
Date: Wed May 08 2002 - 14:29:09 GMT-3


   
Hi Jeff,

You have to check your config. Below is my config that do the same
redistributions as you did (r5--rip--r3--igrp--r4):

r3#sb ^router
router ospf 100
router-id 172.16.146.1
log-adjacency-changes
area 3 range 172.16.144.0 255.255.255.0
area 3 range 172.16.145.0 255.255.255.0
area 3 range 172.16.146.0 255.255.255.0
redistribute rip subnets tag 53 route-map rip-routes
redistribute igrp 100 subnets tag 43 route-map igrp-routes
passive-interface default
no passive-interface Loopback0
no passive-interface Loopback1
no passive-interface Loopback2
no passive-interface Serial0
network 172.16.10.3 0.0.0.0 area 0
network 172.16.144.1 0.0.0.0 area 3
network 172.16.145.1 0.0.0.0 area 3
network 172.16.146.1 0.0.0.0 area 3
!
router rip
timers basic 10 30 30 60
redistribute ospf 100 metric 3 route-map ospf-routes
passive-interface default
no passive-interface Ethernet1
network 172.16.0.0
!
router igrp 100
timers basic 10 30 30 60
redistribute rip metric 64 2000 255 1 1500
redistribute ospf 100 metric 64 2000 255 1 1500 route-map ospf-routes
passive-interface default
no passive-interface Ethernet0
network 172.16.0.0
distance 125 172.16.52.4 0.0.0.0
!
!
ip access-list standard igrp-routes
permit 172.16.11.0 0.0.0.255
permit 172.16.52.0 0.0.0.255
permit 172.16.53.0 0.0.0.255
permit 172.16.242.0 0.0.0.255
permit 172.16.243.0 0.0.0.255
permit 172.16.244.0 0.0.0.255
ip access-list standard ospf-routes
deny 172.16.110.0 0.0.0.255
deny 172.16.100.0 0.0.0.255
deny 172.16.11.0 0.0.0.255
deny 172.16.52.0 0.0.0.255
deny 172.16.53.0 0.0.0.255
deny 172.16.242.0 0.0.0.255
deny 172.16.243.0 0.0.0.255
deny 172.16.244.0 0.0.0.255
permit any
ip access-list standard rip-routes
permit 172.16.110.0 0.0.0.255
permit 172.16.100.0 0.0.0.255
!
r3#sio d | b -5 <<<--- tag 53 are rip routes
                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
172.16.11.0 172.16.146.1 865 0x80000001 0x5706 43
172.16.52.0 172.16.146.1 1162 0x80000002 0x90A2 43
172.16.53.0 172.16.146.1 1162 0x80000002 0x85AC 43
172.16.100.0 172.16.146.1 1172 0x80000001 0x35C4 53
172.16.110.0 172.16.146.1 1172 0x80000001 0xC629 53
172.16.242.0 172.16.146.1 865 0x80000001 0x6015 43
172.16.243.0 172.16.146.1 865 0x80000001 0x551F 43
172.16.244.0 172.16.146.1 865 0x80000001 0x4A29 43
r3#
     172.16.0.0/24 is subnetted, 14 subnets
O IA 172.16.148.0 [110/65] via 172.16.10.1, 00:13:07, Serial0
O IA 172.16.149.0 [110/65] via 172.16.10.1, 00:13:00, Serial0
C 172.16.144.0 is directly connected, Loopback0
C 172.16.145.0 is directly connected, Loopback1
C 172.16.146.0 is directly connected, Loopback2
I 172.16.244.0 [125/1600] via 172.16.52.4, 00:00:02, Ethernet0
I 172.16.242.0 [125/1600] via 172.16.52.4, 00:00:02, Ethernet0
I 172.16.243.0 [125/1600] via 172.16.52.4, 00:00:03, Ethernet0
C 172.16.52.0 is directly connected, Ethernet0
C 172.16.53.0 is directly connected, Ethernet1
C 172.16.10.0 is directly connected, Serial0
I 172.16.11.0 [125/8576] via 172.16.52.4, 00:00:03, Ethernet0
R 172.16.110.0 [120/1] via 172.16.53.1, 00:00:04, Ethernet1 <<<--- rip
route
R 172.16.100.0 [120/1] via 172.16.53.1, 00:00:04, Ethernet1 <<<--- rip
route
r3#

r4#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 14 subnets
I 172.16.148.0 [100/158350] via 172.16.52.3, 00:00:03, Ethernet0
I 172.16.149.0 [100/158350] via 172.16.52.3, 00:00:03, Ethernet0
I 172.16.144.0 [100/1600] via 172.16.52.3, 00:00:03, Ethernet0
I 172.16.145.0 [100/1600] via 172.16.52.3, 00:00:03, Ethernet0
I 172.16.146.0 [100/1600] via 172.16.52.3, 00:00:03, Ethernet0
C 172.16.244.0 is directly connected, Loopback2
C 172.16.242.0 is directly connected, Loopback0
C 172.16.243.0 is directly connected, Loopback1
C 172.16.52.0 is directly connected, Ethernet0
I 172.16.53.0 [100/1200] via 172.16.52.3, 00:00:04, Ethernet0
I 172.16.10.0 [100/8576] via 172.16.52.3, 00:00:04, Ethernet0
C 172.16.11.0 is directly connected, Serial0
I 172.16.110.0 [100/158350] via 172.16.52.3, 00:00:05, Ethernet0
<<<--- RIP route
I 172.16.100.0 [100/158350] via 172.16.52.3, 00:00:05, Ethernet0
<<<--- RIP route
r4#
r5#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     157.10.0.0/28 is subnetted, 1 subnets
C 157.10.1.208 is directly connected, Loopback157
     172.16.0.0/16 is variably subnetted, 13 subnets, 2 masks
R 172.16.148.0/24 [120/3] via 172.16.53.3, 00:00:07, Ethernet0/0
R 172.16.149.0/24 [120/3] via 172.16.53.3, 00:00:07, Ethernet0/0
R 172.16.144.0/24 [120/1] via 172.16.53.3, 00:00:07, Ethernet0/0
R 172.16.145.0/24 [120/1] via 172.16.53.3, 00:00:07, Ethernet0/0
R 172.16.146.0/24 [120/1] via 172.16.53.3, 00:00:07, Ethernet0/0
R 172.16.52.0/24 [120/1] via 172.16.53.3, 00:00:09, Ethernet0/0
C 172.16.53.0/24 is directly connected, Ethernet0/0
C 172.16.50.28/30 is directly connected, Loopback1
C 172.16.50.24/30 is directly connected, Loopback0
C 172.16.50.32/30 is directly connected, Loopback2
R 172.16.10.0/24 [120/1] via 172.16.53.3, 00:00:00, Ethernet0/0
C 172.16.110.0/24 is directly connected, Loopback11 <<<--- RIP route
C 172.16.100.0/24 is directly connected, Loopback10 <<<--- RIP route
r5#

>From: "Jeff Szeto" <jytszeto@hotmail.com>
>Reply-To: "Jeff Szeto" <jytszeto@hotmail.com>
>To: <ccielab@groupstudy.com>
>Subject: Redistribute ospf external route into igrp
>Date: Wed, 8 May 2002 16:20:28 +0800
>
>Hi,
>
>A router runs IGRP, OSPF and RIP. Mutual redistribution exist between
>OSPF---RIP and OSPF---IGRP. But no redistribution between IGRP and RIP.
>From the debug message I found that IGRP is no advertising the RIP routes
>that are redistributed into OSPF while the OSPF routes are advertised
>normally.
>On the other hand, the IGRP routes are advertised into RIP through OSPF.
>
>Could someone explain the concept behind or point me to a document.
>
>Thanks in advance.
>
>Jeff



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:53 GMT-3