RE: IBGP HELP??

From: Brian McGahan (brian@xxxxxxxxxxxxxxx)
Date: Mon May 06 2002 - 19:50:58 GMT-3


   
Jason,

        The config is fine, but the BGP session is in race state. This
is exactly how it is supposed to act. If you 'debub ip routing' on R1
you get:

Router1#ping 165.40.23.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.40.23.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
Router1#
1w0d: RT: Nexthop for 165.40.22.0/23 updated
1w0d: RT: recursion error routing 165.40.23.1 - probable routing loop

Router1#ping 165.40.23.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.40.23.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
1w0d: RT: recursion error routing 165.40.23.1 - probable routing loop
1w0d: RT: Nexthop for 165.40.22.0/23 updated
Router1#ping 165.40.23.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.40.23.1, timeout is 2 seconds:
!!!!!

BGP cannot depend on itself for connectivity like this, hence the
session is in race state. Take a look at R1's routing table while the
session is in race.

     165.40.0.0/23 is subnetted, 1 subnets
B 165.40.22.0 [200/0] via 165.40.23.1, 00:00:19

That's a recursive loop, it's like saying:

Ip route 1.1.1.1 255.255.255.255 1.1.1.1

This is the reason you need a full *physical* iBGP mesh, or an IGP to
provide underlying BGP transport.

BTW, the 'next-hop-self' command on R1 isn't doing anything. That's
only for modifying the next-hop for EBGP learned routes.

HTH

Brian McGahan
CCIE #8593
brian@cyscoexpert.com

CyscoExpert Corporation
Internetwork Consulting & Training
http://www.cyscoexpert.com
Voice: 847.674.3392
Fax: 847.674.2625

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Jason Wydra
Sent: Monday, May 06, 2002 4:37 PM
To: Logan, Harold; Carlos G Mendioroz
Cc: Groupstudy ccielab list
Subject: RE: IBGP HELP??

 CONFIGS
R1
interface TokenRing0/0
 ip address 204.156.20.5 255.255.255.252
 ring-speed 16
!
interface BRI0/0
 no ip address
 shutdown
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
!
interface Serial0/1
 no ip address
 shutdown
!
interface FastEthernet1/0
 ip address 204.156.20.2 255.255.255.252
 shutdown
 duplex auto
 speed auto
!
router bgp 3127
 no synchronization
 bgp log-neighbor-changes
 network 204.156.20.4 mask 255.255.255.252
 neighbor 165.40.23.1 remote-as 3127
 neighbor 204.156.20.6 remote-as 3127
 neighbor 204.156.20.6 next-hop-self

R2
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface TokenRing0/0
 ip address 204.156.20.6 255.255.255.252
interface BRI0/0
!
interface BRI0/0
 no ip address
 shutdown
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
!
interface Serial0/1
 no ip address
 shutdown
!
interface FastEthernet1/0
 ip address 165.40.23.0 255.255.254.0
 shutdown
 duplex auto
 speed auto
!
router bgp 3127
 no synchronization
 bgp log-neighbor-changes
 network 165.40.22.0 mask 255.255.254.0
 network 204.156.20.4 mask 255.255.255.252
 neighbor 165.40.23.1 remote-as 3127
 neighbor 204.156.20.5 remote-as 3127
R3
interface Ethernet0/0
 ip address 165.40.23.1 255.255.254.0
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 no fair-queue
 shutdown
 no fair-queue
 frame-relay lmi-type cisco
!
interface BRI0/0
 ip unnumbered Ethernet0/0
 encapsulation ppp
 shutdown
 timeout absolute 35000 0
 dialer idle-timeout 2147483
 dialer map ip 204.156.20.1 5340
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 01532001 5320
 isdn spid2 01532101 5321
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
!
interface Serial0/1
 no ip address
 shutdown
!
router bgp 3127
 no synchronization
 bgp log-neighbor-changes
 network 165.40.22.0 mask 255.255.254.0
 neighbor 165.40.23.0 remote-as 3127
 neighbor 204.156.20.5 remote-as 3127
!
  "Logan, Harold" <loganh@mccfl.edu> wrote: Would you please post your
bgp configs? It would make the discussion a bit easier.

Hal

-----Original Message-----
From: Jason Wydra [mailto:jasonwydra@yahoo.com]
Sent: Monday, May 06, 2002 4:01 PM
To: Carlos G Mendioroz
Cc: Groupstudy ccielab list
Subject: Re: IBGP HELP??

I'm not running an IGP yet R1 learns about R3 via R2. I have a network
statement on R2 for both links to R1 and R2. R1 has the route to R3 in
its bgp and ip route table. R3 learns nothing from R2 about networks on
the R1 side. Need to put a static route in on R3 pointing to R2 as next
hop for the TCP connection to come up.
Carlos G Mendioroz wrote: Jason,
What IGP are you running ?
How is R1 supposed to learn how to reach R3 ?

Remember that iBGP will never (well almost never *) relay
information, so you need some IGP to do that.

(Hmm, you said that R1 has learned via BGP the 165.40.22.0/23,
so it has to be originated at R2, may be by a network command.
Do you have a simmilar network command for the 204.156.20.0/30 ?)

(*) The "almost never" relates to setups like route reflectors,
where you get a controlled iBGP redistribution.

HTH.

Jason Wydra wrote:
>
> I have AS 3127 with 3 routers. R1 is connected to R2 via Token ring.
R2 is connected to R3 via Ethernet. R1 and R3 do not have a direct
connection. They are attempting to peer through R2. R1 and R2 neighbor
states are active. R2 and R3 neighbor state is active. R1 and R3
neighbor state will NOT come up. The network on link between R1 and R2
is 204.156.20.0/30 and network between R2 and R3 is 165.40.22.0/23. From
R1 I CANNOT ping R3. R1 has learned a route from BGP to R3. Looking on
R3 it has not learned a route to R1 (From R2). This is obviously why I
cannot ping from R1 to R3 and this is also why the BGP peer won't come
up. Simply adding a static route on R3 pointing to R1 solves the problem
and my BGP peers comes up. My question is why does R2 tell R1 about the
165 network but R2 does not tell R3 about the 204 network? Why do I have
to add a static to R3? Please help!!
>
> Jason Wydra
>
> CCNP,CCDP
>
> ---------------------------------
> Do You Yahoo!?
> Yahoo! Health - your guide to health and wellness



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:51 GMT-3