Re: Match Statement in Route-map

From: Jason Gardiner (gardiner@xxxxxxxxxx)
Date: Sun May 05 2002 - 14:01:13 GMT-3


   
Only if it matches one of the conditions:

access-list 11 permit 155.100.7.0 0.0.0.255
access-list 12 permit 155.100.77.0 0.0.0.255

route-map test permit 10
 match ip address 11 12 <--Commands entered separately
 set as-path prepend 2 2 2 2
route-map test permit 20

This produced the following output:

   Network Next Hop Metric LocPrf Weight Path
* 155.100.7.0/24 155.100.7.7 0 0 2 2 2 2 2 i
* 155.100.77.0/24 155.100.7.7 0 0 2 2 2 2 2 i
* 155.100.177.0/24 155.100.7.7 0 0 2 i

Thanks,

Jason Gardiner
Supervisor, Engineering Services
Sprint Internet Backbone Operations

"You can swim all day in the Sea of Knowledge and
still come out completely dry. Most people do."

  Norton Juster

On Sun, 5 May 2002, Nick Shah wrote:

> Ok, tell me how would you interpret this route map...
>
> route-map ABC permit 10
> match ip address 101
> match ip address 102
> set as-path prepend xxxx
> route-map ABC permit 20
>
> Wont these multiple match statements cause the route-map to compare the ip
> prefix in question to *both* the access lists and only if they match is the
> as-path prepended ? Thats how I understand it (correct me if I am wrong)
>
> If in doubt check Doyle Part I, page 812.
>
> Further proof of my understanding...
>
> http://127.0.0.1:8080/cc/td/doc/product/software/ios121/121cgcr/ip_c/ipcprt2
> /1cdindep.htm#xtocid2851338
>
> //snip//
>
> The following example redistributes OSPF intra-area and interarea routes
> with next hop routers on serial interface 0 into BGP with an INTER_AS metric
> of 5:
>
> router bgp 109
> redistribute ospf 109 route-map 10
> !
> route-map 10 permit
> match route-type internal
> match interface serial 0
> set metric 5
>
>
> //snip//
>
> *both* conditions should match (the route type must be intra area/inter area
> + next hop out to serial0)
>
> Thanks
> Nick
> -----Original Message-----
> From: elpingu <elping@acedsl.com>
> To: Nick Shah <nshah@connect.com.au>
> Cc: ccielab@groupstudy.com <ccielab@groupstudy.com>
> Date: Saturday, 4 May 2002 3:42
> Subject: Re: Match Statement in Route-map
>
>
> >hey you might want to read carefully next time
> >
> >this is what you wrote
> >
> >"so CCO says if one condition doesnt match, route is ignored, that will be
> an
> >AND operation."
> >
> >your statement is true and it would be an AND due to "one condition doesnt
> >match, route is ignored" but that is not what CCO says ..that is what you
> >wrote
> >
> >
> >this is what CCO says
> >"Any route that does not match at least one match clause relating to a
> >route-map command will be ignored;"
> >
> >This statement is an OR due to "at least one match"
> >
> >Ping
> >
> >
> >Nick Shah wrote:
> >
> >> well, it would certainly mean an AND operation, wont it ?
> >>
> >> for eg.
> >>
> >> if xyz matches conditionB....
> >> & xyz matches conditionB
> >> set clauses .....
> >>
> >> so CCO says if one condition doesnt match, route is ignored, that will be
> an
> >> AND operation.
> >>
> >> Nick
> >> ----- Original Message -----
> >> From: "elpingu" <elping@acedsl.com>
> >> To: "Krishnan Narayanan" <krishnan.narayanan@cwgoindia.com>
> >> Cc: <ccielab@groupstudy.com>
> >> Sent: Friday, May 03, 2002 12:38 PM
> >> Subject: Re: Match Statement in Route-map
> >>
> >> > you know ....always have read it as an OR clause.
> >> > read below from cco
> >> >
> >> > . Any route that does not match at least one match clause relating to a
> >> route-map command will be ignored;
> >> >
> >> > just to be sure i get it right .....I make two route maps to refer to
> my
> >> clauses.
> >> >
> >> > Ping
> >> >
> >> > Krishnan Narayanan wrote:
> >> >
> >> > > If I have multiple match statements in a route-map ,is an AND
> operation
> >> performed or an OR opertion done ?
> >> > >
> >> > > Thanks
> >> > > KRis.



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:50 GMT-3