RE: EIGRP-->IGRP Redistribution (Link Missing on IGRP Router)

From: Jenkins, Buddy (buddy.jenkins@xxxxxxxx)
Date: Tue Apr 30 2002 - 03:21:56 GMT-3


   
Do a search on group study archive for this topic

OSPF;IGRP;REDISTRIBUTION

You will see many threads about your problem. Be sure to pick one thread and f
ollow it through from start to finish. What you will find out is that since IG
RP is classfull and EIGRP is classless the 25 bit mask that you have on the fra
me relay 0.256 interface does not "fit" into the IGRP 24 bit interface. Your c
hallenge is to make this route with a 25 bit mask fit into a classful protocol
like IGRP. This is probably the most important concept you will need to grasp.
  This redistribution of vlsm masks will appear time and time again from RIP <-
> OSPF, EIGRP <-> IGRP, etc. There are many ways to solve this problem and I w
ould reccomend knowing all of them very well.

Buddy

-----Original Message-----
From: CCIE2B [mailto:ccie2b@cox.net]
Sent: Tuesday, April 30, 2002 2:29 PM
To: ccielab@groupstudy.com
Subject: EIGRP-->IGRP Redistribution (Link Missing on IGRP Router)

All,

I am redistributing EIGRP into IGRP on R2, they have different AS #s. On the
IGRP router R4, I see all the redistributed routes except the interface for
the frame-relay network on R2. The line between the R2 and R4 router is frame
relay P2P. Here are the config's hopefully it will help. TIA
Router 2
R2#wr t
interface Loopback0
 ip address 200.200.200.2 255.255.255.255
!
interface Ethernet0
 ip address 150.50.17.2 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.24 point-to-point
 ip address 150.50.24.2 255.255.255.0
 no ip route-cache
 no ip split-horizon
 no ip mroute-cache
 frame-relay interface-dlci 104
!
interface Serial0.256 multipoint
 ip address 150.50.100.2 255.255.255.224
 no ip route-cache
 no ip split-horizon
 no ip mroute-cache
 frame-relay interface-dlci 105
 frame-relay interface-dlci 106
!
interface BRI0
 ip address 150.50.9.2 255.255.255.192
!
router eigrp 1
 redistribute igrp 2
 passive-interface Serial0.24
 network 150.50.9.0 0.0.0.63
 network 150.50.17.0 0.0.0.255
 network 150.50.24.0 0.0.0.255
 network 150.50.100.0 0.0.0.31
 network 200.200.200.2 0.0.0.0
 default-metric 1500 10 255 1 1500
 no auto-summary
 no eigrp log-neighbor-changes
!
router igrp 2
 redistribute eigrp 1
 passive-interface Serial0.256
 network 150.50.0.0
 default-metric 10000 10 255 1 1500

R2#sh ip route
     200.200.200.0/24 is variably subnetted, 2 subnets, 2 masks
I 200.200.200.0/24 [100/8976] via 150.50.24.4, 00:00:51, Serial0.24
C 200.200.200.2/32 is directly connected, Loopback0
     172.16.0.0/21 is subnetted, 1 subnets
D 172.16.32.0 [90/2297856] via 150.50.100.6, 00:03:07, Serial0.256
I 10.0.0.0/8 [100/8486] via 150.50.24.4, 00:00:51, Serial0.24
     150.50.0.0/16 is variably subnetted, 8 subnets, 4 masks
D 150.50.200.0/24 [90/307200] via 150.50.17.1, 00:03:07, Ethernet0
D 150.50.6.0/25 [90/2681856] via 150.50.100.6, 00:03:08, Serial0.256
D 150.50.7.0/25 [90/2195456] via 150.50.100.6, 00:03:08, Serial0.256
                      [90/2195456] via 150.50.100.5, 00:03:08, Serial0.256
C 150.50.9.0/26 is directly connected, BRI0
C 150.50.17.0/24 is directly connected, Ethernet0
D 150.50.18.0/24 [90/729600] via 150.50.17.1, 00:03:09, Ethernet0
C 150.50.24.0/24 is directly connected, Serial0.24
C 150.50.100.0/27 is directly connected, Serial0.256
R2#

R2#sh ip eigrp top
P 10.0.0.0/8, 1 successors, FD is 2172416
         via Redistributed (2172416/0)
P 150.50.200.0/24, 1 successors, FD is 307200
         via 150.50.17.1 (307200/281600), Ethernet0
P 172.16.32.0/21, 1 successors, FD is 2297856
         via 150.50.100.6 (2297856/128256), Serial0.256
P 150.50.6.0/25, 1 successors, FD is 2681856
         via 150.50.100.6 (2681856/2169856), Serial0.256
P 150.50.7.0/25, 2 successors, FD is 2195456
         via 150.50.100.5 (2195456/281600), Serial0.256
         via 150.50.100.6 (2195456/281600), Serial0.256
P 150.50.9.0/26, 1 successors, FD is 40512000
         via Connected, BRI0
P 150.50.17.0/24, 1 successors, FD is 281600
         via Connected, Ethernet0
P 150.50.18.0/24, 1 successors, FD is 729600
         via 150.50.17.1 (729600/704000), Ethernet0
P 150.50.24.0/24, 1 successors, FD is 2169856
          via Connected, Serial0.24
P 150.50.100.0/27, 1 successors, FD is 2169856
         via Connected, Serial0.256
P 200.200.200.0/24, 1 successors, FD is 2297856
         via Redistributed (2297856/0)
P 200.200.200.2/32, 1 successors, FD is 128256
         via Connected, Loopback0
R2#
ROUTER 4
R4#
interface Loopback0
 ip address 200.200.200.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0
!
interface Serial0/0
 ip address 150.50.24.4 255.255.255.0
 encapsulation frame-relay IETF
 ip split-horizon
 no fair-queue
 clockrate 64000
 frame-relay lmi-type ansi
!
router igrp 2
 passive-interface FastEthernet0/0
 network 10.0.0.0
 network 150.50.0.0
!

R4#sh ip route
     200.200.200.0/24 is variably subnetted, 2 subnets, 2 masks
I 200.200.200.0/24 is possibly down,
          routing via 150.50.24.2, Serial0/0
C 200.200.200.4/32 is directly connected, Loopback0
I 172.16.0.0/16 [100/10976] via 150.50.24.2, 00:00:32, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
     150.50.0.0/24 is subnetted, 4 subnets
I 150.50.200.0 [100/8676] via 150.50.24.2, 00:00:32, Serial0/0
I 150.50.17.0 [100/8576] via 150.50.24.2, 00:00:34, Serial0/0
I 150.50.18.0 [100/8826] via 150.50.24.2, 00:00:34, Serial0/0
C 150.50.24.0 is directly connected, Serial0/0
R4#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:22 GMT-3