RE: Router announce wrong metric afer redist connected at igrp (was: IGRP announced metric question. )

From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Fri Apr 26 2002 - 00:10:10 GMT-3


   
In case you cannot change the setup, then don't redistribute connected into IGR
P. Advertise these connected network in the other routing process and then redi
strbute back to IGRP...

> Parry Chua
>
>

-----Original Message-----
From: Katson PN Yeung [mailto:kyeung@hkcix.com]
Sent: Friday, April 26, 2002 11:00 AM
To: ying chang; Chua, Parry; ccielab@groupstudy.com
Subject: RE: Router announce wrong metric afer redist connected at igrp
(was: IGRP announced metric question. )

Hi, according to your findings, I did another tests with the following config:

                  |Lo10 (10.10.10.1/24)
                  |
               E0|--------|
            -----| 2514 |---Lo150 (150.10.10.1/24)
201.10.10.1/24 |--------|
                    |
                    |Lo192 (192.168.10.1/24)

router igrp 3
  redistribute connected metric 2000 100 255 1 1500 route-map connected-2-igrp
  network 201.10.10.0
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 150.10.0.0 0.0.255.255
access-list 1 permit 192.168.10.0 0.0.0.255

route-map connected-2-igrp permit 10
  match ip address 1

Test 1.
---------------------------------------------------------------------------
Regardless of whatever IP and subnet I choose for E0, I get this:

1d17h: IGRP: sending update to 255.255.255.255 via Ethernet0 (201.10.10.1)
1d17h: network 192.168.10.0, metric=5100
1d17h: network 10.0.0.0, metric=501
1d17h: network 150.10.0.0, metric=501
1d17h: IGRP: Update contains 0 interior, 3 system, and 0 exterior routes.
1d17h: IGRP: Total routes in update: 3

Test 2.
---------------------------------------------------------------------------
But when I change the Lo10, Lo150, and Lo192 netmask to align with the
classful boundry, I get this:

1d18h: IGRP: sending update to 255.255.255.255 via Ethernet0 (201.10.10.1)
1d18h: network 192.168.10.0, metric=5100
1d18h: network 10.0.0.0, metric=5100
1d18h: network 150.10.0.0, metric=5100
1d18h: IGRP: Update contains 0 interior, 3 system, and 0 exterior routes.
1d18h: IGRP: Total routes in update: 3

Conclusion:
When there are redistribute connected in IGRP, the metric of the
redistributed
route will follow the redistribution metric only if the interface in question
align with the natural mask. Otherwise, the resulting metric will be
calculated
based on the Bandwidth and Delay specified on the interface being
redistributed.

This phenomenon does not occur in EIGRP.

Rgds,
K a t s o n

At 05:59 AM 4/26/2002, ying chang wrote:
>What I found is the metric specified in the redistribute connected will
>not work when you redistribute a /16 or /8 network in /24 igrp domain. To
>get the desired metric, you can change the bandwidth and delay at the
>interface level. Please see below:
>
>======================================================
>**** 70.0.0.0/24, 197.7.7.0/24 and 192.168.7.0 will be
>**** redistributed via redistribute connected in igrp
>**** network 133.10.0.0
>
>!
>interface Loopback70
>ip address 70.70.70.1 255.255.255.0
>!
>interface Loopback77
>ip address 197.7.7.7 255.255.255.0
>!
>interface Ethernet0
>ip address 192.168.7.1 255.255.255.0
>!
>interface Serial0
>ip address 133.10.26.7 255.255.255.0
>no fair-queue
>!
>!
>router igrp 100
>timers basic 10 30 30 60
>redistribute connected metric 1000 10 255 1 1500 route-map r7
>network 133.10.0.0
>!
>access-list 7 permit 192.168.7.0 0.0.0.255
>access-list 7 permit 197.7.7.0 0.0.0.255
>access-list 7 permit 70.0.0.0 0.255.255.255
>route-map r7 permit 10
>match ip address 7
>!
>-----------------------------------------------------------------
>**** 70.0.0.0 did not use metric specified in the redist connected
>**** 192.168.7.0 and 197.7.7.0 have no problems
>
>r7#debug ip igrp tran
>IGRP protocol debugging is on
>r7#
>IGRP: sending update to 255.255.255.255 via Serial0 (133.10.26.7)
> network 70.0.0.0, metric=501 <<<<--- not affected
> network 192.168.7.0, metric=10010 <<<<--- OK
> network 197.7.7.0, metric=10010 <<<<--- OK
>=================================================================
>***** change bandwidth from to 2000 to 1000 in redist connected
>***** 70.0.0.0 stay the same, but subnet 192 and 197 are changed
>!
>router igrp 100
>timers basic 10 30 30 60
>redistribute connected metric 2000 10 255 1 1500 route-map r7
>network 133.10.0.0
>!
>
>r7#debug ip igrp trans
>IGRP protocol debugging is on
>r7#
>IGRP: sending update to 255.255.255.255 via Serial0 (133.10.26.7)
> network 70.0.0.0, metric=501 <<<<---- not affected
> network 192.168.7.0, metric=5010 <<<<--- changed accordingly
> network 197.7.7.0, metric=5010 <<<<--- changed accordingly
>==================================================================
>***** Change bandwidth and delay in the interface
>***** Now 70.0.0.0 has the same metric as subnet 192 and 197
>!
>interface Loopback70
>ip address 70.70.70.1 255.255.255.0
>bandwidth 2000 <<<<----
>delay 10 <<<<----
>!
>
>r7#debug ip igrp trans
>IGRP protocol debugging is on
>r7#
>IGRP: sending update to 255.255.255.255 via Serial0 (133.10.26.7)
> network 70.0.0.0, metric=5010 <<<<--- changed
> network 192.168.7.0, metric=5010 <<<<--- changed from redis conn
> network 197.7.7.0, metric=5010 <<<<--- changed from redis conn
>=====================================================================
>
>
>
>
>
>
>
>
>>From: "Chua, Parry" <Parry.Chua@compaq.com>
>>Reply-To: "Chua, Parry" <Parry.Chua@compaq.com>
>>To: "Katson PN Yeung" <kyeung@hkcix.com>, <ccielab@groupstudy.com>
>>Subject: RE: Router announce wrong metric afer redist connected at igrp
>>(was: IGRP announced metric question. )
>>Date: Thu, 25 Apr 2002 12:26:47 +0800
>>
>>Try create a static route and do redistribute the static , it will work
>>correctly. It sould like when redistribute connected, it take the metric
>>as the base.
>>
>> > Parry Chua
>> >
>> >
>>
>>
>>-----Original Message-----
>>From: Katson PN Yeung [mailto:kyeung@hkcix.com]
>>Sent: Thursday, April 25, 2002 11:12 AM
>>To: ccielab@groupstudy.com
>>Subject: Router announce wrong metric afer redist connected at igrp
>>(was: IGRP announced metric question. )
>>
>>
>>Dear Group,
>>
>>It seems that my previous "igrp metric" does not draw your attention. So I
>>did more tests to find out... I am using 12.1.12a
>>
>>
>>
>>|-----|s0 s1|-----|
>>| R5 |-----| R8 |---E0
>>| | | |
>>|-----| |-----|
>> | |
>> | ( )
>> Lo0 tok0
>>
>>
>>both R5 and R8 are igrp only router. Both running 12.1.12a
>>
>>Interface BW Delay (usec) IP
>>--------- ------ ------------ -------------------
>>R5 s0 1544K 20000 172.168.200.5/24
>>R8 s1 64K 20000 172.168.200.8/24
>>R8 Lo0 8000000K 5000 160.10.10.1/24
>>R8 Tok 0 16000K 630 172.168.80.1/24
>>R8 E0 1000K 1000 172.168.48.1/24
>>
>>
>>
>>
>>Test 1.
>>---------------------------------------------------------
>>- R8 With this config:
>>router igrp 3
>> redistribute connected metric 2000 100 255 1 1500 route-map
>> connected-2-igrp
>> network 172.168.0.0
>>!
>>access-list 2 permit 160.10.10.0 0.0.0.255
>>access-list 3 deny any
>>!
>>route-map connected-2-igrp permit 10
>> match ip address 2
>>!
>>route-map connected-2-igrp permit 20
>> match ip address 3
>>
>>
>>Result: (debug igrp at R5)
>>2d22h: IGRP: received update from 172.168.200.8 on Serial1.2
>>2d22h: subnet 172.168.48.0, metric 8576 (neighbor 5100)
>>2d22h: subnet 172.168.80.0, metric 8576 (neighbor 5100)
>>2d22h: network 165.10.0.0, metric 8976 (neighbor 501)
>>2d22h: IGRP: Update contains 2 interior, 3 system, and 0 exterior routes.
>>2d22h: IGRP: Total routes in update: 5
>>
>>
>>R8 announce 5100 for tok0 and E0, 501 for lo0
>>
>>
>>
>>Test 2.
>>---------------------------------------------------------
>>R8 with this config
>>
>>router igrp 3
>> network 172.168.0.0
>>
>>
>>Result: (debug igrp at R5)
>>2d23h: IGRP: received update from 172.168.200.8 on Serial1.2
>>2d23h: subnet 172.168.48.0, metric 12100 (neighbor 10100)
>>2d23h: subnet 172.168.80.0, metric 8539 (neighbor 688)
>>
>>
>>
>>
>>
>>Questions:
>>---------------------------------------------------------
>>1. In test 1 the intention is to redistribute Lo0 to igrp and set it's
>>metric according to my redistribute metric (2000 100 255 1 1500) = 5100.
>>However it uses it own interface metric 501.
>>
>>2. In test 1, the route-map is to confine the redistribution to Lo0, while
>>leaving other interface (tok0, E0) untouched. However, E0 and Tok0 metrics
>>are changed to the 5100 (2000 100 255 1 1500, specified at the redis
>>connected line.)
>>
>>3. In test 2, I just erase the "redis connected" and do a "clear ip route
>>*". R8 announce metric back to normal!!! (10100 for E0 amd 688 for Tok0)
>>
>>
>>Can some people tell me why??
>>
>>I suppose, in igrp, redistribute connected actually first include *ALL*
>>connected interfaces and set it's metrics according to the redis command
>>line. Then it processes the route-map part, and mport the right connected
>>interface to the route table....
>>
>>But why the redistributed route metric does not affected the connected
>>route?? Really clueless.
>>
>>Maybe I will try to do it again with EIGRP.
>>
>>Rgds,
>>K a t s o n
>>-----
>>Chinalink Networks Limited.
>>voice: (852)2159 6818 fax: (852)2159 6999
>>Let's fight against the evil scumware:
>>http://www.whirlywiryweb.com/q/ezula.asp



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:20 GMT-3