From: Katson PN Yeung (kyeung@xxxxxxxxx)
Date: Thu Apr 25 2002 - 01:48:20 GMT-3
I redo test1 using EIGRP with the very same config. I got the answer below:
(note: the redis metric, route-map and access-list are the same!)
R8
router eigrp 3
redistribute connected metric 2000 100 255 1 1500 route-map connected-2-igrp
network 172.168.0.0
auto-summary
no eigrp log-neighbor-changes
!
access-list 2 permit 160.10.10.0 0.0.0.255
access-list 3 deny any
!
route-map connected-2-igrp permit 10
match ip address 2
!
route-map connected-2-igrp permit 20
match ip address 3
Then what I can see at R5:
R5#sh ip eigrp top 3
IP-EIGRP Topology Table for AS(3)/ID(137.55.55.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.168.48.0/24, 1 successors, FD is 3097600
via 172.168.200.8 (3097600/2585600), Serial1.2
P 172.168.80.0/24, 1 successors, FD is 2185984
via 172.168.200.8 (2185984/176128), Serial1.2
P 160.10.10.0/24, 1 successors, FD is 2195456
via 172.168.200.8 (2195456/1305600), Serial1.2
P 172.168.200.0/24, 1 successors, FD is 2169856
via Connected, Serial1.2
Route 172.168.48.0
FD 3097600 = 256 x ((10^7 / 1000) + 2000 + 100)
R8 Announced 2585600 = 256 x ((10^7 /1000) + 100)
Route 172.168.80.0
FD 2185984 = 256 x ((10^7 / 1544) + 2000 + 63)
R8 Announced 176128 = 256 x (( 10^7 / 16000) + 63)
Route 160.10.10.0
FD 2195456 = 256 x ((10^7 / 1544) + 2000 + 100)
R8 Announced 1305600 = 256 x ((10^7 / 2000) + 100)
Therefore, the redis connected route-map and metric are behave differently
in EIGRP.
Maybe, it is a bug in 12.1.12a.
At 11:12 AM 4/25/2002, Katson PN Yeung wrote:
>Dear Group,
>
>It seems that my previous "igrp metric" does not draw your attention. So I
>did more tests to find out... I am using 12.1.12a
>
>
>
>|-----|s0 s1|-----|
>| R5 |-----| R8 |---E0
>| | | |
>|-----| |-----|
> | |
> | ( )
> Lo0 tok0
>
>
>both R5 and R8 are igrp only router. Both running 12.1.12a
>
>Interface BW Delay (usec) IP
>--------- ------ ------------ -------------------
>R5 s0 1544K 20000 172.168.200.5/24
>R8 s1 64K 20000 172.168.200.8/24
>R8 Lo0 8000000K 5000 160.10.10.1/24
>R8 Tok 0 16000K 630 172.168.80.1/24
>R8 E0 1000K 1000 172.168.48.1/24
>
>
>
>
>Test 1.
>---------------------------------------------------------
>- R8 With this config:
>router igrp 3
> redistribute connected metric 2000 100 255 1 1500 route-map connected-2-igrp
> network 172.168.0.0
>!
>access-list 2 permit 160.10.10.0 0.0.0.255
>access-list 3 deny any
>!
>route-map connected-2-igrp permit 10
> match ip address 2
>!
>route-map connected-2-igrp permit 20
> match ip address 3
>
>
>Result: (debug igrp at R5)
>2d22h: IGRP: received update from 172.168.200.8 on Serial1.2
>2d22h: subnet 172.168.48.0, metric 8576 (neighbor 5100)
>2d22h: subnet 172.168.80.0, metric 8576 (neighbor 5100)
>2d22h: network 165.10.0.0, metric 8976 (neighbor 501)
>2d22h: IGRP: Update contains 2 interior, 3 system, and 0 exterior routes.
>2d22h: IGRP: Total routes in update: 5
>
>
>R8 announce 5100 for tok0 and E0, 501 for lo0
>
>
>
>Test 2.
>---------------------------------------------------------
>R8 with this config
>
>router igrp 3
> network 172.168.0.0
>
>
>Result: (debug igrp at R5)
>2d23h: IGRP: received update from 172.168.200.8 on Serial1.2
>2d23h: subnet 172.168.48.0, metric 12100 (neighbor 10100)
>2d23h: subnet 172.168.80.0, metric 8539 (neighbor 688)
>
>
>
>
>
>Questions:
>---------------------------------------------------------
>1. In test 1 the intention is to redistribute Lo0 to igrp and set it's
>metric according to my redistribute metric (2000 100 255 1 1500) = 5100.
>However it uses it own interface metric 501.
>
>2. In test 1, the route-map is to confine the redistribution to Lo0, while
>leaving other interface (tok0, E0) untouched. However, E0 and Tok0 metrics
>are changed to the 5100 (2000 100 255 1 1500, specified at the redis
>connected line.)
>
>3. In test 2, I just erase the "redis connected" and do a "clear ip route
>*". R8 announce metric back to normal!!! (10100 for E0 amd 688 for Tok0)
>
>
>Can some people tell me why??
>
>I suppose, in igrp, redistribute connected actually first include *ALL*
>connected interfaces and set it's metrics according to the redis command
>line. Then it processes the route-map part, and mport the right connected
>interface to the route table....
>
>But why the redistributed route metric does not affected the connected
>route?? Really clueless.
>
>Maybe I will try to do it again with EIGRP.
>
>Rgds,
>K a t s o n
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:19 GMT-3