From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Mon Apr 22 2002 - 21:42:10 GMT-3
I think this is more neat and correct than just looking for a missing route. Mi
ssing route does not
ensure that the backup route is available. Only when backup route is present th
an it is make sense to use it for other policy control..
> Parry Chua
>
>
-----Original Message-----
From: ying chang [mailto:ying_c@hotmail.com]
Sent: Monday, April 22, 2002 9:42 PM
To: yesmat@iprimus.com.au; bsin@erols.com
Cc: ccielab@groupstudy.com
Subject: RE: OSPF Conditional Default Origination
Ya,
I did see the problem when I shut the frame relay link with your config. But
we have more than one way to do things, please see below and give it a try
and let me know if it works for you:
r1#sb router ospf
router ospf 100
router-id 192.168.200.1
log-adjacency-changes
redistribute igrp 100 subnets tag 2 route-map igrp-routes
network 133.10.2.1 0.0.0.0 area 0
network 133.10.5.1 0.0.0.0 area 0
network 133.10.6.1 0.0.0.0 area 0
neighbor 133.10.2.4
neighbor 133.10.2.3
default-information originate always route-map check-isdn-route
distance 125 133.10.3.2 0.0.0.0
!
route-map check-isdn-route permit 10
match ip address sub192 <<-- a route can be picked up by isdn
match ip next-hop isdn-link <<-- when frame relay dies
!
ip access-list standard sub192
permit 192.168.1.0 0.0.0.255
!
ip access-list standard isdn-link
permit 133.10.5.5 <<<--- next hop isdn address
!
----------------------------------------
Frame Relay is up and running (192.168.1.0) go through S0.1:
r1#sir
Gateway of last resort is not set
192.168.200.0/32 is subnetted, 1 subnets
C 192.168.200.1 is directly connected, Loopback192
128.200.0.0/24 is subnetted, 1 subnets
C 128.200.1.0 is directly connected, Loopback128
160.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
B 160.100.128.0/22 [200/0] via 133.10.3.2, 01:15:22
I 160.100.0.0/16 [100/8576] via 133.10.3.2, 00:00:01, Serial0.2
O E2 192.190.102.0/24 [110/20] via 133.10.2.3, 00:03:52, Serial0.1
133.10.0.0/16 is variably subnetted, 11 subnets, 3 masks
C 133.10.6.0/24 is directly connected, Serial1
C 133.10.5.0/24 is directly connected, BRI0
C 133.10.3.0/24 is directly connected, Serial0.2
C 133.10.2.0/24 is directly connected, Serial0.1
C 133.10.5.5/32 is directly connected, BRI0
I 133.10.17.0/24 [100/160250] via 133.10.3.2, 00:00:03, Serial0.2
O IA 133.10.51.0/24 [110/70] via 133.10.2.4, 00:03:55, Serial0.1
O IA 133.10.49.0/26 [110/212] via 133.10.2.4, 00:03:55, Serial0.1
O IA 133.10.49.0/24 [110/128] via 133.10.2.4, 00:03:55, Serial0.1
O IA 133.10.65.0/26 [110/148] via 133.10.2.4, 00:03:55, Serial0.1
O IA 133.10.65.0/24 [110/138] via 133.10.2.4, 00:03:55, Serial0.1
O IA 192.168.1.0/24 [110/139] via 133.10.2.4, 00:03:55, Serial0.1 <<<--
r1#
----------------------------------------------
shut down s0.1 from frame relay switch:
r10-frsw#sh frame route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 110 Serial1/1 111 active
Serial1/0 120 Serial1/2 121 inactive
Serial1/0 130 Serial1/3 131 inactive
Serial1/1 111 Serial1/0 110 active
Serial1/2 121 Serial1/0 120 active
Serial1/3 131 Serial1/0 130 active
r10-frsw#
----------------------------------------------
ISDN kicks in:
r1#sir
Gateway of last resort is not set
192.168.200.0/32 is subnetted, 1 subnets
C 192.168.200.1 is directly connected, Loopback192
128.200.0.0/24 is subnetted, 1 subnets
C 128.200.1.0 is directly connected, Loopback128
160.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
B 160.100.128.0/22 [200/0] via 133.10.3.2, 01:18:22
I 160.100.0.0/16 [100/8576] via 133.10.3.2, 00:00:05, Serial0.2
133.10.0.0/16 is variably subnetted, 10 subnets, 3 masks
C 133.10.6.0/24 is directly connected, Serial1
C 133.10.5.0/24 is directly connected, BRI0
C 133.10.3.0/24 is directly connected, Serial0.2
C 133.10.5.5/32 is directly connected, BRI0
I 133.10.17.0/24 [100/160250] via 133.10.3.2, 00:00:06, Serial0.2
O IA 133.10.51.0/24 [110/10079] via 133.10.5.5, 00:01:14, BRI0
O IA 133.10.49.0/26 [110/10073] via 133.10.5.5, 00:01:14, BRI0
O IA 133.10.49.0/24 [110/10137] via 133.10.5.5, 00:01:14, BRI0
O IA 133.10.65.0/26 [110/10009] via 133.10.5.5, 00:01:14, BRI0
O IA 133.10.65.0/24 [110/10147] via 133.10.5.5, 00:01:14, BRI0
O IA 192.168.1.0/24 [110/10000] via 133.10.5.5, 00:01:14, BRI0 <<<---
r1#
----------------------------------------------
route-map check 192.168.1.0's next hop is 133.10.5.5 so it generates default
route:
r1#siod | beg -5
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
0.0.0.0 192.168.200.1 721 0x80000001 0xA873 100 <<<-
133.10.3.0 192.168.200.1 912 0x80000005 0x13C1 2
133.10.17.0 192.168.200.1 912 0x80000005 0x784E 2
192.190.102.0 192.168.200.3 983 0x80000003 0xB1AD 36
r1#
----------------------------------------------
See from the other side of ISDN:
r5#siod | beg -5
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
0.0.0.0 192.168.200.1 1 (DNA) 0x80000001 0xA873 100
133.10.3.0 192.168.200.1 1032 0x80000005 0x13C1 2
133.10.17.0 192.168.200.1 1032 0x80000005 0x784E 2
192.190.102.0 192.168.200.3 1103 0x80000003 0xB1AD 36
r5#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 133.10.5.1 to network 0.0.0.0
192.168.200.0/32 is subnetted, 1 subnets
C 192.168.200.5 is directly connected, Loopback192
133.10.0.0/16 is variably subnetted, 10 subnets, 3 masks
O 133.10.6.0/24 [110/10063] via 133.10.5.1, 00:04:24, BRI0
C 133.10.5.0/24 is directly connected, BRI0
C 133.10.5.1/32 is directly connected, BRI0
O E2 133.10.3.0/24 [110/20] via 133.10.5.1, 00:04:14, BRI0
O E2 133.10.17.0/24 [110/20] via 133.10.5.1, 00:04:14, BRI0
O 133.10.51.0/24 [110/80] via 133.10.65.7, 01:22:28, Ethernet0
O IA 133.10.49.0/24 [110/138] via 133.10.65.7, 00:04:25, Ethernet0
O 133.10.49.0/26 [110/74] via 133.10.65.7, 01:22:28, Ethernet0
O IA 133.10.65.0/24 [110/148] via 133.10.65.7, 00:04:25, Ethernet0
C 133.10.65.0/26 is directly connected, Ethernet0
C 192.168.1.0/24 is directly connected, Loopback1
O*E2 0.0.0.0/0 [110/1] via 133.10.5.1, 00:04:16, BRI0
r5#
>From: "yakout esmat" <yesmat@iprimus.com.au>
>Reply-To: "yakout esmat" <yesmat@iprimus.com.au>
>To: "Bob Sinclair" <bsin@erols.com>
>CC: <ccielab@groupstudy.com>
>Subject: RE: OSPF Conditional Default Origination
>Date: Mon, 22 Apr 2002 17:55:07 +1000
>
>Bob,
>
>I actually have taken Halabi's example in Chapter 12 and tried to build my
>scenario based on that.
>
>But again, my route-map can only check for the existance of the route but
>can't check for the absence of it.
>
>What I am trying to acheive exactely is: advertise the default route, when
>my frame relay interface (physical) goes down and my ISDN (Backup)comes up.
>When this happens the router that is the source of the default route looses
>some routes because of the F/R interface lose, and has to inject the
>default
>into OSPF Domain in order for my network to be able still to reach every
>interface.
>
>But, when F/R interface is up and ISDN down(Standby mode)no default should
>be injected into OSPF Domian.
>
>Your idea, using Admin distance to control the existance of a specific
>route
>when my original route disappears is an excellent one (never thought about
>it) but the question still remains whether that would be acceptable in the
>lab exam??
>
>Thanks for your feedback, any other ideas are very much appreciated.
>
>Ya
>
>
>-----Original Message-----
>From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
>Bob Sinclair
>Sent: Monday, April 22, 2002 1:35 AM
>To: yakout esmat
>Cc: ccielab@groupstudy.com
>Subject: Re: OSPF Conditional Default Origination
>
>
>Yakout,
>
>BGP has the "non-exist" map syntax for the purpose you are trying to
>achieve. The fact that it has this special syntax makes me think you will
>need to test for the existence, not absence, of a route in OSPF.
>
>The best example of this is in Halabi's book. Can you arrange to advertise
>the default only if some other route is present, then arrange if this other
>route is present, then 148.5.5.0 must not be? Perhaps through metric or
>AD?
>
>I think you are correct in your understanding of the command. Cannot test
>absence of route, only presence. Make appearance of route A conditional on
>absence of 148.5.5.0, then advertise default only if A is present. If A is
>present, 148.5.5.0 must not be.
>
>-Bob
>
>
>. ----- Original Message -----
>From: "yakout esmat" <yesmat@iprimus.com.au>
>To: "Groupstudy" <ccielab@groupstudy.com>
>Sent: Sunday, April 21, 2002 6:43 AM
>Subject: OSPF Conditional Default Origination
>
>
> > Hi all,
> >
> > I have a problem configuring OSPF Conditional Default Origination, my
>config
> > as follows:
> >
> > !
> > router ospf 100
> > summary-address 198.168.0.0 255.255.0.0
> > network 148.5.6.6 0.0.0.0 area 0
> > network 148.5.16.6 0.0.0.0 area 0
> > default-information originate route-map default
> > !
> > route-map default deny 10
> > match ip address 3
> > !
> > route-map default permit 20
> > !
> > access-list 3 permit 148.5.5.0 0.0.0.255
> > !
> > end
> >
> > What I want to achieve is: If network 148.5.5.0/24 exists in the routing
> > table DO NOT advertise the default route into OSPF Domain (which is
> > represented by first instance of the route-map 10)
> >
> > Otherwise Advertise the default (which is covered by the second instance
>20)
> >
> > My observation is: it only works if the first instance permits the
>default
> > based on the EXISTANCE of the network in the table, and denies the
>default
> > if the network doesn't exist in the table.
> >
> > Do I have misunderstanding of the Conditional Default Origination or
>what??
> >
> > Any feed back is very much appreciated.
> >
> > Thanks in advance
> >
> > ya
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:17 GMT-3