RE: Virtual Links

From: kym blair (kymblair@xxxxxxxxxxx)
Date: Thu Apr 18 2002 - 00:18:58 GMT-3


   
Tarek,

I've successfully set up two virtual links from area 0 to area 2. Since I
was in the middle of another scenario, my router numbers and area numbers
are a little different. Here is what I have, then my configs:

area 0 -- R3 === area 1 ---- R2 ----- area 5 --|
                         ---- R5 ----- area 5 --|

My drawing isn't too good. R3 is in area 0 and has two virtual links
through area 1 to R2 and R5. R2 and R5 are both in area 5 (network
140.4.50.0).

Router 3 establishes both virtual-links successfully:

R3#sh ip ospf virtual-link
Virtual Link OSPF_VL1 to router 140.4.2.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, via interface Serial1, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
    Adjacency State FULL (Hello suppressed)
    Index 3/4, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec
  Message digest authentication enabled
      No key configured, using default key id 0
Virtual Link OSPF_VL0 to router 140.4.5.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, via interface Serial1, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
    Adjacency State FULL (Hello suppressed)
    Index 4/6, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec
  Message digest authentication enabled
      No key configured, using default key id 0

Router 3 shows the networks in the ospf database as learned from each remote
router:

R3#sh ip ospf database

            OSPF Router with ID (140.4.3.1) (Process ID 64)

                Router Link States (Area 0)
<snip>
                Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
<snip>
140.4.50.0 140.4.2.1 503 0x80000003 0x4991
140.4.50.0 140.4.3.1 496 0x80000003 0xC4D4
140.4.50.0 140.4.5.1 421 0x80000001 0x38A1

Router 3 sees two paths to area 5 (network 140.4.50.0):

R3#show ip route
<snip>
O IA 140.4.50.0/24 [110/74] via 140.4.1.2, 00:00:04, Serial1
                      [110/74] via 140.4.1.5, 00:00:04, Serial1

The configs (with lots of extra junk that you can ignore):

ROUTER3:

R3#sh config
version 12.2
hostname R3
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 140.4.3.1 255.255.255.0
!
interface Ethernet0
ip address 140.4.4.3 255.255.255.0
ip ospf message-digest-key 1 md5 KEY5
ip ospf priority 200
media-type 10BaseT
!
interface Serial1
ip address 140.4.1.3 255.255.255.240
encapsulation frame-relay
ip ospf hello-interval 10
ip ospf priority 200
clockrate 64000
frame-relay map ip 140.4.1.2 302 broadcast
frame-relay map ip 140.4.1.3 302 broadcast
frame-relay map ip 140.4.1.5 305 broadcast
no frame-relay inverse-arp
!
interface TokenRing0
ip address 140.4.30.1 255.255.255.0
ring-speed 16
!
router ospf 64
log-adjacency-changes
area 0 authentication message-digest
area 1 virtual-link 140.4.5.1
area 1 virtual-link 140.4.2.1
network 140.4.1.3 0.0.0.0 area 1
network 140.4.3.1 0.0.0.0 area 0
network 140.4.4.3 0.0.0.0 area 0
network 140.4.30.1 0.0.0.0 area 30
neighbor 140.4.1.5
neighbor 140.4.1.2
!
ip classless

ROUTER2:

R2#show config
version 12.2
hostname R2
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 140.4.2.1 255.255.255.0
!
interface Ethernet1
ip address 140.4.50.2 255.255.255.0
media-type 10BaseT
!
interface Serial0
ip address 140.4.1.2 255.255.255.240
encapsulation frame-relay
ip ospf hello-interval 10
ip ospf priority 0
no fair-queue
clockrate 64000
frame-relay map ip 140.4.1.2 203 broadcast
frame-relay map ip 140.4.1.3 203 broadcast
frame-relay map ip 140.4.1.5 203 broadcast
no frame-relay inverse-arp
!
interface Serial1
ip address 172.16.0.2 255.255.255.0
!
interface TokenRing0
ip address 140.4.21.1 255.255.255.0
ring-speed 16
!
router ospf 64
log-adjacency-changes
area 0 authentication message-digest
area 1 virtual-link 140.4.3.1
passive-interface Ethernet0
passive-interface Serial1
network 140.4.1.2 0.0.0.0 area 1
network 140.4.2.1 0.0.0.0 area 1
network 140.4.21.1 0.0.0.0 area 20
network 140.4.50.2 0.0.0.0 area 5
!
ip classless

ROUTER5:

R5#show config
version 12.2
hostname R5
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 140.4.5.1 255.255.255.0
!
interface FastEthernet0/0
ip address 140.4.50.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 140.4.1.5 255.255.255.240
encapsulation frame-relay
ip ospf hello-interval 10
ip ospf priority 0
no fair-queue
frame-relay map ip 140.4.1.2 503 broadcast
frame-relay map ip 140.4.1.3 503 broadcast
frame-relay map ip 140.4.1.5 503 broadcast
no frame-relay inverse-arp
!
router ospf 64
log-adjacency-changes
area 0 authentication message-digest
area 1 virtual-link 140.4.3.1
area 4 stub no-summary
network 140.4.1.5 0.0.0.0 area 1
network 140.4.5.1 0.0.0.0 area 1
network 140.4.50.1 0.0.0.0 area 5
network 140.4.56.5 0.0.0.0 area 4
!
ip classless

HTH, Kym

--------------------------------------------------------------
>From: Tarek Sabry <tsabry@houston.sns.slb.com>
>Reply-To: Tarek Sabry <tsabry@houston.sns.slb.com>
>To: "'Jason'" <jgraun@attbi.com>, "'Wade Edwards'"
><wade.edwards@powerupnetworks.com>
>CC: ccielab@groupstudy.com
>Subject: RE: Virtual Links
>Date: Wed, 17 Apr 2002 21:03:31 -0500
>
>In fact I get an error message on r3 right before the VL goes down. The
>error says: Detected router with duplicate router id xxx.xxx.x.x (which is
>itself by the way!) in type-4 LSA advertised bt xxx.xx.xx.x (which is r4).
>
>Jason, see if you get the same error. Hmmm so how are we going to handle
>that now? Everybody seems to agree that this should work! By the way do we
>need to make area 2 some kind of stub so that no router LSAs get generated
>from it? Or do I have the definition of stub backwards??
>
>Tarek
>
>-----Original Message-----
>From: Jason [mailto:jgraun@attbi.com]
>Sent: Wednesday, April 17, 2002 8:21 PM
>To: 'Tarek Sabry'; 'Wade Edwards'
>Cc: ccielab@groupstudy.com
>Subject: RE: Virtual Links
>
>
>Given your diagram you might have a problem on R4. I haven't been able
>to use two virtual links going to the same RID in the same area, which
>what you would have on R4, but give it a try and see.
>
>Jason
>
>-----Original Message-----
>From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
>Tarek Sabry
>Sent: Wednesday, April 17, 2002 5:52 PM
>To: 'Wade Edwards'
>Cc: ccielab@groupstudy.com
>Subject: RE: Virtual Links
>
>Wade
>
>No I don't have 2 different transit areas. Just area 1 is a transit
>area. Do
>I still need 2 virtual links???? There's a LAN between r2 and r3. I made
>a
>silly ASCII thing here that I hope will show up in e-mail.
>
> -------(area 1)------(r2)-----(area 2)
> /
>(area 0 )----(r4)--------
> \
> --------(area 1)------(r3)-----(area 2)
>
>Thanks
>Tarek
>
>-----Original Message-----
>From: Wade Edwards [mailto:wade.edwards@powerupnetworks.com]
>Sent: Wednesday, April 17, 2002 5:32 PM
>To: Tarek Sabry
>Cc: ccielab@groupstudy.com
>Subject: RE: Virtual Links
>
>
>You have to have two virtual links. If you have two routers and there
>are two paths through two different transit areas you will need to have
>two virtual links between those two routers. One through each transit
>area.
>
>I always thought if you have authentication on OSPF area 0 then you need
>to have that specified on the virtual-link because the virtual-link is
>part of area 0, which has authentication. If you had to take off the
>MD5 authentication from the virtual-link in order to get the
>virtual-link to come up what is the purpose of the command on the
>virtual-link.
>
>I guess it must be YAIB (Yet Another IOS Bug).
>
>L8r.
>
> -----Original Message-----
>From: Tarek Sabry [mailto:tsabry@houston.sns.slb.com]
>Sent: Wednesday, April 17, 2002 4:59 PM
>To: ccielab@groupstudy.com
>Subject: Virtual Links
>
>Hi
>
>This is a quick one. When I have 2 spokes that can act as ABRs between
>area
>1 and area 2 let's say, do I need 2 virtual links to area 0? Or should I
>only have one virtual link that I choose?
>
>Another question, if area 0 is authenticated then do I have to enable
>authentication on the virtual link? I thought I should, but the only way
>I'm
>able to bring one of the virtual links up is to remove the md5
>authentication!! Is there a problem because I'm using 2 parallel VLinks
>or
>this is the way it is supposed to work?
>
>Thanks
>Tarek



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:12 GMT-3