Dialer Watch question

From: Babacar Diop (babacard2000@xxxxxxxxx)
Date: Wed Apr 17 2002 - 13:29:49 GMT-3


   
I would appreciate any insight in this issue.

I am doing dialer watch on R5 and R3. Here are the configs

For R5

interface Loopback0
 ip address 133.14.5.5 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 ip address 133.14.56.5 255.255.255.0
 frame-relay interface-dlci 506
!
interface Serial0.2 multipoint
 ip address 133.14.243.5 255.255.255.0
 no ip split-horizon
 ip ospf priority 100
 frame-relay interface-dlci 503
 frame-relay interface-dlci 504
!
interface Serial1
 ip address 133.14.51.5 255.255.255.0

interface BRI0
 ip address 133.14.35.5 255.255.255.252
 encapsulation ppp
 dialer idle-timeout 10
 dialer watch-disable 10
 dialer map ip 133.14.3.3 name r3 broadcast 8358664
  dialer map ip 133.14.35.6 name r3 broadcast 8358664
 dialer load-threshold 1 either
 dialer watch-group 1
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 ppp multilink
!
router ospf 64
 log-adjacency-changes
 network 133.14.5.0 0.0.0.255 area 0
 network 133.14.35.4 0.0.0.3 area 3
 network 133.14.56.0 0.0.0.255 area 0
 network 133.14.243.0 0.0.0.255 area 0
 neighbor 133.14.243.4
 neighbor 133.14.243.3
!
ip classless
ip http server
!
access-list 100 deny ospf any any
access-list 100 permit ip any any
dialer watch-list 1 ip 133.14.3.3 255.255.255.255
dialer-list 1 protocol ip list 100
!

For R3

interface Loopback0
 ip address 133.14.3.3 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 133.14.243.3 255.255.255.0
 ip ospf priority 0
 frame-relay interface-dlci 305

interface BRI0
 ip address 133.14.35.6 255.255.255.252
 encapsulation ppp
 dialer map ip 133.14.35.5 name r5 broadcast
 dialer load-threshold 1 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication chap
 ppp multilink
!
router ospf 64
 log-adjacency-changes
 network 133.14.3.0 0.0.0.255 area 0
 network 133.14.35.4 0.0.0.3 area 3
 network 133.14.243.0 0.0.0.255 area 0
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!

The route i am watching is the loopback of R3.

When i shut R3's loopback, R5 dials fine (no problem there).

When i later do a "no shut" on R3's loopback, R5 never learns the route through
 ospf. Instead it shows it as "directly connect".(see below)

r5#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
O IA 200.200.200.1 [110/65] via 133.14.51.1, 00:10:55, Serial1
     133.14.0.0/16 is variably subnetted, 9 subnets, 3 masks
C 133.14.243.0/24 is directly connected, Serial0.2
O 133.14.1.1/32 [110/65] via 133.14.51.1, 00:10:56, Serial1
O 133.14.6.6/32 [110/65] via 133.14.56.6, 00:10:56, Serial0.1
O 133.14.4.4/32 [110/65] via 133.14.243.4, 00:10:56, Serial0.2
C 133.14.3.3/32 is directly connected, BRI0
C 133.14.5.0/24 is directly connected, Loopback0
C 133.14.35.4/30 is directly connected, BRI0
C 133.14.56.0/24 is directly connected, Serial0.1
C 133.14.51.0/24 is directly connected, Serial1
r5#

I don't think i am doing anything wrong here. What i am thinking is that R5 thi
nks that 133.14.3.3 is directly connected and never installs the ospf route in
its routing table. The isdn circuit stays up and is never brought down until i
manually clear it. But i thought the idle-timeout is supposed to check whether
the primary link is active and bring down the isdn circuit.

Note: i have also tried to shut the serial interface on R3 and bring it back up
. I got the same result.

Thanks for your help

---------------------------------
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:11 GMT-3