RE: auto-rp + nbma

From: Geoffrey KIM (Geoffrey.KIM@xxxxxxxxx)
Date: Tue Apr 16 2002 - 21:59:15 GMT-3


   
Lorenzo,

I'm not a multicast expert, but let me try if I can help you...

Since R2 is a candidate RP, you need:

  ip pim send-rp-announce int ser 0.1 scope 15

which makes the MA (mapping agent) aware of R2 as a candidate RP.

On R3, as an MA, you need:

  ip pim send-rp-discovery int ser 0 scope 15

which sends out RP mappings to routers listening to 224.0.1.40.

On R5, since you are listening to 224.0.1.40, you don't need any
rp-address config:

  [DELETE] ip pim rp-address 150.50.2.2

I hope this fixes your problem. Please let me know how it goes.

Cheers,
Geoffrey

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On
> Behalf Of LORENZO Juan Ignacio
> Sent: Wednesday, April 17, 2002 12:21 AM
> To: ccielab@groupstudy.com
> Subject: auto-rp + nbma
>
>
> I have the following topology:
>
>
> R3(HUB)
> | |
> R5(spoke) R2 (sopoke)
>
>
>
> I configured the multicast addresses on R2 Et0 224.10.10.10 and
> 224.20.20.20, I can reach them from R3 but I can4t from R5.
> R2 is the RP(rendevouz point) and R3 is the MA (maping
> agent). I think that
> I have the correct configuration but something is missing,
> does someone
> knows what?????
>
>
> Here are all the configs:
>
> --R5--
>
> interface Ethernet0
> ip address 150.50.6.5 255.255.255.0
> no ip redirects
> no ip directed-broadcast
> ip pim sparse-dense-mode
> ipx network 56565656
> ipx nlsp enable
> ipx nlsp rip off
> ipx nlsp sap off
> standby 10 timers 7 17
> standby 10 priority 115
> standby 10 preempt
> standby 10 authentication genesis
> standby 10 mac-address 0000.0c07.aaaa
> standby 10 ip 150.50.6.1
> standby 10 track Serial0.1 40
> !
>
> interface Serial0.1 point-to-point
> ip address 10.10.10.5 255.255.255.0
> no ip directed-broadcast
> ip pim sparse-dense-mode
> ip ospf message-digest-key 1 md5 pachanga
> ip ospf network broadcast
> ip ospf priority 0
> frame-relay interface-dlci 103
>
> ip pim rp-address 150.50.2.2
>
> R5#ping 224.20.20.20
>
> Type escape sequence to abort.
> Sending 1, 100-byte ICMP Echos to 224.20.20.20, timeout is 2 seconds:
> .
> R5#ping 224.10.10.10
>
> Type escape sequence to abort.
> Sending 1, 100-byte ICMP Echos to 224.10.10.10, timeout is 2 seconds:
> .
> R5#sh ip pim rp
> Group: 224.0.1.39, RP: 150.50.2.2, v1, uptime 00:02:17,
> expires 00:00:42
> Group: 224.0.1.40, RP: 150.50.2.2, v1, uptime 00:04:16,
> expires 00:02:56
> Group: 224.10.10.10, RP: 150.50.2.2, v2, v1, uptime 00:09:57, expires
> 00:02:02
> Group: 224.20.20.20, RP: 150.50.2.2, v2, uptime 00:00:10,
> expires never
> R5#sh ip mroute
> IP Multicast Routing Table
> Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
> R - RP-bit set, F - Register flag, T - SPT-bit set, J
> - Join SPT
> X - Proxy Join Timer Running
> Timers: Uptime/Expires
> Interface state: Interface, Next-Hop or VCD, State/Mode
>
> (*, 224.0.1.39), 00:05:45/00:02:56, RP 150.50.2.2, flags: SJPC
> Incoming interface: Serial0.1, RPF nbr 10.10.10.2
> Outgoing interface list: Null
>
> (*, 224.0.1.40), 00:10:42/00:00:00, RP 150.50.2.2, flags: SJCL
> Incoming interface: Serial0.1, RPF nbr 10.10.10.2
> Outgoing interface list:
> Ethernet0, Forward/Sparse-Dense, 00:10:43/00:02:39
>
> (150.50.3.3, 224.0.1.40), 00:05:01/00:02:59, flags: CLJT
> Incoming interface: Serial0.1, RPF nbr 10.10.10.3
> Outgoing interface list:
> Ethernet0, Forward/Sparse-Dense, 00:05:01/00:02:39
>
> (*, 224.10.10.10), 00:10:02/00:02:59, RP 150.50.2.2, flags: SPF
> Incoming interface: Serial0.1, RPF nbr 10.10.10.2
> Outgoing interface list: Null
>
> (150.50.6.5, 224.10.10.10), 00:00:10/00:02:49, flags: PFT
> Incoming interface: Ethernet0, RPF nbr 0.0.0.0, Registering
> Outgoing interface list: Null
>
> (*, 224.20.20.20), 00:04:35/00:02:59, RP 150.50.2.2, flags: SPF
> Incoming interface: Serial0.1, RPF nbr 10.10.10.2
> Outgoing interface list: Null
>
> (150.50.6.5, 224.20.20.20), 00:00:17/00:02:42, flags: PFT
> Incoming interface: Ethernet0, RPF nbr 0.0.0.0, Registering
> Outgoing interface list: Null
>
>
> --R3--
>
> interface Ethernet0
> ip address 150.50.3.3 255.255.255.0
> no ip directed-broadcast
> ip pim sparse-dense-mode
> ipx network 33333333
> !
> interface Serial0
> ip address 10.10.10.3 255.255.255.0
> no ip directed-broadcast
> ip pim nbma-mode
> ip pim sparse-dense-mode
> encapsulation frame-relay
> ip ospf message-digest-key 1 md5 pachanga
> ip ospf network broadcast
> no ip mroute-cache
> logging event subif-link-status
> logging event dlci-status-change
> ipx network AAAAAAAA
> no ipx split-horizon eigrp 1
> no fair-queue
> frame-relay map ip 10.10.10.2 102 broadcast
> frame-relay map ip 10.10.10.4 104 broadcast
> frame-relay map ip 10.10.10.5 105 broadcast
> frame-relay map ipx AAAAAAAA.0002.0002.0002 102 broadcast
> frame-relay map ipx AAAAAAAA.0004.0004.0004 104 broadcast
> no frame-relay inverse-arp
>
>
> ip pim send-rp-discovery Ethernet0 scope 15
>
>
> --R2--
>
>
> !
> interface Ethernet0
> ip address 150.50.2.2 255.255.255.0
> no ip directed-broadcast
> ip pim sparse-dense-mode
> ip igmp join-group 224.10.10.10
> ip igmp join-group 224.20.20.20
> ipx encapsulation ARPA
> ipx network BEBE
>
> interface Serial0
> no ip address
> no ip directed-broadcast
> encapsulation frame-relay
> no ip mroute-cache
> logging event subif-link-status
> logging event dlci-status-change
> !
> interface Serial0.1 point-to-point
> ip address 10.10.10.2 255.255.255.0
> no ip directed-broadcast
> ip pim sparse-dense-mode
> ip ospf message-digest-key 1 md5 pachanga
> ip ospf network broadcast
> ip ospf priority 0
> ipx network AAAAAAAA
> frame-relay interface-dlci 103
>
>
> ip pim send-rp-announce Ethernet0 scope 15 group-list 5
>
>
> --------------------------------------------------------------
> ----------
> Lic. Juan Ignacio Lorenzo - Network Systems Engineer
> Cisco Certified Network Professional
> --------------------------------------------------------------
> ----------



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:10 GMT-3