From: peter brown (pita40@xxxxxxxxxxx)
Date: Tue Apr 16 2002 - 02:18:26 GMT-3
I have a problem with ISDN backup configuration with Frame-relay.
Please see the config below for good understanding. The problem is with r2
below.
hostname r1
!
!
username r2 password 0 cisco
ip subnet-zero
isdn switch-type basic-ni
!
!
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
ip ospf priority 100
no ip mroute-cache
logging event subif-link-status
logging event dlci-status-change
frame-relay traffic-shaping
!
interface Serial0.1 multipoint
ip address 150.100.250.33 255.255.255.240
no ip directed-broadcast
ip ospf message-digest-key 1 md5 cisco
ip ospf hello-interval 20
frame-relay class cisco
frame-relay map ip 150.100.250.34 102 broadcast
frame-relay map ip 150.100.250.35 103 broadcast
!
interface Serial0.2 point-to-point
ip address 150.100.251.1 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 104
!
interface Serial1
ip address 150.100.1.1 255.255.255.0
no ip directed-broadcast
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
ip address 151.100.100.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer map ip 151.100.100.2 name r2 broadcast 5482373
dialer load-threshold 1 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 20254823710101 5482371
isdn spid2 20254823720101 5482372
ppp authentication chap
ppp multilink
!
router ospf 1
router-id 150.100.250.33
area 0 authentication message-digest
area 1 nssa no-redistribution no-summary
area 100 range 150.100.250.0 255.255.255.0
summary-address 170.10.10.0 255.255.255.0 not-advertise
redistribute rip metric 1 metric-type 1 subnets
network 150.100.1.1 0.0.0.0 area 1
network 150.100.100.2 0.0.0.0 area 11
network 150.100.250.33 0.0.0.0 area 0
neighbor 150.100.250.35
neighbor 150.100.250.34
!
router rip
redistribute ospf 1 metric 1
passive-interface BRI0
passive-interface Serial0.1
passive-interface Serial1
network 150.100.0.0
!
ip classless
!
!
map-class frame-relay cisco
frame-relay adaptive-shaping becn
frame-relay cir 6400
frame-relay bc 1000
frame-relay be 32
frame-relay mincir 3200
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r1#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 65, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 64, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = 1
TEI 65, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = 2
Layer 3 Status:
1 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 1
CCB:callid=0x1E, sapi=0x0, ces=0x1, B-chan=1
The Free Channel Mask: 0x80000002
Total Allocated ISDN CCBs = 1
r1#
02:06:35: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5482373 r2
###############################################################################
#############
r2#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
username r1 password 0 cisco
ip subnet-zero
isdn switch-type basic-ni
!
!
!
interface Loopback0
ip address 150.100.22.1 255.255.255.252
no ip directed-broadcast
!
interface Loopback1
ip address 150.100.22.5 255.255.255.252
no ip directed-broadcast
!
interface Loopback2
ip address 150.100.22.9 255.255.255.252
no ip directed-broadcast
!
interface Loopback3
ip address 150.100.22.19 255.255.255.248
no ip directed-broadcast
!
interface Loopback4
ip address 150.100.22.25 255.255.255.248
no ip directed-broadcast
!
interface Loopback5
ip address 150.100.21.46 255.255.255.240
no ip directed-broadcast
!
interface Loopback6
ip address 150.100.21.61 255.255.255.240
no ip directed-broadcast
!
interface Loopback7
ip address 150.100.250.53 255.255.255.240
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
frame-relay traffic-shaping
frame-relay class cisco
!
interface Serial1.1 point-to-point
ip address 150.100.250.34 255.255.255.240
no ip directed-broadcast
ip ospf message-digest-key 1 md5 cisco
ip ospf network non-broadcast
ip ospf hello-interval 20
ip ospf priority 0
frame-relay interface-dlci 201
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
ip address 151.100.100.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 151.100.100.1 name r1 broadcast 5482371
dialer load-threshold 1 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 20254823730101 5482373
isdn spid2 20254823740101 5482374
ppp authentication chap
ppp multilink
!
router ospf 1
router-id 150.100.250.34
area 0 authentication message-digest
area 10 range 150.100.21.0 255.255.255.0
area 20 range 150.100.22.0 255.255.255.0
area 27 range 150.100.250.0 255.255.255.0
network 150.100.21.46 0.0.0.0 area 10
network 150.100.21.61 0.0.0.0 area 10
network 150.100.22.1 0.0.0.0 area 20
network 150.100.22.5 0.0.0.0 area 20
network 150.100.22.9 0.0.0.0 area 20
network 150.100.22.19 0.0.0.0 area 21
network 150.100.22.25 0.0.0.0 area 21
network 150.100.250.34 0.0.0.0 area 0
network 150.100.250.53 0.0.0.0 area 27
network 151.100.100.2 0.0.0.0 area 11
!
ip classless
!
!
map-class frame-relay cisco
frame-relay adaptive-shaping becn
frame-relay cir 6400
frame-relay bc 1000
frame-relay be 32
frame-relay mincir 3200
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r2#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 65, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 64, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = 1
TEI 65, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = 2
Layer 3 Status:
1 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 1
CCB:callid=0x8010, sapi=0x0, ces=0x1, B-chan=1
The Free Channel Mask: 0x80000002
Total Allocated ISDN CCBs = 1
r2#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-INS-L), Version 12.0(15), RELEASE SOFTWARE
(fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Thu 28-Dec-00 00:03 by linda
Image text-base: 0x030412F0, data-base: 0x00001000
ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE
SOFTW
ARE (fc1)
r2 uptime is 8 minutes
System restarted by power-on
System image file is "flash:c2500-ins-l.120-15.bin"
cisco 2500 (68030) processor (revision L) with 6144K/2048K bytes of memory.
Processor board ID 02965303, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
Basic Rate ISDN software, Version 1.1.
1 Token Ring/IEEE 802.5 interface(s)
2 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)
Configuration register is 0x2102
r2#
The question is when I enable the fram cloud the spid on r2 becomes invalid.
why does this happen. Below
is the output.
r2#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
DEACTIVATED
Layer 2 Status:
Layer 2 NOT Activated
Spid Status:
TEI Not Assigned, ces = 1, state = 1(terminal down)
spid1 configured, spid1 NOT sent, spid1 NOT valid
TEI Not Assigned, ces = 2, state = 1(terminal down)
spid2 configured, spid2 NOT sent, spid2 NOT valid
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
The Free Channel Mask: 0x80000003
Number of L2 Discards = 3, L2D_Task Discards = 2
Total Allocated ISDN CCBs = 0
r2#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:09 GMT-3