IGP Redistribution to IGP to BGP

From: Dustin.Yates@xxxxxxxxxxxx
Date: Wed Apr 10 2002 - 02:09:55 GMT-3


   
Requirement for Router 3: 1. Redistribute routes learned from EIGRP in to
OSPF. 2. Redistribute OSPF routes in to BGP.

Problem: R3 is receiving routes through EIGRP that are being redistributed
into OSPF, but aren't making it into the BGP table-- sample routes are
212.12.1.0, 212.12.7.0, 212.12.8.0, ... & 212.12.12.0. Is there anything
special one should consider when performing multiple redistribution such as
this on the same router?

Relevant configs and show commands below....

Regards, dy

hostname R3
!
interface Loopback0
 ip address 155.1.100.131 255.255.255.192
!
!
router eigrp 100
 redistribute ospf 1 route-map o2e
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Loopback0
 network 161.1.0.0
 no auto-summary
 eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 area 34 nssa default-information-originate
 redistribute eigrp 100 subnets route-map e2o
 passive-interface default
 no passive-interface Serial0/0.204
 no passive-interface Serial0/1
 no passive-interface Loopback0
 network 155.1.100.131 0.0.0.0 area 3
 network 161.1.34.3 0.0.0.0 area 34
 network 161.1.53.1 0.0.0.0 area 0
!
router bgp 1127
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map o2b
 neighbor 161.1.34.4 remote-as 400
 neighbor 161.1.34.4 route-map filter-to-r4 out
 neighbor 161.1.123.66 remote-as 1127
 no auto-summary
!
!
ip prefix-list filter161 seq 5 permit 161.1.0.0/16
ip prefix-list filter161 seq 10 permit 161.1.0.0/16 ge 17
access-list 11 permit 161.1.160.0
access-list 11 permit 161.1.161.0
route-map e2o deny 10
 match tag 2
!
route-map e2o permit 20
 match ip address 11
 set metric 10
 set metric-type type-1
 set tag 3
!
route-map e2o permit 30
 set metric 103
 set tag 3
!
route-map o2e deny 10
 match tag 2
!
route-map o2e deny 20
 match tag 3
!
route-map o2e permit 30
 set metric 56 100 255 1 1500
 set tag 3
!
route-map o2b permit 10
 set metric 0
 set weight 32768
 set origin igp
!
route-map filter-to-r4 deny 10
 match ip address prefix-list filter161
!
route-map filter-to-r4 permit 20
!

R3#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D EX 212.12.9.0/24 [170/45765376] via 161.1.123.1, 01:03:41, Ethernet0/0
D EX 212.12.8.0/24 [170/45765376] via 161.1.123.1, 01:03:41, Ethernet0/0
D EX 212.12.11.0/24 [170/45765376] via 161.1.123.1, 01:03:43, Ethernet0/0
D EX 212.12.10.0/24 [170/45765376] via 161.1.123.1, 01:03:43, Ethernet0/0
D EX 212.12.12.0/24 [170/45765376] via 161.1.123.1, 01:03:43, Ethernet0/0
D 212.12.1.0/24 [90/1787392] via 161.1.123.1, 01:03:43, Ethernet0/0
D EX 212.12.7.0/24 [170/45765376] via 161.1.123.1, 01:03:48, Ethernet0/0

R3# show ip ospf database
:
output shortened
:
                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Ta
212.12.1.0 155.1.100.131 548 0x80000009 0x904B 3
212.12.7.0 155.1.100.131 48 0x80000016 0x3494 3
212.12.8.0 155.1.100.131 48 0x80000016 0x299E 3
212.12.9.0 155.1.100.131 48 0x80000016 0x1EA8 3
212.12.10.0 155.1.100.131 48 0x80000016 0x13B2 3
212.12.11.0 155.1.100.131 48 0x80000016 0x8BC 3
212.12.12.0 155.1.100.131 48 0x80000016 0xFCC6 3

R3#sh ip bgp
BGP table version is 40, local router ID is 155.1.100.131
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
:
output shortened
:
*>i192.168.255.0 212.12.1.254 0 100 0 1 91 ?
*>i223.255.254.0 212.12.1.254 0 100 0 1 i
R3#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:03 GMT-3