LAB 8 IPX IPXWAN on tunnel interface.

From: Larson, Chris (Contractor) (Chris.Larson@xxxxxx)
Date: Mon Apr 08 2002 - 09:54:35 GMT-3


   
I cannot get my tunnel interface up and running between R6 and R8 in ccboot
lab 8. I had this same issue when trying to run NLSP over IPXWAN using a
tunnel across ethernet. IPXWAN never seems to come up. This is driving me
nuts as I have seen it as a requirement in 2 labs now (To use the tunnel for
IPXWAN) and have not been able to get it started either time.
Any help would be appreciated. Configs included.

hostname R6
!
!
username R5
memory-size iomem 20
ip subnet-zero
no ip domain-lookup
!
ipx routing 0006.0006.0006
ipx internal-network 6
ipx server-split-horizon-on-server-paths
isdn switch-type basic-ni
!
!
!
!
interface Loopback0
 ip address 137.20.60.1 255.255.240.0
 no ip directed-broadcast
 ipx network 22
!
interface Tunnel0
 no ip address
 no ip directed-broadcast
 ipx ipxwan 0 unnumbered R6
 ipx nlsp enable
 ipx nlsp rip off
 tunnel source 137.20.86.2
 tunnel destination 137.20.86.1
!
interface FastEthernet0/0
 ip address 137.20.64.6 255.255.240.0
 no ip redirects
 no ip directed-broadcast
 ipx network 695
 standby 1 timers 5 10
 standby 1 priority 100
 standby 1 authentication cisco
 standby 1 ip 137.20.64.8
!
interface Serial0/0
 ip address 137.20.86.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
 no fair-queue
 clockrate 56000
!
interface BRI0/0
 ip address 137.20.224.6 255.255.240.0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 20
 dialer map ip 137.20.224.5 name R5 broadcast 8358661
 dialer map ipx 6005.0005.0005.0005 name R5 broadcast 8358661
 dialer-group 1
 ipx network 6005
 no ipx route-cache
 ipx watchdog-spoof
 ipx spx-spoof
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 no peer neighbor-route
!
router ospf 1
 redistribute connected metric-type 1 subnets route-map allows0
 redistribute bgp 2 metric 333 subnets route-map filterrings
 network 137.20.60.0 0.0.0.255 area 0
 network 137.20.64.0 0.0.0.255 area 0
 network 137.20.224.6 0.0.0.0 area 0
 network 137.20.224.0 0.0.15.255 area 0
!
router bgp 2
 redistribute ospf 1 metric 100 match internal external 1 route-map BGPFilt
 neighbor 137.20.25.1 remote-as 2
 neighbor 137.20.25.1 update-source Loopback0
 neighbor 137.20.86.1 remote-as 1
 no auto-summary
!
ip classless
no ip http server
!
access-list 1 permit 137.20.86.0 0.0.0.255
access-list 2 permit 172.168.70.0 0.0.0.255
access-list 2 permit 137.20.86.0 0.0.0.255
access-list 2 permit 137.20.224.0 0.0.0.255
access-list 2 permit 160.0.0.0 0.255.255.255
access-list 2 permit 161.10.10.0 0.0.0.255
access-list 2 permit 160.10.10.0 0.0.0.255
access-list 2 permit 170.10.10.0 0.0.0.255
access-list 3 permit 160.0.0.0 0.255.255.255
access-list 10 permit 137.20.81.0 0.0.0.255
access-list 10 permit 137.20.82.0 0.0.0.255
access-list 101 deny ip host 137.20.224.5 any
access-list 101 deny ip host 137.20.224.6 any
access-list 901 deny any any all any rip
access-list 901 deny any any all any sap
access-list 901 deny any any all any 457
access-list 901 permit any any all any all
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx list 901
route-map allows0 permit 10
 match ip address 1
!
route-map allows0 deny 20
!
route-map filteragg deny 10
 match ip address 3
!
route-map filterrings deny 10
 match ip address 10
!
route-map filterrings permit 20
!
route-map BGPFilt deny 10
 match ip address 2
!
route-map BGPFilt permit 20
!
!
!
ipx route default 6005.0005.0005.0005
!
ipx router eigrp 1
 network 695
!
!
ipx router nlsp
 area-address 0 0
 redistribute eigrp 1
!
!
ipx router rip
 no network 695
!
!
ipx sap 4 fileserver 22.0008.0008.0008 452 1
ipx sap 7 printserver 22.0008.0008.0008 452 1
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

hostname R8
!
!
ip subnet-zero
no ip domain-lookup
ipx routing 0008.0008.0008
ipx internal-network 8
ipx server-split-horizon-on-server-paths
!
!
!
!
!
interface Loopback0
 no ip address
 no ip directed-broadcast
 ipx network 801
!
interface Loopback1
 ip address 137.20.80.1 255.255.255.0
 no ip directed-broadcast
!
interface Tunnel0
 no ip address
 no ip directed-broadcast
 ipx ipxwan 0 unnumbered R8
 ipx nlsp enable
 ipx nlsp rip off
 tunnel source 137.20.86.1
 tunnel destination 137.20.86.2
!
interface Ethernet0
 ip address 172.168.80.1 255.255.255.0
 no ip directed-broadcast
 no keepalive
 ipx network 800
 ipx nlsp enable
!
interface Ethernet0.1
 no ip directed-broadcast
 ipx encapsulation SAP
 ipx network 810
!
interface Serial0
 ip address 137.20.86.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 137.20.82.1 255.255.255.0
 no ip directed-broadcast
 ipx network 802
 ipx nlsp enable
 ring-speed 16
!
interface Virtual-TokenRing0
 no ip address
 no ip directed-broadcast
 ipx network 803
 ipx nlsp enable
 ring-speed 16
!
interface Virtual-TokenRing1
 ip address 137.20.81.1 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
!
router bgp 1
 network 137.20.81.0 mask 255.255.255.0
 network 137.20.82.0 mask 255.255.255.0
 network 172.168.80.0 mask 255.255.255.0
 neighbor 137.20.86.2 remote-as 2
 no auto-summary
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
!
!
!
!
ipx router nlsp
 area-address 0 0
!
!
ipx router rip
 no network 801
 no network 810
 no network 802
 no network 803
!
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:59 GMT-3