From: Engelhard M. Labiro (engelhard@xxxxxxxxxxxxxx)
Date: Mon Apr 08 2002 - 08:25:44 GMT-3
Hi,
>From R5`s config, it shows that the router still does an IP routing.
If there is any IP packet want to leave out R5, it will look to its route
table first to route that packet, it won`t bridge an IP packet,
which is your goal to bridge IP between R5 and R6.
Regarding an interface down at R5, does it connected to an
access port at the switch ? I mean, R5 doesn`t suppose to know
which VLAN its belong to right ? So, it is the switch that
should tag a packet coming from R5. Please check that the port
is an "access port" belong to VLAN 10. My guess, this may be
a problem that you got an encapsulation error too.
> I got it working now - The configs are below...
>
> Just oine problem (I don't know if this is related to my Fastethernet
> on R5), but...the interface resets as soon as I do changes on it, and
> after that only a reload of R5 and R6 will make it work again!
> Any ideas why this is happening?
>
> Also...If I wan't to run IPX normally routed on the 2 Vlan's I reckon
> I just have to give the network statement on the subinterfaces on
> R6!
>
> Anyway...thanks for valuable input!
>
> Nic
>
> R5#sh run
> Building configuration...
>
> Current configuration : 1636 bytes
> !
> version 12.1
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R5
> !
> boot system flash:c7200-js-mz.121-9a.bin
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> ipx routing 0005.0005.0005
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 192.22.5.5 255.255.255.0
> !
> interface FastEthernet0/0
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> half-duplex
> !
> interface FastEthernet1/0
> ip address 192.22.17.5 255.255.255.0
> duplex auto
> speed auto
> !
> interface FastEthernet1/1
> ip address 192.22.12.5 255.255.255.0
> no ip redirects
> speed 100
> full-duplex
> ipx network 10
> standby ip 192.22.12.2
> standby priority 125
> standby preempt
> !
> interface Ethernet2/0
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/1
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/2
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/3
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/4
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/5
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/6
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Ethernet2/7
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Serial3/0
> no ip address
> no ip route-cache
> no ip mroute-cache
> framing g751
> dsu bandwidth 34010
> serial restart-delay 0
> !
> ip classless
> no ip http server
> !
> !
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
>
> R6:
>
> R6#sh run
> Building configuration...
>
> Current configuration : 1934 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R6
> !
> !
> !
> !
> resource-pool disable
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> ipx routing 0006.0006.0006
> mta receive maximum-recipients 0
> !
> controller T1 0
> framing esf
> clock source line primary
> linecode b8zs
> channel-group 1 timeslots 1 speed 64
> !
> controller T1 1
> clock source line secondary 1
> !
> controller T1 2
> !
> controller T1 3
> !
> !
> !
> bridge irb
> !
> !
> interface Loopback0
> ip address 137.22.6.6 255.255.255.0
> ip ospf network point-to-point
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Serial0:1
> ip address 137.22.11.6 255.255.255.240
> encapsulation frame-relay
> ip ospf priority 0
> frame-relay map ip 137.22.11.3 64
> frame-relay map ip 137.22.11.4 64
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> !
> interface FastEthernet0
> no ip address
> duplex auto
> speed auto
> !
> interface FastEthernet0.1
> encapsulation isl 1
> ip address 1.1.1.2 255.255.255.0
> no ip redirects
> !
> interface FastEthernet0.10
> encapsulation isl 10
> no ip redirects
> ipx encapsulation NOVELL-ETHER
> ipx network 10
> bridge-group 1
> !
> interface FastEthernet0.20
> encapsulation isl 20
> ip address 137.22.14.1 255.255.255.252
> no ip redirects
> !
> interface FastEthernet0.30
> encapsulation isl 30
> ip address 137.22.16.6 255.255.255.128
> no ip redirects
> !
> interface FastEthernet0.40
> encapsulation isl 40
> no ip redirects
> ipx encapsulation NOVELL-ETHER
> ipx network 40
> bridge-group 1
> !
> interface BVI1
> ip address 137.22.12.6 255.255.255.0
> no ip redirects
> standby ip 137.22.12.2
> standby priority 126
> standby preempt
> !
> router ospf 1
> router-id 137.22.6.6
> log-adjacency-changes
> network 137.22.6.6 0.0.0.0 area 1
> network 137.22.11.6 0.0.0.0 area 1
> network 137.22.14.1 0.0.0.0 area 33
> !
> ip classless
> no ip http server
> !
> !
> !
> !
> !
> !
> bridge 1 protocol ieee
> bridge 1 route ip
> !
> line con 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
>
> -----Original Message-----
> From: Engelhard M. Labiro [mailto:engelhard@netmarks.co.jp]
> Sent: 8. april 2002 11:40
> To: Nicolai Gersbo Solling; CCIE
> Subject: Re: IRB - Transparent bridging problem!
>
>
> I tried your scenario last time, with a router in a stick to bridge
> between VLANs. I got a working config to bridge between
> the two VLAN, at the time either "bridge 1 protocol ieee" or
> "bridge 1 protocol vlan-bridge" doesn`t have any different result.
> Both commands still bridge the two VLANs.
> I didn`t investigate any further what are differences if any with
> a "vlan-bridge" command. Hope that someone would tell us
> what this command for.
>
>
> Engelhard M. Labiro$B!!(B(engelhard@netmarks.co.jp)
> Security Group, Technical Solution Center, Netmarks Inc.
> 2-13-34 Konan, Minato-Ku, Tokyo 108-0075
> Tel: +81-3-5461-2575, Fax: +81-3-5461-2093
>
> ----- Original Message -----
> From: "Nicolai Gersbo Solling" <nicolai@cisco.com>
> To: "CCIE" <ccielab@groupstudy.com>
> Sent: Monday, April 08, 2002 1:35 AM
> Subject: IRB - Transparent bridging problem!
>
>
> > I have the following Scenario:
> >
> > R5---Vlan 10---Switch---Vlan40---R6
> >
> > I wan't to bridge IP between R5 and R6...
> >
> > ...but I am a bit in doubt of which bridge protocol to use:
> >
> > R5 is a standard configuration and the switch has it's sc0 in Vlan 40.
> >
> > I have configured R6 (The router that actually takes care of the
bridging)
> > with the following:
> >
> > bridge 1 protocol vlan-bridge
> > bridge 1 route ip
> > bridge 1 route ipx
> > !
> > interface FastEthernet0.10
> > encapsulation isl 10
> > no ip redirects
> > bridge-group 1
> > !
> > interface FastEthernet0.40
> > encapsulation isl 40
> > no ip redirects
> > bridge-group 1
> > !
> > interface BVI1
> > ip address 137.22.12.6 255.255.255.0
> > no ip redirects
> > standby ip 137.22.12.2
> > standby priority 126
> > standby preempt
> >
> > I got the config working now, but I had some strange problems getting it
> to
> > work...
> > I got Encapsulation failed on R5 when I tried to ping R6 - Both the
> > Mac-table of the switch and the Arp-cache of R6 looked good, but I could
> > just not resolve on R5...
> > Then I tried reloading R6 - This did not help...Somehow something was
> wrong
> > in the switch - After giveing that a good old powercycle - It works like
a
> > charm...
> >
> > Any good, and bright ideas why I encountered this...
> > And is it Vlan Bridging I need to use?
> >
> > Nic
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:59 GMT-3