From: ying chang (ying_c@xxxxxxxxxxx)
Date: Sat Apr 06 2002 - 22:56:13 GMT-3
Hi all,
Below is the config and output. The problem was originated from Peter's
earlier post. Noticed on R2 192.168.1.0 from R3 is suppressed as shown in
the debug.
Thanks,
Chang
R1: (AS1, connect to R2 and R3 in AS236 via ebgp, will hint AS236 to prefer
R1-R2 route)
!
router bgp 1
bgp log-neighbor-changes
network 192.168.1.0 <<<<-- network to be advertised
neighbor 10.1.1.2 remote-as 236
neighbor 10.1.1.2 soft-reconfiguration inbound
neighbor 10.1.1.2 route-map set-med1 out
neighbor 10.1.1.3 remote-as 236
neighbor 10.1.1.3 soft-reconfiguration inbound
neighbor 10.1.1.3 route-map set-med2 out
!
!
route-map set-med2 permit 10
set metric 30
!
route-map set-med1 permit 10
set metric 20 <<<<-- lower MED to make R1-R2 route more attractive
!
====================
r1#sib
BGP table version is 4, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* 26.1.1.0/24 10.1.1.3 0 236 i
*> 10.1.1.2 0 236 i
* 36.1.1.0/24 10.1.1.3 0 0 236 i
*> 10.1.1.2 0 236 i
*> 192.168.1.0 0.0.0.0 0 32768 i
r1#
-----------------------------
R2: (AS236, R2-R1 is the preferred route to AS1)
r2#sb router
router ospf 100
router-id 26.1.1.2
log-adjacency-changes
passive-interface default
no passive-interface Ethernet1
no passive-interface Serial0
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
no synchronization
bgp router-id 26.1.1.2
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 soft-reconfiguration inbound
neighbor 26.1.1.6 remote-as 236
neighbor 26.1.1.6 next-hop-self
neighbor 36.1.1.3 remote-as 236
neighbor 36.1.1.3 next-hop-self
neighbor 36.1.1.3 soft-reconfiguration inbound
!
r2#sib
BGP table version is 7, local router ID is 26.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i26.1.1.0/24 26.1.1.6 0 100 0 i
* i36.1.1.0/24 36.1.1.3 0 100 0 i
*>i 26.1.1.6 0 100 0 i
*> 192.168.1.0 10.1.1.1 20 0 1 i
r2#
...
11:18:03: BGP(0): 26.1.1.6 computing updates, afi 0, neighbor version 0,
table v
ersion 5, starting at 0.0.0.0
11:18:03: BGP(0): 26.1.1.6 send UPDATE (format) 192.168.1.0/24, next
26.1.1.2, m
etric 20, path 1
11:18:03: BGP(0): 26.1.1.6 1 updates enqueued (average=59, maximum=59)
11:18:03: BGP(0): 26.1.1.6 update run completed, afi 0, ran for 16ms,
neighbor v
ersion 0, start version 5, throttled to 5
11:18:03: BGP: 26.1.1.6 initial update completed#
r2#
11:18:07: BGP(0): 36.1.1.3 computing updates, afi 0, neighbor version 4,
table v
ersion 5, starting at 0.0.0.0
11:18:07: BGP(0): 36.1.1.3 send UPDATE (format) 192.168.1.0/24, next
26.1.1.2, m
etric 20, path 1
11:18:07: BGP(0): 36.1.1.3 1 updates enqueued (average=59, maximum=59)
11:18:07: BGP(0): 36.1.1.3 update run completed, afi 0, ran for 12ms,
neighbor v
ersion 4, start version 5, throttled to 5
11:18:08: BGP(0): 36.1.1.3 rcv UPDATE about 192.168.1.0/24 -- withdrawn
------------------------------------------
R3: (AS236, backup border router to AS1)
r3#sb router
router ospf 100
router-id 36.1.1.3
log-adjacency-changes
passive-interface default
no passive-interface Ethernet0
no passive-interface Serial0
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
no synchronization
bgp log-neighbor-changes
network 36.1.1.0 mask 255.255.255.0
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 soft-reconfiguration inbound
neighbor 26.1.1.2 remote-as 236
neighbor 26.1.1.2 next-hop-self
neighbor 26.1.1.2 soft-reconfiguration inbound
neighbor 36.1.1.6 remote-as 236
neighbor 36.1.1.6 next-hop-self
neighbor 36.1.1.6 soft-reconfiguration inbound
!
r3#sib
BGP table version is 8, local router ID is 36.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i26.1.1.0/24 36.1.1.6 0 100 0 i
*> 36.1.1.0/24 0.0.0.0 0 32768 i
* i 36.1.1.6 0 100 0 i
*>i192.168.1.0 26.1.1.2 20 100 0 1 i
* 10.1.1.1 30 0 1 i
r3#
----------------------------------------
R6: (AS236, internal router, have to go through R2 or R3 to reach AS1)
r6#sb router
router ospf 100
router-id 36.1.1.6
log-adjacency-changes
passive-interface default
no passive-interface Ethernet0
no passive-interface Ethernet1
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
no synchronization
bgp router-id 36.1.1.6
bgp log-neighbor-changes
network 26.1.1.0 mask 255.255.255.0
network 36.1.1.0 mask 255.255.255.0
neighbor 26.1.1.2 remote-as 236
neighbor 26.1.1.2 soft-reconfiguration inbound
neighbor 36.1.1.3 remote-as 236
neighbor 36.1.1.3 soft-reconfiguration inbound
!
r6#sib
BGP table version is 7, local router ID is 36.1.1.6
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 26.1.1.0/24 0.0.0.0 0 32768 i
* i36.1.1.0/24 36.1.1.3 0 100 0 i
*> 0.0.0.0 0 32768 i
*>i192.168.1.0 26.1.1.2 20 100 0 1 i
r6#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:58 GMT-3