ISDN Callback - Solved!

From: Nicolai Gersbo Solling (nicolai@xxxxxxxxx)
Date: Wed Apr 03 2002 - 12:55:56 GMT-3


   
Hi there Guys!

After fidling around with it for a while I have figred out why the Callback
did not work...

The reason is that you have to have a dialer map at the callback-server that
points to the hostname of the client...

for instance in my case on R2:
dialer map ip 192.168.3.1 name ISDN-1 class CALLBACK broadcast 384010

Apart from that the map-class is also very important...
In this case I have the following map-class defined:

map-class dialer CALLBACK
 dialer callback-server username

This mean that I have the following config on ISDN-2:

ISDN-2#sh run
Building configuration...

Current configuration : 1068 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ISDN-2
!
!
username ISDN-10 password 0 nicolai
username ISDN-1 password 0 nicolai
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-net3
!
!
!
interface Loopback0
 ip address 192.168.4.2 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 192.168.2.2 255.255.255.0
 keepalive 1
!
interface BRI0
 ip address 192.168.3.2 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 30
 dialer map ip 192.168.3.1 name ISDN-1 class CALLBACK broadcast 384010
 dialer-group 1
 isdn switch-type basic-net3
 ppp callback accept
 ppp authentication chap callin
 ppp multilink
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.2 0.0.0.0 area 0
 network 192.168.3.2 0.0.0.0 area 0
 network 192.168.4.2 0.0.0.0 area 0
!
no ip classless
no ip http server
!
!
map-class dialer CALLBACK
 dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
line vty 0 4
 login
!
end

Config for ISDN-1:
ISDN-1#sh run
Building configuration...

Current configuration : 1388 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname ISDN-1
!
no logging buffered
!
username ISDN-2 password 0 nicolai
username ISDN-1 callback-dialstring 384010 password 0 nicolai
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-net3
!
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.0
 keepalive 1
 shutdown
!
interface BRI0
 ip address 192.168.3.1 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 30
 dialer map ip 192.168.3.2 broadcast 384020
 dialer-group 1
 isdn switch-type basic-net3
 ppp callback request
 ppp authentication chap
 ppp chap hostname ISDN-1
 ppp chap password 7 14191B0803082B22
 ppp multilink
 hold-queue 1024 out
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.1 0.0.0.0 area 0
 network 192.168.2.1 0.0.0.0 area 0
 network 192.168.3.1 0.0.0.0 area 0
!
no ip classless
no ip http server
!
logging trap critical
access-list 1 permit any
access-list 100 deny udp any eq rip any eq rip
access-list 100 permit ip any any
dialer watch-list 1 ip 192.168.4.0 255.255.255.0
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
line vty 0 4
 login
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:52 GMT-3