From: DAN DORTON (DHSTS68@xxxxxxxxxxxxxxx)
Date: Tue Apr 02 2002 - 11:08:52 GMT-3
I have ran snapshot & demand circuits simultainiously many times.
Make sure that if you are using dialer-idle timeout at a low interval
to shut down the demand circuit bring it back up at least above the time
it takes snapshot keepalives to cross the link.
Otherwise snapshot will be broken.
You can use the suppress-state-change command for snapshot if you wish
snapshot not to come up everytime the demand circuit does, otherwise
snapshot will go active everytime the link goes up.
I prefer to just let snapshot come up & down as the link does.
I currently have a configuration running with snapshot, demand circuit,
one-way chap & ppp callback.
Here are the configs if you wish to take a look at them.
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
username R6 password 0 dial
ip subnet-zero
no ip domain-lookup
!
ip cef
ip ssh time-out 120
ip ssh authentication-retries 3
ipx routing 0000.0003.0003
isdn switch-type basic-ni
!
!
!
!
interface Loopback0
ip address 200.200.200.3 255.255.255.255
!
interface Ethernet0
ip address 172.168.36.3 255.255.255.248
ip ospf message-digest-key 1 md5 secure
ipx network 36
!
interface Serial0
bandwidth 64
ip address 172.168.13.3 255.255.255.0
ip rip send version 1
ip rip receive version 1
encapsulation frame-relay
ip split-horizon
ipx network 13
frame-relay map ipx 13.0000.0001.0001 301 broadcast
frame-relay map ipx 13.0000.0003.0003 301 broadcast
frame-relay map ip 172.168.13.1 301 broadcast
frame-relay map ip 172.168.13.3 301 broadcast
no frame-relay inverse-arp
!
interface BRI0
bandwidth 128
ip address 172.168.63.1 255.255.255.252
encapsulation ppp
ip ospf demand-circuit
dialer map snapshot 1 name R3 broadcast 18008358662
dialer map snapshot 1 name R3 broadcast 18008358664
dialer map ip 172.168.63.1 name R6 broadcast 18008358662
dialer map ip 172.168.63.2 name R6 broadcast 18008358662
dialer map ip 172.168.63.2 name R6 broadcast 18008358664
dialer map ipx 63.0000.0003.0003 name R6 broadcast 18008358662
dialer map ipx 63.0000.0006.0006 name R6 broadcast 18008358662
dialer map ipx 63.0000.0006.0006 name R6 broadcast 18008358664
dialer hold-queue 50
dialer load-threshold 1 either
dialer-group 1
ipx network 63
no ipx route-cache
ipx watchdog-spoof
ipx spx-spoof
isdn switch-type basic-ni
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
snapshot client 5 30 dialer
no peer neighbor-route
ppp callback request
ppp authentication chap callin
ppp multilink
!
router ospf 1
log-adjacency-changes
area 0 authentication message-digest
area 0 range 172.168.36.0 255.255.255.0
area 0 range 172.168.63.0 255.255.255.0
network 172.168.36.0 0.0.0.7 area 0
network 172.168.63.0 0.0.0.3 area 0
network 200.200.200.3 0.0.0.0 area 0
default-information originate always
!
router rip
timers basic 15 90 90 120
redistribute ospf 1 metric 1
passive-interface BRI0
network 172.168.0.0
network 200.200.200.0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 200.200.200.1 remote-as 200
neighbor 200.200.200.1 update-source Loopback0
neighbor 200.200.200.1 route-reflector-client
neighbor 200.200.200.6 remote-as 200
neighbor 200.200.200.6 update-source Loopback0
neighbor 200.200.200.6 route-reflector-client
no auto-summary
!
ip classless
ip route 200.200.200.1 255.255.255.255 172.168.31.1
no ip http server
ip pim bidir-enable
!
access-list 101 deny udp any any eq rip
access-list 101 deny udp any eq rip any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 permit ip any any
access-list 901 deny rip any all any all
access-list 901 deny sap any all any all
access-list 901 deny any any all any 457
access-list 901 permit any any all any all
dialer-list 1 protocol ip list 101
dialer-list 1 protocol ipx list 901
!
!
!
alias subinterface fi frame map ip
alias subinterface fx frame map ipx
alias interface fi frame map ip
alias interface fx frame map ipx
alias interface di dialer map ip
alias interface dx dialer map ipx
alias configure rr router rip
alias configure ri router igrp
alias configure re router eigrp
alias configure rs router isis
alias configure rb router bgp
alias configure ro router ospf
alias configure xr ipx router rip
alias configure xe ipx router eigrp
alias configure xn ipx router nlsp
alias exec ct config t
alias exec sr show run
alias exec si show ip route
alias exec sx show ipx route
alias exec sbn show ip bgp neighbor
alias exec sb show ip bgp
alias exec son show ip ospf neighbor
alias exec ci clear ip route *
alias exec cx clear ipx route *
alias exec cb clear ip bgp *
alias exec sfm show frame map
!
line con 0
exec-timeout 0 0
line vty 0 4
!
end
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
!
username R3 password 0 dial
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0006.0006
isdn switch-type basic-ni
!
voice-port 1/0/0
!
voice-port 1/1/0
!
voice-port 1/0/1
!
voice-port 1/1/1
!
!
!
!
!
interface Loopback0
ip address 200.200.200.6 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/0
ip address 172.168.36.6 255.255.255.248
no ip directed-broadcast
ip ospf message-digest-key 1 md5 secure
!
interface Serial0/0
bandwidth 64
ip address 172.168.46.6 255.255.255.240
no ip directed-broadcast
encapsulation frame-relay
ip ospf authentication-key 1 cisco
ip ospf network point-to-point
ip ospf priority 6
no ip mroute-cache
ipx network 46
frame-relay map ip 172.168.46.4 604 broadcast
frame-relay map ip 172.168.46.6 604 broadcast
frame-relay map ipx 46.0000.0004.0004 604 broadcast
frame-relay map ipx 46.0000.0006.0006 604 broadcast
no frame-relay inverse-arp
!
interface TokenRing0/0
ip address 172.168.62.6 255.255.255.0
no ip directed-broadcast
ip ospf authentication-key 1 cisco
ring-speed 16
!
interface BRI0/0
bandwidth 128
ip address 172.168.63.2 255.255.255.252
no ip directed-broadcast
encapsulation ppp
dialer callback-secure
dialer map snapshot 1 name R3 class callback broadcast 18008358661
dialer map snapshot 1 name R3 class callback broadcast 18008358663
dialer map ip 172.168.63.1 name R3 class callback broadcast
18008358661
dialer map ip 172.168.63.1 name R3 class callback broadcast
18008358663
dialer map ip 172.168.63.2 name R3 class callback broadcast
18008358661
dialer map ipx 63.0000.0003.0003 name R3 class callback broadcast
18008358661
dialer map ipx 63.0000.0003.0003 name R3 class callback broadcast
18008358663
dialer map ipx 63.0000.0006.0006 name R3 class callback broadcast
18008358661
dialer hold-queue 50
dialer load-threshold 1 either
dialer-group 1
ipx network 63
no ipx route-cache
ipx watchdog-spoof
ipx spx-spoof
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
no peer neighbor-route
snapshot server 5 dialer
ppp callback accept
ppp authentication chap
ppp multilink
!
interface Serial0/1
mtu 1400
bandwidth 64
ip address 172.168.26.6 255.255.255.240
no ip directed-broadcast
encapsulation frame-relay
ip ospf authentication-key 1 cisco
ip ospf priority 6
ipx network 26
clockrate 64000
frame-relay map ipx 26.0000.0002.0002 602 broadcast
frame-relay map ip 172.168.26.2 602 broadcast
frame-relay map ipx 26.0000.0006.0006 602 broadcast
frame-relay map ip 172.168.26.6 602 broadcast
no frame-relay inverse-arp
!
router ospf 1
area 0 authentication message-digest
area 0 range 172.168.36.0 255.255.255.0
area 0 range 172.168.63.0 255.255.255.0
area 2 range 172.168.26.0 255.255.255.0
area 2 virtual-link 200.200.200.2 message-digest-key 1 md5 secure
area 4 authentication
area 4 range 172.168.46.0 255.255.255.0
area 4 virtual-link 200.200.200.4 message-digest-key 1 md5 secure
area 51 authentication
area 51 virtual-link 200.200.200.2 message-digest-key 1 md5 secure
network 172.168.26.0 0.0.0.15 area 2
network 172.168.36.0 0.0.0.7 area 0
network 172.168.46.0 0.0.0.15 area 4
network 172.168.62.0 0.0.0.255 area 51
network 172.168.63.0 0.0.0.3 area 0
network 200.200.200.6 0.0.0.0 area 0
neighbor 172.168.26.2 priority 255
!
router bgp 200
no synchronization
neighbor peers100 peer-group
neighbor peers100 remote-as 100
neighbor peers100 ebgp-multihop 2
neighbor peers100 update-source Loopback0
neighbor peers100 maximum-prefix 200 warning-only
neighbor 200.200.200.2 peer-group peers100
neighbor 200.200.200.3 remote-as 200
neighbor 200.200.200.3 update-source Loopback0
neighbor 200.200.200.4 peer-group peers100
no auto-summary
!
ip classless
!
!
map-class dialer callback
dialer callback-server username
access-list 901 deny rip any all any all
access-list 901 deny sap any all any all
access-list 901 deny any any all any 457
access-list 901 permit any any all any all
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx list 901
!
!
!
!
alias subinterface fi frame map ip
alias subinterface fx frame map ipx
alias interface fi frame map ip
alias interface fx frame map ipx
alias interface di dialer map ip
alias interface dx dialer map ipx
alias configure rr router rip
alias configure ri router igrp
alias configure re router eigrp
alias configure rs router isis
alias configure rb router bgp
alias configure ro router ospf
alias configure xr ipx router rip
alias configure xe ipx router eigrp
alias configure xn ipx router nlsp
alias exec ct config t
alias exec sr show run
alias exec si show ip route
alias exec sx show ipx route
alias exec sbn show ip bgp neighbor
alias exec sb show ip bgp
alias exec son show ip ospf neighbor
alias exec ci clear ip route *
alias exec cx clear ipx route *
alias exec cb clear ip bgp *
alias exec sfm show frame map
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
Dan
>>> "Chua, Parry" <Parry.Chua@compaq.com> 04/01/02 10:11PM >>>
I think there is not cinflict for demand circuit and snapshot. deamnd
circuit does not shutdown the link but suppress hello and it is
available for use. Snapshot does not depends on which routing protocols,
it just merely turn on and off for some time. It characteristic suit for
routing protocol that send update periodic thus good for non-link state
routing protocols. Backup interface is the one that shutdown the link.
Floating static should also be able to work with demand circuit.
Parry Chua
-----Original Message-----
From: Ouellette, Tim [mailto:tim.ouellette@eds.com]
Sent: Tuesday, April 02, 2002 11:45 AM
To: 'Lupi, Guy'
Cc: 'ccielab@groupstudy.com'
Subject: RE: DDR for IPX
My understanding is Snapshot routing is only used for distance vector
routing protocols.
Also, the whole Demand circuit thing is to keep a link down, which in
terms
of functionality is the same as snapshot (well, somewhat anyways).
Tim
-----Original Message-----
From: Lupi, Guy [mailto:Guy.Lupi@eurekaggn.com]
Sent: Monday, April 01, 2002 4:59 PM
To: 'ccielab@groupstudy.com'
Subject: DDR for IPX
Does anyone know whether or not snapshot routing can be used in
conjunction
with OSPF demand circuits? I don't see why not. Snapshot is the only
way
to back up IPX correct?
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:51 GMT-3