From: ying chang (ying_c@xxxxxxxxxxx)
Date: Sun Mar 24 2002 - 00:29:27 GMT-3
Hi,
I did it a few days ago. The setup is almost identical to what you have in
BRI0. In your callback server's dialer interface, Replace your BRI's dialer
map command with "dialer string xxxxxxx class class-name", all ppp commands
pretty much just move from bri to dialer1.
Chang
>From: "Sean C." <Upp_and_Upp@hotmail.com>
>Reply-To: "Sean C." <Upp_and_Upp@hotmail.com>
>To: <Steven.Dill@us.didata.com>, <ccielab@groupstudy.com>
>Subject: Re: ISDN callback scenario w/ Dialer interface??
>Date: Sat, 23 Mar 2002 20:13:12 -0800
>
>Good question on using profiles. Don't know. But looking at your configs
>-
>the first question I would have is how does the callback router know what
>number to dial back. Usually this is applied from dialer maps but since
>you
>can't apply dialer-maps to profiles I guess you would have to place the
>dialer string on the callback router. How else is it going to know to
>callback the calling router - hmmm? Also, you may want to strip off the
>extras till you get the link up once - like the chap hostanme and password
>and just use usernames until that part is stable. Also, I think the dialer
>class needs to be applied to allow the callback profile interface to return
>calls after callback is succesfully negotiated.
>
>HTH,
>Sean
>----- Original Message -----
>From: <Steven.Dill@us.didata.com>
>To: <nshah@connect.com.au>; <Upp_and_Upp@hotmail.com>; <labccie@yahoo.com>;
><mamoor@ieee.org>; <ccielab@groupstudy.com>
>Sent: Saturday, March 23, 2002 4:35 PM
>Subject: RE: ISDN callback scenario w/ Dialer interface??
>
>
>Can this be done on a dialer interface??
>
>I am attempting to do this and my first call attempt (ping) is a success.
>After the line disconnects and I attempt to ping again and it fails.
>
>(Calling Router)
>
>interface BRI0
> no ip address
> no ip route-cache
> no ip mroute-cache
> dialer pool-member 1
> isdn switch-type basic-ni
> isdn spid1 0835866101 8358661
> isdn spid2 0835866301 8358663
>!
>interface Dialer1
> ip address 122.3.34.1 255.255.255.252
> encapsulation ppp
> ip ospf message-digest-key 1 md5 cisco
> dialer remote-name r4
> dialer pool 1
> dialer idle-timeout 10
> dialer string 8358662
> dialer watch-group 1
> dialer-group 1
> ppp callback request
> ppp authentication chap
> ppp chap hostname cisco
> ppp chap password 7 1511021F072
>
>(Callback Router)
>
>interface BRI0
> no ip address
> no ip route-cache
> no ip mroute-cache
> dialer pool-member 1
> isdn switch-type basic-ni
> isdn spid1 0835866201 8358662
> isdn spid2 0835866401 8358664
>!
>interface Dialer1
> ip address 122.3.34.2 255.255.255.252
> encapsulation ppp
> no ip route-cache
> ip ospf message-digest-key 1 md5 cisco
> no ip mroute-cache
> dialer pool 1
> dialer callback-secure
> dialer-group 1
> ppp callback accept
> ppp authentication chap
>
>
>
>Thank you!!!
>
>
>
>-----Original Message-----
>From: Nick Shah [mailto:nshah@connect.com.au]
>Sent: Saturday, March 23, 2002 7:16 PM
>To: Sean C.; Lab Candidate; Ahmed Mamoor Amimi; ccielab@groupstudy.com
>Subject: Re: ISDN callback scenario
>
>
>well atleast, you have multilink configured on both ends , LAB Candidate
>(cant the name be simpler :) doesnt ...
>
>In real life , I have found more IOS's where Multilink PPP doesnt work
>properly than in which it works...
>
>Nick
>-----Original Message-----
>From: Sean C. <Upp_and_Upp@hotmail.com>
>To: Nick Shah <nshah@connect.com.au>; Lab Candidate <labccie@yahoo.com>;
>Ahmed Mamoor Amimi <mamoor@ieee.org>; ccielab@groupstudy.com
><ccielab@groupstudy.com>
>Date: Sunday, 24 March 2002 10:56
>Subject: Re: ISDN callback scenario
>
>
> >Hello,
> >
> >Well, I just took my stab at the callback scenario and it worked fine
>using
> >the configs from Lab candidate (do you need to be that anonymous?). I
>also
> >added the commands 'dialer enable-timeout 5' on the callback router and
> >'dialer wait-for-carrier 10' but the callback worked whether these were
> >configured or not.
> >
> >The only thing I can't guarantee is my multilink. I have it enabled on
>both
> >sides butttt sometimes the multilink works, sometimes multilink doesn't
> >work. I have a feeling it's more my simulator or the code than anything.
> >The calls still go through, just sometimes the 2nd channel doesn't get
> >brought up.
> >
> >IOS r5 - Version 12.1(8)
> >IOS r6 - Version 12.1(12)
> >!
> >hostname r5
> >!
> >username r6 password 0 cisco
> >!
> >interface BRI0
> > description Callback router
> > ip address 40.40.40.2 255.255.255.0
> > encapsulation ppp
> > dialer callback-secure
> > dialer enable-timeout 5
> > dialer map ip 40.40.40.1 name r6 class test broadcast 2221
> > dialer map ip 40.40.40.1 name r6 class test broadcast 2222
> > dialer load-threshold 3 either
> > dialer-group 1
> > isdn switch-type basic-net3
> > isdn spid1 1111
> > isdn spid2 1112
> > ppp callback accept
> > ppp authentication chap
> > ppp multilink
> >!
> >map-class dialer test
> > dialer callback-server username
> >!
> >dialer-list 1 protocol ip permit
> >!
> >=============================
> >hostname r6
> >!
> >username r5 password 0 cisco
> >!
> >interface BRI0
> > description Calling router
> > ip address 40.40.40.1 255.255.255.0
> > encapsulation ppp
> > dialer wait-for-carrier-time 10
> > dialer map ip 40.40.40.2 name r5 broadcast 1111
> > dialer map ip 40.40.40.2 name r5 broadcast 1112
> > dialer load-threshold 3 either
> > dialer-group 1
> > isdn switch-type basic-net3
> > isdn spid1 2221
> > isdn spid2 2222
> > no peer neighbor-route
> > ppp callback request
> > ppp authentication chap
> > ppp multilink
> >!
> >dialer-list 1 protocol ip permit
> >!
> >
> >
> >r6#p
> >Target IP address: 40.40.40.2
> >Repeat count [5]: 15
> >Datagram size [100]: 1500
> >Type escape sequence to abort.
> >Sending 15, 1500-byte ICMP Echos to 40.40.40.2, timeout is 2 seconds:
> >00:44:01: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
> >00:44:01: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down..
> >00:44:07: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
> >00:44:07: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to
>up.!!!
> >00:44:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, changed
> >state to up
> >00:44:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface
>Virtual-Access1,
> >changed state to up!!!!!!!!
> >Success rate is 73 percent (11/15), round-trip min/avg/max = 384/388/396
>ms
> >00:44:13: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 1111 r5
> >
> >The initial up/down/up on the r6's output is the calling going to r5,
> >accepted by r5, r5 disconnecting per callback feature, and the r5
> >successfully calling r6 back.
> >
> >HTH,
> >Sean
> >
> >
> >----- Original Message -----
> >From: "Nick Shah" <nshah@connect.com.au>
> >To: "Lab Candidate" <labccie@yahoo.com>; "Ahmed Mamoor Amimi"
> ><mamoor@ieee.org>; <ccielab@groupstudy.com>
> >Sent: Saturday, March 23, 2002 2:10 PM
> >Subject: Re: ISDN callback scenario
> >
> >
> >hmm...on one router you have got ppp multilink configured on the client
> >side, and not on the server, This *may* cause dialer callback-secure to
> >reject the call as improperly configured. try removing ppp multilink.
> >
> >If that still doesnt resolve the issue, I would do a debug on ppp nego. &
> >authentication and see that r2/r3 is getting authenticated and
>negotiating
> >call back parameters...
> >
> >hth
> >Nick
> >
> >-----Original Message-----
> >From: Lab Candidate <labccie@yahoo.com>
> >To: Ahmed Mamoor Amimi <mamoor@ieee.org>; ccielab@groupstudy.com
> ><ccielab@groupstudy.com>
> >Date: Saturday, 23 March 2002 8:47
> >Subject: Re: ISDN callback scenario
> >
> >
> >>I took out dialer callback secure and it still desn't work giving the
>same
> >error message "callback
> >>is not configured for user r2". But it works perfectly when I changed it
>to
> >caller ID callback.
> >>Any ider what's going on here?
> >>
> >>
> >>--- Ahmed Mamoor Amimi <mamoor@ieee.org> wrote:
> >>> first try this with the minimum config.
> >>> remove the call-back secure then try.
> >>>
> >>> i was wondering if call-back works with multilink.. !! let me know ..
> >>>
> >>> -Mamoor
> >>>
> >>>
> >>> ----- Original Message -----
> >>> From: Lab Candidate <labccie@yahoo.com>
> >>> To: <ccielab@groupstudy.com>
> >>> Sent: Saturday, March 23, 2002 12:59 PM
> >>> Subject: ISDN callback scenario
> >>>
> >>>
> >>> > r2 and r3 are setup with basic ISDN callback as below.
> >>> > r2 callback client, r3 callback server.
> >>> > everything is configured as CCO example, but when r2 calls r3
> >>> > when r2 pings r3, r2 calls and disconnects, and waiting for r3.
> >>> > but r3 never calls back.
> >>> > r3 debug says "callback is not configured for user r2"
> >>> > debug output and r2/r3 configs attached below.
> >>> > what's the problem here please?
> >>> >
> >>> > r3#
> >>> > 2d05h: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
> >>> > 2d05h: BR0/0:1 DDR: No callback configured for user r2.
> >>> > 2d05h: BR0/0:1 DDR: disconnecting call
> >>> > 2d05h: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 2588
>r2
> >>> > 2d05h: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
> >>> > 2d05h: BR0/0:1 DDR: disconnecting call
> >>> >
> >>> > ===============r2==================
> >>> > version 12.2
> >>> > service timestamps debug uptime
> >>> > service timestamps log uptime
> >>> > no service password-encryption
> >>> > !
> >>> > hostname r2
> >>> > !
> >>> > no logging buffered
> >>> > !
> >>> > username r3 password 0 cisco
> >>> > ip subnet-zero
> >>> > !
> >>> > !
> >>> > interface BRI0/0
> >>> > ip address 40.40.40.1 255.255.255.0
> >>> > encapsulation ppp
> >>> > dialer map snapshot 1 name r3 broadcast 2589
> >>> > dialer map ip 40.40.40.2 name r3 broadcast 2589
> >>> > dialer load-threshold 50 either
> >>> > dialer-group 1
> >>> > isdn switch-type basic-ni
> >>> > isdn spid1 2588 2588
> >>> > isdn spid2 3588 3588
> >>> > no cdp enable
> >>> > ppp callback request
> >>> > ppp authentication chap
> >>> > ppp multilink
> >>> > !
> >>> > dialer-list 1 protocol ip permit
> >>> > !
> >>> > !
> >>> > line con 0
> >>> > exec-timeout 0 0
> >>> > line aux 0
> >>> > line vty 0 4
> >>> > password tts
> >>> > no login
> >>> > !
> >>> > end
> >>> >
> >>> > r2#
> >>> >
> >>> >
> >>> > ============r3=============
> >>> > version 12.2
> >>> > service timestamps debug uptime
> >>> > service timestamps log uptime
> >>> > no service password-encryption
> >>> > !
> >>> > hostname r3
> >>> > !
> >>> > !
> >>> > username r2 password 0 cisco
> >>> > ip subnet-zero
> >>> > !
> >>> > isdn switch-type basic-ni
> >>> > !
> >>> > interface BRI0/0
> >>> > ip address 40.40.40.2 255.255.255.0
> >>> > encapsulation ppp
> >>> > dialer callback-secure
> >>> > dialer map snapshot 1 name r2 broadcast 2588
> >>> > dialer map ip 40.40.40.1 name r2 class dc1 broadcast 2588
> >>> > dialer-group 1
> >>> > isdn switch-type basic-ni
> >>> > isdn spid1 2589 2589
> >>> > isdn spid2 3589 3589
> >>> > snapshot server 5 dialer
> >>> > ppp callback accept
> >>> > ppp authentication chap
> >>> > !
> >>> > map-class dialer dc1
> >>> > dialer callback-server username
> >>> >
> >>> > dialer-list 1 protocol ip permit
> >>> > !
> >>> > line con 0
> >>> > line aux 0
> >>> > line vty 0 4
> >>> > password tts
> >>> > no login
> >>> > !
> >>> > ntp master 1
> >>> > end
> >>> >
> >>> > r3#
> >>> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:20 GMT-3