From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Mon Mar 18 2002 - 00:34:59 GMT-3
I will suggest that make the config in a more simple way up to verify what went
wrong.
You will notice that your R6 only learn a eigrp external (D EX) route from R9 a
nd
R9 only learn two eigrp internal route from R6, what happen to the rest of eigr
p routes
(internal and external) ?
Parry Chua
-----Original Message-----
From: Dustin.Yates@ercgroup.com [mailto:Dustin.Yates@ercgroup.com]
Sent: Saturday, March 16, 2002 7:22 AM
To: ccielab@groupstudy.com
Cc: tshon@netzero.net
Subject: RE: OSPF to EIGRP Redistribution Problem
Not at all...
R6:
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
logging rate-limit console 10 except errors
!
ip subnet-zero
!
!
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
key chain atmexpert
key 1
key-string ccie
call rsvp-sync
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
ip address 200.0.0.6 255.255.255.255
!
interface Ethernet0/0
ip address 150.50.7.6 255.255.255.128
ip ospf authentication
ip ospf authentication-key ccie
half-duplex
standby 1 timers 7 17
standby 1 priority 110 preempt
standby 1 authentication ipexpert
standby 1 name ipexpert_r6
standby 1 mac-address 0000.0c07.aaaa
standby 1 ip 150.50.7.1
!
interface Serial0/0
bandwidth 500
ip address 150.50.100.6 255.255.255.224
encapsulation frame-relay
ip ospf authentication
ip ospf authentication-key ccie
ip ospf priority 0
no fair-queue
frame-relay map ip 150.50.100.2 401 broadcast
frame-relay map ip 150.50.100.5 401 broadcast
no frame-relay inverse-arp
frame-relay lmi-n391dte 255
frame-relay lmi-n392dte 10
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial0/1
bandwidth 1000
ip address 150.50.6.6 255.255.255.128
clockrate 1000000
!
interface ATM1/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM1/0.100 point-to-point
bandwidth 20000
ip address 150.50.6.9 255.255.255.128
pvc 1/100
protocol ip 150.50.6.5 broadcast
!
!
router eigrp 100
redistribute ospf 1
passive-interface default
no passive-interface Serial0/1
network 150.50.0.0
default-metric 56 100 255 1 1500
no auto-summary
eigrp log-neighbor-changes
!
router ospf 1
log-adjacency-changes
area 0 authentication
redistribute connected subnets
redistribute eigrp 100 subnets
passive-interface default
no passive-interface Ethernet0/0
no passive-interface Serial0/0
network 150.50.7.6 0.0.0.0 area 1
network 150.50.100.6 0.0.0.0 area 0
network 200.0.0.6 0.0.0.0 area 0
default-metric 100
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
dial-peer cor custom
!
!
!
alias exec crs copy run start
alias exec ct config t
alias exec sir show ip route
alias exec siib show ip int brief
alias exec sioi show ip ospf interface
alias exec sion show ip ospf neigh
alias exec cib clear ip bgp
alias exec sibn show ip bgp nei
alias exec srb show run | begin
alias exec ssb show start | begin
alias exec ssbr show start | begin router
alias exec sr show run
alias exec ss show start
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
transport input none
escape-character 17
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
login
!
end
R6#
R9:
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R9
!
!
!
!
!
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
cns event-service server
!
!
!
interface Loopback0
ip address 200.0.0.9 255.255.255.255
!
interface Tunnel0
ip unnumbered Serial0
shutdown
tunnel source Serial0
tunnel destination 150.50.5.69
!
interface Ethernet0
ip address 150.50.6.209 255.255.255.128
shutdown
!
interface Serial0
bandwidth 1000
ip address 150.50.6.9 255.255.255.128
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router eigrp 100
redistribute connected
passive-interface default
no passive-interface Serial0
network 150.50.0.0
no auto-summary
eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
alias exec crs copy run start
alias exec ct config t
alias exec sir show ip route
alias exec siib show ip int brief
alias exec sioi show ip ospf interface
alias exec sion show ip ospf neigh
alias exec cib clear ip bgp
alias exec sibn show ip bgp nei
alias exec srb show run | begin
alias exec ssb show start | begin
alias exec ssbr show start | begin router
alias exec sr show run
alias exec ss show start
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
login
!
end
R9#
-----Original Message-----
From: Tshon [mailto:tshon@netzero.net]
Sent: Friday, March 15, 2002 3:56 PM
To: Dustin.Yates@ercgroup.com
Cc: ccielab@groupstudy.com
Subject: Re: OSPF to EIGRP Redistribution Problem
Do you mind showing us the whole config?
Dustin.Yates@ercgroup.com wrote:
>Just to set this up... I've got two routers connected back-to-back, R6
>running 12.2(1) & R9 running 12.1(1), via serial connection. I'm running
>OSPF and EIGRP on R6 with OSPF redistributed into EIGRP. EIGRP is active
>only on the link between R6 & R9. Relevant configs:
>
>R6:
>interface Serial0/1
> bandwidth 1000
> ip address 150.50.6.6 255.255.255.128
> clockrate 1000000
>!
>router eigrp 100
> redistribute ospf 1
> passive-interface default
> no passive-interface Serial0/1
> no passive-interface ATM1/0.100
> network 150.50.0.0
> default-metric 56 100 255 1 1500
> no auto-summary
> eigrp log-neighbor-changes
>!
>router ospf 1
> log-adjacency-changes
> area 0 authentication
> redistribute connected subnets
> redistribute eigrp 100 subnets
> passive-interface default
> no passive-interface Ethernet0/0
> no passive-interface Serial0/0
> network 150.50.7.6 0.0.0.0 area 1
> network 150.50.100.6 0.0.0.0 area 0
> network 200.0.0.6 0.0.0.0 area 0
> default-metric 100
>!
>
>R9:
>interface Serial0
> bandwidth 1000
> ip address 150.50.6.9 255.255.255.128
> no fair-queue
>!
>router eigrp 100
> redistribute connected
> passive-interface default
> no passive-interface Serial0
> network 150.50.0.0
> no auto-summary
> eigrp log-neighbor-changes
>!
>
>Here's my problem... R6 has numerous OSPF routes that aren't making it into
>R9's routing table. I see EIGRP internal routes on R9. And, I can even
see
>the ExtS tagged routes from "debug ip eigrp" on R9. I've done this so many
>times now that I'm afraid I'm missing something small. Can anyone provide
a
>hint as to what I've overlooked here? Here's a copy of the "show ip route"
>and "debug ip eigrp" outputs:
>
>R6#sir
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
>area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
>Gateway of last resort is not set
>
> 200.0.0.0/24 is variably subnetted, 7 subnets, 2 masks
>O IA 200.0.0.8/32 [110/302] via 150.50.100.5, 18:32:01, Serial0/0
>D EX 200.0.0.9/32 [170/3200000] via 150.50.6.9, 00:02:17, Serial0/1
>O E2 200.0.0.0/24 [110/100] via 150.50.100.2, 18:32:01, Serial0/0
>O E2 200.0.0.1/32 [110/100] via 150.50.100.2, 18:32:01, Serial0/0
>O 200.0.0.5/32 [110/201] via 150.50.100.5, 18:32:01, Serial0/0
>C 200.0.0.6/32 is directly connected, Loopback0
>O 200.0.0.7/32 [110/11] via 150.50.7.7, 18:32:02, Ethernet0/0
>O E2 10.0.0.0/8 [110/100] via 150.50.100.2, 18:32:02, Serial0/0
> 150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
>O E2 150.50.200.0/24 [110/100] via 150.50.100.2, 18:32:02, Serial0/0
>O IA 150.50.4.0/24 [110/365] via 150.50.100.5, 18:32:02, Serial0/0
>C 150.50.6.0/25 is directly connected, Serial0/1
>C 150.50.7.0/25 is directly connected, Ethernet0/0
>O E2 150.50.17.0/24 [110/100] via 150.50.100.2, 18:32:04, Serial0/0
>O E2 150.50.18.0/24 [110/100] via 150.50.100.2, 18:32:04, Serial0/0
>O E2 150.50.24.0/24 [110/100] via 150.50.100.2, 18:32:04, Serial0/0
>C 150.50.100.0/27 is directly connected, Serial0/0
>O 150.50.5.64/27 [110/110] via 150.50.7.7, 18:32:04, Ethernet0/0
>R6#
>
>R9#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
>area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
>Gateway of last resort is not set
>
> 200.0.0.0/32 is subnetted, 1 subnets
>C 200.0.0.9 is directly connected, Loopback0
> 150.50.0.0/16 is variably subnetted, 3 subnets, 2 masks
>C 150.50.6.0/25 is directly connected, Serial0
>D 150.50.7.0/25 [90/3097600] via 150.50.6.6, 00:00:52, Serial0
>D 150.50.100.0/27 [90/6144000] via 150.50.6.6, 00:00:52, Serial0
>R9#
>
>R9#clear ip eigrp nei
>R9#
>17:44:46: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 150.50.6.6 (Serial0) is
>down
>: manually cleared
>R9#
>17:44:49: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 150.50.6.6 (Serial0) is
>up:
>new adjacency
>R9#
>17:44:49: IP-EIGRP: 150.50.6.0/25 - do advertise out Serial0
>17:44:49: IP-EIGRP: 200.0.0.9/32 - do advertise out Serial0
>17:44:49: IP-EIGRP: Ext 200.0.0.9/32 metric 128256 - 256 128000
>R9#
>17:44:51: IP-EIGRP: 150.50.6.0/25 - do advertise out Serial0
>17:44:51: IP-EIGRP: 200.0.0.9/32 - do advertise out Serial0
>17:44:51: IP-EIGRP: Ext 200.0.0.9/32 metric 128256 - 256 128000
>17:44:52: IP-EIGRP: Processing incoming UPDATE packet
>17:44:52: IP-EIGRP: Int 150.50.7.0/25 M 3097600 - 2560000 537600 SM 281600
-
>256
>000 25600
>17:44:52: IP-EIGRP: Int 150.50.100.0/27 M 6144000 - 5120000 1024000 SM
>5632000 -
> 5120000 512000
>17:44:52: IP-EIGRP: ExtS 200.0.0.8/32 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>17:44:52: IP-EIGRP: ExtS 200.0.0.0/24 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>17:44:52: IP-EIGRP: ExtS 200.0.0.1/32 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>17:44:52: IP-EIGRP: ExtS 200.0.0.5/32 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>17:44:52: IP-EIGRP: ExtS 200.0.0.7/32 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>17:44:52: IP-EIGRP: ExtS 10.0.0.0/8 M 46251776 - 45714176 537600 SM
45739776
>- 4
>5714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.200.0/24 M 46251776 - 45714176 537600 SM
>4573977
>6 - 45714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.4.0/24 M 46251776 - 45714176 537600 SM
>45739776
>- 45714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.17.0/24 M 46251776 - 45714176 537600 SM
>45739776
> - 45714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.18.0/24 M 46251776 - 45714176 537600 SM
>45739776
> - 45714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.24.0/24 M 46251776 - 45714176 537600 SM
>45739776
> - 45714176 25600
>17:44:52: IP-EIGRP: ExtS 150.50.5.64/27 M 46251776 - 45714176 537600 SM
>45739776
> - 45714176 25600
>17:44:52: IP-EIGRP: ExtS 200.0.0.6/32 M 46251776 - 45714176 537600 SM
>45739776 -
> 45714176 25600
>R9#
>17:44:54: IP-EIGRP: 150.50.6.0/25 - do advertise out Serial0
>17:44:54: IP-EIGRP: 200.0.0.9/32 - do advertise out Serial0
>17:44:54: IP-EIGRP: Ext 200.0.0.9/32 metric 128256 - 256 128000
>17:44:54: IP-EIGRP: Int 150.50.7.0/25 metric 3097600 - 2560000 537600
>17:44:54: IP-EIGRP: Int 150.50.100.0/27 metric 6144000 - 5120000 1024000
>17:44:54: IP-EIGRP: Processing incoming UPDATE packet
>17:44:54: IP-EIGRP: ExtS 200.0.0.9/32 M 4294967295 - 2560000 4294967295 SM
>42949
>67295 - 2560000 4294967295
>R9#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:12 GMT-3