From: RSiddappa@xxxxxxxxxx
Date: Thu Mar 14 2002 - 13:36:01 GMT-3
This is what I did and it did worked. Little difffernt, but absolutely
useful. ( Watch for Multiring IP)
R1
------T0-------------R2-------------so------------R3------------------Eo----
--------------R4
R1 and R4 end hosts.
R2 is doing the Source route Translational bridging.
R3 is doing Transparent bridging.
Criteria : SR / TLB.
hostname R1
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
!
interface Serial0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 72000
!
interface Serial1
no ip directed-broadcast
ip ospf cost 1
!
interface TokenRing0
ip address 10.10.10.5 255.255.255.0
no ip directed-broadcast
ring-speed 16
multiring ip
!Very important command on R1 for this set up to work.
!
interface BRI0
ip address 172.168.65.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
shutdown
isdn switch-type basic-ni
isdn spid1 0835866401 8358664
isdn spid2 0835866201 8358662
ppp authentication chap
!
interface PCbus0
no ip address
no ip directed-broadcast
shutdown
!
ip classless
!
!
!
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
R1#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.10.4 0 0007.787c.8598 SNAP TokenRing0
Internet 10.10.10.5 - 0007.ef8a.5bde SNAP TokenRing0
R1#ping 10.10.10.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms
hostname R2
!
enable password cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
!
!
source-bridge ring-group 4095
source-bridge transparent 4095 10 1 1
!
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface TokenRing0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
ring-speed 16
source-bridge 6 1 4095
!
interface BRI0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface PCbus0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip classless
!
!
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
!
line con 0
privilege level 15
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
R2#sh bridge
Total of 300 station blocks, 298 free
Codes: P - permanent, S - self
Bridge Group 1:
Address Action Interface Age RX count TX count
00e0.f751.da7b forward RingGroup4095 3 5 5
00e0.1e3e.a119 forward Serial0 3 5 4
R2#sh source-bridge
Local Interfaces: receive transmit
srn bn trn r p s n max hops cnt cnt drops
To0 6 1 4095 * b 7 7 7 10 10 0
Global RSRB Parameters:
TCP Queue Length maximum: 100
Ring Group 4095:
No TCP peername set, TCP transport disabled
Maximum output TCP queue length, per peer: 100
Rings:
bn: 1 rn: 10 locvrt ma: 40e0.f751.d0b3 Bridge-group 1 fwd: 10
bn: 1 rn: 6 local ma: 4007.ef8a.0bcd TokenRing0 fwd: 10
Explorers: ------- input ------- ------- output -------
spanning all-rings total spanning all-rings total
To0 0 0 0 0 0 0
Explorer fastswitching enabled
Local switched: 1 flushed 0 max Bps 38400
rings inputs bursts throttles output drops
To0 0 0 0 0
R2#sh rif
Codes: * interface, - static, + remote
Dst HW Addr Src HW Addr How Idle (min) Routing Information Field
0007.ef8a.0bcd N/A To0 * -
0007.ef8a.5bde N/A BG1 3 0890.0061.FFF1.00A0
hostname R3
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
cns event-service server
!
interface Ethernet0
no ip address
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface Serial0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
ip address 30.30.30.2 255.255.255.0
no ip route-cache
no ip mroute-cache
clockrate 72000
bridge-group 1
!
ip classless
no ip http server
!
!
bridge 1 protocol ieee
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
R3#sh bridge
Total of 300 station blocks, 298 free
Codes: P - permanent, S - self
Bridge Group 1:
Address Action Interface Age RX count TX count
00e0.f751.da7b forward Serial1 1 33 32
00e0.1e3e.a119 forward Ethernet0 1 35 33
-----Original Message-----
From: Ahmed Mamoor Amimi [mailto:mamoor@ieee.org]
Sent: Thursday, March 14, 2002 10:13 AM
To: John Neiberger; steven.j.nelson@bt.com; Siddappa, Rajeev;
ccielab@groupstudy.com
Subject: Re: RE: SR/TLB for IP Discoveries (LONG)
How about this :
This is a totally working config with test of DSPU :
r1(0)----(e)---0(bridge)1-----(e)----(0)r2
|
|
|
(TR)
|
|
r3
R1 :
conf t
dspu pu TEST rmac eeee.eeee.eeee rsap 6 lsap 6
interface e0
mac-address 2222.2222.2222
dspu start TEST1
dspu enable-host lsap 6
R3 :
conf t
dspu pu TEST rmac 4444.4444.4444 rsap 6 lsap 6
inter to0
mac-address 7777.7777.7777
dspu start TEST1
dspu enable-host lsap 6
multiring all
bridge config :
conf t
source-bridge ring-group 100
source-bridge transparent 100 1000 1 1
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
int e0
bridge-group 1
exit
int e1
bridge-group 1
exit
inter to0
source-bridge 10 1 100
source-bridge spanning
-Mamoor
----- Original Message -----
From: John Neiberger <neiby@ureach.com>
To: <steven.j.nelson@bt.com>; <RSiddappa@NECBNS.com>;
<ccielab@groupstudy.com>
Sent: Thursday, March 14, 2002 8:37 PM
Subject: RE: RE: SR/TLB for IP Discoveries (LONG)
> I know that, but we're doing SR/TLB so the entire transparent
> bridging domain appears as a ring to the SRB domain, in effect
> giving us two rings.
>
> In my example, the TR interface on R3 is on ring 10. Because
> of SR/TLB, the TB domain appears to be on ring 200.
>
> So, from the perspective of the SRB domain, we have two rings.
> Of course, the ethernet side isn't aware of any of this.
>
> I don't have a router with TR interfaces here at work so I
> can't test this. Perhaps someone who has the setup available
> could pop in these configs without 'multiring ip' and make sure
> it works. I'm fairly sure, but not positive, that I tested it
> without it and didn't work.
>
> Regards,
> John
>
> ---- On Thu, 14 Mar 2002, steven.j.nelson@bt.com
> (steven.j.nelson@bt.com) wrote:
>
> > No because there are no RIFs on Ethernet, so no need for
> Multiring IP
> >
> > -----Original Message-----
> > From: John Neiberger [mailto:neiby@ureach.com]
> > Sent: 14 March 2002 15:29
> > To: Nelson,SJ,Steven,IVNH25 C; RSiddappa@NECBNS.com;
> > ccielab@groupstudy.com
> > Subject: Re: RE: SR/TLB for IP Discoveries (LONG)
> >
> >
> > As I see it, though, from the perspective of the token-ring-
> > only router, the ethernet domain is a different ring. So,
> from
> > it's perspective, there are two rings. It's my (limited)
> > understanding that without multiring ip, the TR-only router
> > would only speak IP to devices on the same ring.
> >
> > Is that correct or not? Admittedly, SRB isn't my strong
> point.
> >
> > John
> >
> > ---- On Thu, 14 Mar 2002, steven.j.nelson@bt.com
> > (steven.j.nelson@bt.com) wrote:
> >
> > > All
> > >
> > > As far as I understand this, Multiring IP is not required
> in
> > this
> > > sceanrio.
> > > Multiring IP is used on a TR interface to enable the use
> and
> > the caching
> > > of
> > > RIF information when SRB to another ring or srb domain.
> > >
> > > If no rif is found in the packet that hits the ring with
> > Multiring IP
> > > configured then the router will act as an SRB end station
> and
> > send out a
> > > test frame (explorer) to locate the destination and then
> pass
> > the packet
> > > back to the source host with the RIF information so the
> host
> > can then
> > > send
> > > an XID to the destination.
> > >
> > > Not required when SRB/TLB between ring and ethernet.
> > >
> > > Just my two cents and probably wrong !!!
> > >
> > > Ta
> > >
> > > Steve
> > >
> > > -----Original Message-----
> > > From: RSiddappa@NECBNS.com [mailto:RSiddappa@NECBNS.com]
> > > Sent: 14 March 2002 06:42
> > > To: neiby@ureach.com; ccielab@groupstudy.com
> > > Subject: RE: SR/TLB for IP Discoveries (LONG)
> > >
> > >
> > > John,
> > >
> > > This is absolutely good and workign config. But I am stll
> not
> > sure do u
> > > need
> > > that multiring Ip on the token ring interface fo the router
> > doign
> > > Translational bridging.
> > >
> > > I do no think. I had it workign with out that few days back.
> > >
> > > R.
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: John Neiberger [mailto:neiby@ureach.com]
> > > Sent: Thursday, March 14, 2002 12:17 AM
> > > To: ccielab@groupstudy.com
> > > Subject: SR/TLB for IP Discoveries (LONG)
> > >
> > >
> > > Since I was temporarily fed up with staring at ipsec
> configs
> > I
> > > thought I'd take a crack at the SR/TLB stuff going on
> today.
> > I
> > > wasn't able to make this work using the configs posted
> > today.
> > > In fact, I can't figure out why the posted configs were
> > working
> > > at all. :-)
> > >
> > > I printed out three different docs from CCO and cross-
> > > referenced that with examples from the archives to come up
> > with
> > > a working solution. Here is the scenario:
> > >
> > > R2 --- (eth) --- R4 --- (tr) --- R3
> > >
> > > Let's start with R4 since it's the most complex. The first
> > > step is to configure SRB and transparent bridging:
> > >
> > > no ip routing
> > > !
> > > source-bridge ring-group 100
> > > !
> > > int to0
> > > source-bridge 10 5 100
> > > !
> > > int e0
> > > bridge-group 1
> > > !
> > > bridge 1 protocol ieee
> > >
> > > Then, configure SR/TLB to bridge between the two interfaces:
> > >
> > > source-bridge transparent 100 200 5 1
> > >
> > > In that config, the first number is from the source-bridge
> > ring-
> > > group statement. The second number is the virtual ring
> > number
> > > that identifies the transparent bridging domain to the SRB
> > > domain. The third number is the bridge number taken from
> the
> > > SRB config on the token ring interface. Finally, the
> fourth
> > > number is the bridge-group number taken from the ethernet
> > > interface config.
> > >
> > > At this point things won't be working just yet. On R2, the
> > > ethernet-only router, we simply need to configure an IP
> > > address. Then, we need to add an IP address to R3 that's
> in
> > > the same subnet. Go ahead, try to ping...it won't work
> yet,
> > > and here's where it starts to get a little tricky if you're
> > > doing this with IP.
> > >
> > > On R4 you've configured SR/TLB which handles layer-two
> > traffic
> > > just fine but it doesn't know how to handle embedded layer
> > > three addresses. To fix this, add the following:
> > >
> > > bridge 1 bitswap-layer3-addresses
> > >
> > > That's fairly straightforward, but things aren't going to
> > work
> > > yet. If you try to ping R2 from R3, the initial ARP will
> > > fail. Why? Because the router needs to send an explorer
> and
> > > it's not configured to do so. So, go to R3 and add the
> > > following:
> > >
> > > int to0
> > > source-bridge 10 4 200 (the 4 and 200 are irrelevant)
> > > source-bridge spanning
> > > multiring ip <------ important!
> > >
> > > Pings still won't work until you go back to the SR/TLB
> router
> > > and add 'source-bridge spanning' and 'multiring ip'. At
> that
> > > point, pings should succeed.
> > >
> > > With this solution there are no guarantees that all IP
> > traffic
> > > will work. In fact, this is configuration is probably a
> > really
> > > bad idea if you're running IP, but it at least sort of
> > works.
> > >
> > > I broke this down into sections to show the steps I went
> > > through to figure this out and make it work. Here are the
> > > final working configs:
> > >
> > > R2 (ethernet):
> > >
> > > int ethernet0
> > > ip address 172.16.43.2 255.255.255.0
> > >
> > > R3 (token ring):
> > >
> > > int tokenring0
> > > ip add 172.16.43.3 255.255.255.0
> > > source-bridge 10 4 200
> > > source-bridge spanning
> > > multiring ip
> > >
> > > R4 (SR/TLB):
> > >
> > > no ip routing
> > > !
> > > source-bridge ring-group 100
> > > source-bridge transparent 100 200 5 1
> > > !
> > > int ethernet 0
> > > bridge-group 1
> > > !
> > > int tokenring0
> > > source-bridge 10 50 100
> > > source-bridge spanning
> > > multiring ip
> > > !
> > > bridge 1 protocol ieee
> > > bridge 1 bitswap-layer3-addresses
> > >
> > > I currently have these exact configs on my routers, and
> here
> > is
> > > the result:
> > >
> > > R3#
> > > R3#sho arp
> > > Protocol Address Age (min) Hardware Addr
> Type
> > > Interface
> > > Internet 172.16.43.3 - 0000.30e2.cc0c
> SNAP
> > > TokenRing0
> > > R3#ping 172.16.43.2
> > >
> > > Type escape sequence to abort.
> > > Sending 5, 100-byte ICMP Echos to 172.16.43.2, timeout is 2
> > > seconds:
> > > .!!!!
> > > Success rate is 80 percent (4/5), round-trip min/avg/max =
> > > 8/8/8 ms
> > > R3#sho arp
> > > Protocol Address Age (min) Hardware Addr
> Type
> > > Interface
> > > Internet 172.16.43.3 - 0000.30e2.cc0c
> SNAP
> > > TokenRing0
> > > Internet 172.16.43.2 0 0000.30b1.4bc1
> SNAP
> > > TokenRing0
> > > R3#
> > >
> > > I sure hope I don't have to mess with this in the real lab,
> > but
> > > this little adventure was very enlightening. At least I
> > think
> > > I could get it working if I run into it when it counts. :-)
> > >
> > > Regards,
> > > John
> > >
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:08 GMT-3