Policy Routing config (50% working)

From: Jeongwoo Park (jpark@xxxxxxxx)
Date: Fri Mar 08 2002 - 06:11:38 GMT-3


   
Hi all
My policy routing is only 50% working.
R1------R2--------R3
R2 is doing policy routing.
Here is the config of three routers and testing result.
Take a look at it and see what makes it working only 50%.

Thanks in adv.

JP

R1#wr t
######
Current configuration:
!
version 10.2
service tcp-small-servers
!
hostname R1
!
!
ip subnet-zero
!
interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 172.16.4.2 255.255.255.0
shutdown
!
interface Serial1
ip address 172.16.14.17 255.255.255.252
!
router rip
network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
transport input all
line vty 0 4
exec-timeout 0 0
password wams
no login
line vty 5 15
login
!
end

R1#

R2#wr t
Building configuration...

Current configuration : 1367 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Loopback1
 ip address 172.16.1.17 255.255.255.240
!
interface Loopback2
 ip address 172.16.1.33 255.255.255.240
!
interface Loopback3
 ip address 172.16.1.49 255.255.255.252
!
interface Loopback4
 ip address 172.16.1.65 255.255.255.240
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.240
!
interface Serial0
 ip address 172.16.14.14 255.255.255.252
 ip policy route-map POLICY
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 172.16.14.18 255.255.255.252
 ip policy route-map POLICY
 clockrate 500000
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router rip
 network 172.16.0.0
!
ip classless
ip http server
!
access-list 1 permit 172.16.1.0 0.0.0.15
access-list 1 permit 172.16.1.16 0.0.0.15
access-list 1 permit 172.16.1.32 0.0.0.15
access-list 2 permit 172.16.1.48 0.0.0.15
access-list 2 permit 172.16.1.64 0.0.0.15
route-map POLICY permit 10
 match ip address 1
 set ip next-hop 172.16.14.17
!
route-map POLICY permit 15
 match ip address 2
 set ip next-hop 172.16.14.13
!
alias exec r sh ip route
!
line con 0
 exec-timeout 0 0
 password wams
line aux 0
line vty 0 2
 exec-timeout 0 0
 password wams
 login
line vty 3 4
 password wams
 login
!
end

R2#

R3#wr t
Building configuration...

Current configuration : 705 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable password wams
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 ip address 172.16.14.13 255.255.255.252
 no fair-queue
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
router rip
 network 1.0.0.0
 network 172.16.0.0
!
ip classless
ip http server
!
alias exec r sh ip route
!
line con 0
line aux 0
 transport input all
line vty 0 4
 exec-timeout 0 0
 password wams
 login
line vty 5 15
 login
!
no scheduler allocate
end

R3#

R2#ping ip
Target IP address: 1.1.1.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.17
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping ip
Target IP address: 1.1.1.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.49
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
R2#ping ip
Target IP address: 172.16.14.17
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.17
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.14.17, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R2#ping ip
Target IP address: 172.16.14.17
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.17
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.14.17, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:56 GMT-3