From: Lupi, Guy (Guy.Lupi@xxxxxxxxxxxxx)
Date: Wed Mar 06 2002 - 20:52:33 GMT-3
It is interesting that you say that, because I struggled with that about a
month back. I know the Cisco documentation says that you need ipxwan
enabled, but I don't find that to be true with hdlc and ppp links, see
config below:
R4
r4#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
username johnny password 0 cisco
ip subnet-zero
no ip domain-lookup
ipx routing 0008.de5c.a38a
ipx internal-network 4
!
!
!
interface Serial0
ip address 1.4.1.4 255.255.255.0
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
ipx network 14
ipx nlsp enable
no fair-queue
clockrate 1300000
ppp authentication chap
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
area 14 stub no-summary
network 1.4.1.0 0.0.0.255 area 14
!
ip classless
!
!
!
ipx router nlsp
area-address 0 0
!
!
ipx router rip
no network 14
no network 4
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
r4# sh ipx nlsp neigh
NLSP Level-1 Neighbors: Tag Identifier = notag
System Id Interface State Holdtime Priority Cir Adj Circuit Id
r1 Se0 Up 50 0 -- -- 03
r4#
R1
r1#sh run
Building configuration...
Current configuration : 1400 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
logging rate-limit console 10 except errors
!
username r4 password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip inspect name firewall tcp
ipx routing 0010.7b80.e936
ipx internal-network 1
cns event-service server
!
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
ip address 5.1.5.1 255.255.255.0
ip inspect firewall out
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ipx network 51
ipx nlsp enable
no arp frame-relay
frame-relay interface-dlci 101
!
interface Serial1
ip address 1.4.1.1 255.255.255.0
ip access-group 101 out
encapsulation ppp
ipx network 14
ipx nlsp enable
ppp authentication chap
ppp chap hostname johnny
!
router ospf 100
log-adjacency-changes
area 14 stub no-summary
network 1.4.1.0 0.0.0.255 area 14
network 5.1.5.0 0.0.0.255 area 0
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 101 permit icmp host 5.1.5.5 host 1.4.1.4
!
!
!
ipx router nlsp
area-address 0 0
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r1# sh ipx nlsp neigh
NLSP Level-1 Neighbors: Tag Identifier = notag
System Id Interface State Holdtime Priority Cir Adj Circuit Id
r4 Se1 Up 52 0 -- -- 01
r5 Se0.1 Up 54 0 -- -- 01
r1#
-----Original Message-----
From: John Neiberger [mailto:neiby@ureach.com]
Sent: Wednesday, March 06, 2002 6:40 PM
To: Lupi, Guy; 'Antonio Marfil'; ccielab@groupstudy.com
Subject: Re: RE: IPX NLSP neighbors on frame-relay point-to-point
subinterface s
This brings up a related question. Why does NLSP require
ipxwan with HDLC or PPP on WAN links, but not on point-to-point
frame relay? Actually, a better question is why is ipxwan
required at all?
I've never understood what ipxwan accomplishes on a non-dialup
link.
John
---- On Wed, 6 Mar 2002, Lupi, Guy (Guy.Lupi@eurekaggn.com)
wrote:
> Works ok for me, here is the config and a "sh ipx nlsp
neighbor" from
> each
> router. HTH.
>
> R5
>
> version 12.1
> no service single-slot-reload-enable
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r5
> !
> logging rate-limit console 10 except errors
> !
> ip subnet-zero
> no ip finger
> no ip domain-lookup
> !
> clns routing
> ipx routing 0010.7b36.e1dd
> ipx internal-network 5
> cns event-service server
> !
> !
> !
> !
> !
> interface Ethernet0
> ip address 172.16.5.5 255.255.255.0
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0.1 point-to-point
> ip address 5.1.5.5 255.255.255.0
> ip ospf authentication message-digest
> ip ospf message-digest-key 1 md5 cisco
> ipx network 51
> ipx nlsp enable
> no arp frame-relay
> frame-relay interface-dlci 151
> !
> interface Serial0.2 point-to-point
> ip address 5.2.5.5 255.255.255.0
> no arp frame-relay
> frame-relay interface-dlci 152
> !
> interface Serial0.3 point-to-point
> ip address 5.3.5.5 255.255.255.0
> no arp frame-relay
> frame-relay interface-dlci 153
> !
> interface Serial1
> ip address 192.168.1.1 255.255.255.0
> !
> router eigrp 1
> redistribute ospf 100 metric 1500 20000 128 128 1500
> network 172.16.5.0 0.0.0.255
> no auto-summary
> no eigrp log-neighbor-changes
> !
> router ospf 100
> log-adjacency-changes
> redistribute eigrp 1 subnets
> network 5.1.5.0 0.0.0.255 area 0
> network 5.2.5.0 0.0.0.255 area 0
> network 5.3.5.0 0.0.0.255 area 0
> default-information originate route-map default-generate
> !
> ip kerberos source-interface any
> ip classless
> no ip http server
> !
> access-list 1 permit 8.8.8.8
> access-list 2 permit 172.16.5.8
> route-map default-generate permit 10
> match ip address 1
> match ip next-hop 2
> !
> !
> !
> !
> ipx router nlsp
> area-address 0 0
> !
> !
> !
> tftp-server flash:/c2500-jos56i-l.121-5.T10.bin
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> password cisco
> login
> !
> end
>
> r5#sh ipx nlsp neigh
> NLSP Level-1 Neighbors: Tag Identifier = notag
> System Id Interface State Holdtime Priority Cir
Adj Circuit
> Id
> r1 Se0.1 Up 57 0 -- --
02
>
> r5#
>
> R1
>
> r1#sh run
> Building configuration...
>
> Current configuration : 1380 bytes
> !
> version 12.1
> no service single-slot-reload-enable
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r1
> !
> logging rate-limit console 10 except errors
> !
> username r4 password 0 cisco
> ip subnet-zero
> no ip finger
> no ip domain-lookup
> !
> ip inspect name firewall tcp
> clns routing
> ipx routing 0010.7b80.e936
> ipx internal-network 1
> cns event-service server
> !
> !
> !
> !
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Ethernet1
> no ip address
> shutdown
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> frame-relay lmi-type cisco
> !
> interface Serial0.1 point-to-point
> ip address 5.1.5.1 255.255.255.0
> ip inspect firewall out
> ip ospf authentication message-digest
> ip ospf message-digest-key 1 md5 cisco
> ipx network 51
> ipx nlsp enable
> no arp frame-relay
> frame-relay interface-dlci 101
> !
> interface Serial1
> ip address 1.4.1.1 255.255.255.0
> ip access-group 101 out
> encapsulation ppp
> ppp authentication chap
> ppp chap hostname johnny
> !
> router ospf 100
> log-adjacency-changes
> area 14 stub no-summary
> network 1.4.1.0 0.0.0.255 area 14
> network 5.1.5.0 0.0.0.255 area 0
> !
> ip kerberos source-interface any
> ip classless
> ip http server
> !
> access-list 101 permit icmp host 5.1.5.5 host 1.4.1.4
> !
> !
> !
> ipx router nlsp
> area-address 0 0
> !
> !
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
> r1#sh ipx nlsp neigh
> NLSP Level-1 Neighbors: Tag Identifier = notag
> System Id Interface State Holdtime Priority Cir
Adj Circuit
> Id
> r5 Se0.1 Up 47 0 -- --
01
>
> r1#
>
>
> -----Original Message-----
> From: Antonio Marfil [mailto:tony.marfil@networxcorp.com]
> Sent: Wednesday, March 06, 2002 4:47 PM
> To: ccielab@groupstudy.com
> Subject: IPX NLSP neighbors on frame-relay point-to-point
subinterfaces
>
>
> Is is possible to establish an NLSP neighbor adjacency using
frame-relay
> point-to-point subinterfaces on both sides of a connection?
>
> I'm using inverse arp and can 'ping ipx' both sides.
>
> Still when i do a 'show ipx nlsp neigh' there is nothing.
>
> Any help would be much appreciated.
>
> Regards,
> Tony
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:55 GMT-3