From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Tue Mar 05 2002 - 19:41:19 GMT-3
You can use what ever you want. If you want to do the unnumbered on the
tunnel. You would have to add the appropriate routes.
For example:
r1
int e0
ip address 10.0.0.1 255.255.255.0
int tunn 0
ip unnumbered e0
ip route 0.0.0.0 0.0.0.0 serial 0
ip route 50.0.0.0 255.255.255.0 int tunn 0
r2
int e0
ip address 50.0.0.1 255.255.255.0
int tunn 0
ip unnumbered e0
ip route 0.0.0.0 0.0.0.0 serial 0
ip route 10.0.0.0 255.255.255.0 int tunn 0
This would be for say a router with a WAN side and a LAN side, and you were
not using a routing protocol.
or if the connection between these 2 goes out the ethernet interface and you
aren't using a routing protocol:
r1
int e0
ip address 10.0.0.1 255.255.255.0
int tunn 0
ip unnumbered e0
tunnel destination 50.0.0.1
ip route 50.0.0.1 255.255.255.255 e0
ip route 50.0.0.0 255.255.255.0 int tunn 0
r2
int e0
ip address 50.0.0.1 255.255.255.0
int tunn 0
ip unnumbered e0
tunnel destination 10.0.0.1
ip route 10.0.0.1 255.255.255.255 e0
ip route 10.0.0.0 255.255.255.0 int tunn 0
If you were using a routing protocol you would not need the route statement.
If you enable the routing protocol on the tunnel it will establish adjacency
with the other side of the tunnel as if it was directly connected. Ofcourse
to first establish the tunnel you will have to have a default route or
something, since you are only going to run the routing protocol on the
tunnel interface. This works great until you want run into let's say a hub
spoke situation and you wanted to have a multipoint GRE tunnel at the hub.
Then you will run into an issue if you don't allow multicasts in the nhrp
configuration or specify a neighbor on the spoke along with an interface.
Kindof wierd, but it works. It says send a unicast to this neighbor down the
tunnel interface.
router eigrp 100
neighbor 10.0.0.1 tunnel 0
If you use multiple gre tunnels for each connection between peers you will
not run into this issue. This issue is only present when you are using nhrp.
Another wierd issue to look out for is when there is one routing protocol
running on the physical and a different one running on the tunnel and they
are both advertising the subnet the other side of the tunnel is on. If the
one on the phsical interface has a higher administrative distance than the
one on the tunnel interface, the tunnel will flap because it will say to
itself my best route to the tunnel destination is via the tunnel interface.
Example:
int e0
ip address 50.0.0.1 255.255.255.0
int tunn 0
ip address 7.0.0.1 255.255.255.0
tunn destination 10.0.0.1
ip router isis
router ospf 100
network 7.0.0.1 0.0.0.0 area 0
router isis
net 49.0001.0000.0000.00
sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is subnetted, 1 subnets
O 10.0.0.0/24 [110/0] via ethernet 0/0
i 10.0.0.0/24 [110/0] via tunnel 0
>>>Brian
>From: Tarek Sabry <tsabry@houston.sns.slb.com>
>Reply-To: tsabry@slb.com
>To: 'Brian Lodwick' <xpranax@hotmail.com>
>Subject: RE: Quick question: GRE and EIGRP
>Date: Tue, 05 Mar 2002 15:41:38 -0600
>
>Hmm on a second though ...... well maybe I cannot use the same network for
>the physical and the tunnel though. Maybe I have to use a different subnet
>for the tunnels. Probably I can use the same MAJOR network but a different
>subnet. What do you think? Would my config below work? I mean you're right
>about the use of the passive interface, but I think I am wrong about my IP
>addressing.
>
>Thanks
>Tarek
>
>-----Original Message-----
>From: Brian Lodwick [mailto:xpranax@hotmail.com]
>Sent: Tuesday, March 05, 2002 3:12 PM
>To: tsabry@houston.sns.slb.com
>Subject: Re: Quick question: GRE and EIGRP
>
>
>Just did it in a lab with the tunnel unnumbered to the ethernet interface,
>and made the ethernet passive and it works.
>
> >>>Brian
>
>
> >From: Tarek Sabry <tsabry@houston.sns.slb.com>
> >Reply-To: Tarek Sabry <tsabry@houston.sns.slb.com>
> >To: ccielab@groupstudy.com
> >Subject: Quick question: GRE and EIGRP
> >Date: Tue, 05 Mar 2002 14:35:14 -0600
> >
> >If I'm running EIGRP on a router and I would like to apply it on a GRE
> >tunnel that happens to be using some Ethernet interface, can I make the
> >Ethernet interface passive because I do not want it to participate in
>EIGRP
> >updates?
> >
> >int Tunnel63
> >ip add 192.168.20.5 255.255.255.0
> >tunnel source fa0/0
> >tunnel destination 192.168.20.2
> >tunnel key 63
> >
> >int FastEthernet0/0
> >ip address 192.168.20.1 255.255.255.0
> >
> >router eigrp 4
> >network 192.168.20.0
> >passive-interface fa0/0
> >no auto-summary
> >
> >Well, can I use the same network number for the tunnel AND the underlying
> >physical interface to begin with?
> >
> >Also for EIGRP, can I use a mask the way I do with OSPF? I heard that
> >starting with some IOS release I can. Please verify.
> >
> >Thanks
> >Tarek
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:54 GMT-3