From: yakout (yesmat@xxxxxxxxxxxxxx)
Date: Sun Mar 03 2002 - 00:05:38 GMT-3
Guys,
That's all good and work fine. But what if we need to redistribute ALLLL of
ospf(1) routes into IGRP NOT ONLY "summary-address a.b.c.d ...." networks
(which is usually the case). Then redistributing ospf(2) by itself will not
work, we need to redistribute ospf(1) into IGRP as well.
Please correct me if I am wrong.
Cheers
Yakout
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Cote, David [Contractor]
Sent: Friday, February 01, 2002 12:53 AM
To: 'ccielab@groupstudy.com'
Subject: RE: what if router is ASBR only , how to /28 in to /24 IGRP ?
I did this last night, had some /28 and /26 bit masked OSPF networks I
needed to redistribute into IGRP which has /24 bit networks.
So I created a second ospf process, redistributed the first ospf process,
created summary-addresses in the second process, then redistributed the
second process into igrp. worked like a charm. You don't have to have any
networks in the second process. Sample code below:
router ospf 1
network 10.10.10.0 0.0.0.15 area 2
redistribute igrp 1 metric 20 metric-type 1 subnets
router ospf 2
summary-address 10.10.10.0 255.255.255.0 <-- this network connected
locally
summary-address 10.10.12.0 255.255.255.0 <-- this network in area 0 that
has a 28 bit mask
redistribute ospf 1 subnets
router igrp 1
network 172.10.0.0
redistribute ospf 2
I also used route maps to filter routes but didn't include them here for
clarity.
- Dave Cote
-----Original Message-----
From: Chua, Parry [mailto:Parry.Chua@compaq.com]
Sent: Wednesday, January 30, 2002 4:36 PM
To: Bryan Ginman; tang bing
Cc: ccielab@groupstudy.com
Subject: RE: what if router is ASBR only , how to /28 in to /24 IGRP ?
If you intend to do it OSPF side, then the following should work.
R2# ! create a second ospf process, assisn area 0 network
! redistribute the ospf process into this new process with
selection.
! summary the area2 network from /28 to /24
R2# router ospf 123
network a.b.c.d mask area 0
redistribute ospf ospf-area2 subnets route-map o2o2igrp
summary area2/28 255.255.255.0
R2# route-map o2o2igrp permit 10
match <area2 network/28 only>
R2# router igrp xx
redistribute ospf 123 <metric>
I have done it on 12.0 and 12.1 IOS, both work w/o any problem.
Parry Chua
-----Original Message-----
From: Bryan Ginman [mailto:ginmanb@westnet.com]
Sent: Thursday, January 31, 2002 12:52 AM
To: tang bing
Cc: ccielab@groupstudy.com
Subject: RE: what if router is ASBR only , how to /28 in to /24 IGRP ?
OK that's a bit clearer. The only way you can do this is this then.
1 Create a tunnel between r1 and r2 with a /28 run igrp over this. Your
/28
routes will come in then
2 Create a loopback and add it to another are that will then allow you
to
area range it.
3 Create a static route to Null0 that summarizes at /24
Cheers,
Bryan
-----Original Message-----
From: tang bing [mailto:tang_bing@yahoo.com]
Sent: Wednesday, January 30, 2002 11:16 AM
To: Bryan Ginman
Cc: ccielab@groupstudy.com
Subject: RE: what if router is ASBR only , how to /28 in to /24 IGRP ?
r1
|
|
igrp/24
|
|
r2
|(int e0/0)
|
ospf-area2-/28
|
|
r3
|
area 0
since r2-e0/0 is in the OSPF process 1 area 2 , r2 is
ASBR , but not ABR .
I configured an other OSPF process 2 , redist process
1 in .
e0/0 is still not in database as type-5 , so you
cann't summary-address it .
area-range ? you cannot put e0/0 in process 2 ,
because one interface can only be in one process .
r3#sh1 router
router ospf 1
log-adjacency-changes
area 0 range 132.2.3.0 255.255.255.0
redistribute igrp 1 metric 10 subnets
network 132.2.3.0 0.0.0.15 area 0
!
router ospf 2
log-adjacency-changes
redistribute ospf 1 subnets
network 132.2.99.0 0.0.0.255 area 0
!
router igrp 1
redistribute ospf 1 metric 1000 10 255 1 1500
passive-interface Ethernet0/0
network 132.2.0.0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
route-map conn-ospf permit 10
match interface Ethernet0/0
!
bridge 1 protocol ieee
alias exec ip show ip route
alias exec bg show ip bgp
alias exec bs show ip bgp sum
alias exec ci clear ip route *
alias exec cb clear ip bgp *
alias exec i show run int
alias exec r show run
alias exec bri sh ip int brie bri1/0:1
alias exec cbri clear int brI 1/0
alias exec o show ip ospf nei
alias exec c conf t
alias exec br show ip int brie
alias exec cs clear ip bgp * soft out
alias exec ipx sh ipx rout
alias exec ipxbri show ipx inter brie
alias exec cipx clear ipx route *
alias exec ipxs sh ipx server
alias exec sh1 show run | begin
r3#sh ip os
r3#sh ip ospf da
r3#sh ip ospf database
OSPF Router with ID (132.2.99.1) (Process ID 2)
Router Link States (Area 0)
Link ID ADV Router Age Seq#
Checksum Link count
132.2.99.1 132.2.99.1 1776 0x80000003
0x9CD0 1
Type-5 AS External Link States
Link ID ADV Router Age Seq#
Checksum Tag
117.1.1.1 132.2.99.1 1776 0x80000003
0xC36C 0
132.2.3.0 132.2.99.1 1776 0x80000003
0xBA88 0
132.2.4.0 132.2.99.1 1776 0x80000003
0x6EBA 0
195.5.5.0 132.2.99.1 1776 0x80000003
0x6D6E 0
205.205.205.5 132.2.99.1 1776 0x80000003
0xEF5E 0
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq#
Checksum Link count
3.3.3.3 3.3.3.3 1997 0x8000002B
0x3996 1
116.1.1.1 116.1.1.1 618 0x8000002A
0x9EE 1
205.205.205.5 205.205.205.5 1900 0x80000030
0xBE96 3
Net Link States (Area 0)
Link ID ADV Router Age Seq#
Checksum
132.2.3.2 205.205.205.5 1900 0x80000029
0x9715
132.2.4.2 116.1.1.1 618 0x80000026
0x9694
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq#
Checksum
117.1.1.1 116.1.1.1 105 0x80000025
0x6AB3
195.5.5.0 116.1.1.1 105 0x8000002F
0xFFBF
Type-5 AS External Link States
Link ID ADV Router Age Seq#
Checksum Tag
132.2.2.0 3.3.3.3 1997 0x80000004
0x3AD8 0
132.2.99.0 3.3.3.3 1998 0x80000003
0xB20F 0
r3#
r3#ip
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA -
OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
E1 - OSPF external type 1, E2 - OSPF external
type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
level-2, ia - IS-IS inter area
* - candidate default, U - per-user static
route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
205.205.205.0/32 is subnetted, 1 subnets
O 205.205.205.5 [110/11] via 132.2.3.2,
00:11:08, Ethernet0/0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, BRI1/0
117.0.0.0/32 is subnetted, 1 subnets
O IA 117.1.1.1 [110/31] via 132.2.3.2, 00:11:08,
Ethernet0/0
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
O IA 195.5.5.0/24 [110/30] via 132.2.3.2, 00:11:08,
Ethernet0/0
132.2.0.0/16 is variably subnetted, 4 subnets, 2
masks
O 132.2.4.0/24 [110/20] via 132.2.3.2, 00:11:08,
Ethernet0/0
C 132.2.2.0/24 is directly connected,
Ethernet0/1
C 132.2.3.0/28 is directly connected,
Ethernet0/0
C 132.2.99.0/28 is directly connected, Loopback9
r3#
--- Bryan Ginman <ginmanb@westnet.com> wrote:
> I thought this router had another area attached to
> it you might want ro
> layout a quick diagram so that we can see what your
> talking about a little
> better.
>
> Cheers,
>
> Bryan
>
> -----Original Message-----
> From: tang bing [mailto:tang_bing@yahoo.com]
> Sent: Wednesday, January 30, 2002 9:36 AM
> To: Bryan Ginman
> Cc: ccielab@groupstudy.com
> Subject: RE: what if router is ASBR only , how to
> /28 in to /24 IGRP ?
>
>
> Hi,
> Still wonn't work .
> R1 has /28 connected to area 10 in OSPF 1 , this is
> the ASBR .
> then in R1 , creat OSPF 2 , redistribute OSPF 1 into
> it .
> the /28 wonn't show as TYPE-5 , so cannot summary
> it.
> and in OSPF 2 , R1 is still ASBR , not ABR , how to
> area range ? which area ? you didn't define any area
> .
> can you explain ?
>
> Ben
>
>
> --- Bryan Ginman <ginmanb@westnet.com> wrote:
> > The create a second OSPF process don't add any
> > interfaces into it,
> > redistribute process 1 into it and it becomes a
> > ASBR. Then are 2 range it.
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com
> > [mailto:nobody@groupstudy.com]On Behalf Of
> > tang bing
> > Sent: Tuesday, January 29, 2002 3:52 PM
> > To: ccielab@groupstudy.com
> > Subject: what if router is ASBR only , how to /28
> in
> > to /24 IGRP ?
> >
> >
> > Let stop the chain .
> > Here is what I found :
> > 1. Router must has type-5 LSA to summary-address .
> > 2. Router must be ABR to do area 0 range , ASBR of
> > course , IGRP redistribute in OSPF .
> >
> > what if router is in Area 2 , no area 0 on this
> > router
> > ?
> > and you cannot put the same interface in a second
> > OSPF
> > process , OSPF wonn't work that way .
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:51 GMT-3