RE: WORKING Fine ( Source Route Transparent bridging.)

From: RSiddappa@xxxxxxxxxx
Date: Sat Feb 23 2002 - 23:58:37 GMT-3


   
Hmmm Parry,

Look interesting. let me try an what happens.

But, what IP address do u want me to put on the BVI interface. Same subnet
as the R1's Token ring interface.

R.

-----Original Message-----
From: Chua, Parry [mailto:Parry.Chua@compaq.com]
Sent: Saturday, February 23, 2002 8:53 PM
To: Siddappa, Rajeev; neiby@ureach.com; tshon@netzero.net;
annu_roopa@yahoo.com
Cc: jim.phillipo@guardent.com; ccielab@groupstudy.com
Subject: RE: WORKING Fine ( Source Route Transparent bridging.)

Hi,

Just a suggestion for you to test, I think you can enable routing On R3
by using
IRB, ie make E0/S0 in the same brige group and assign BVI with IP
address.

Regards
Parry

-----Original Message-----
From: RSiddappa@NECBNS.com [mailto:RSiddappa@NECBNS.com]
Sent: Sunday, February 24, 2002 5:24 AM
To: neiby@ureach.com; tshon@netzero.net; annu_roopa@yahoo.com
Cc: jim.phillipo@guardent.com; ccielab@groupstudy.com
Subject: WORKING Fine ( Source Route Transparent bridging.)

Hi Guys thanks for every ones help.

Here is the working config. Looks like I had not disabled the IP routing
on
one of the routers which was doing bridging. But it was good exercise.

Set up is as follows :

R1-----To--------R2---------So--------------R3---------E0-----------R4

R1 and R4 are used as end hosts, and R2 and R3 are actually doing the
bridging.

It is absolutely important that routing is disabled on R2 and R3 for
this
set up to work.
Assign some IP addresses to R1 and R4's Token ring and Ethernet
interfaces
so that they are in the same subnet. Once u are ready with
configurations on
R2 and R3 try to ping from R1 to R4.

Here is the working solution. ( Config's of R2 and R3 only).

hostname R2
!
enable password cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 bridge-group 1
!
interface Serial1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface TokenRing0
 ip address 10.10.10.6 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 ring-speed 16
 bridge-group 1
!

interface BRI0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface PCbus0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
ip classless
!
bridge 1 protocol ieee

bridge 1 bitswap-layer3-addresses

Absolutely important command for this setup or any set up using the
combination of Token ring and Ethernet to work.

!
line con 0
 privilege level 15
 password cisco
 login
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

R2#sh bridge

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX count TX count
00e0.f751.da7b forward TokenRing0 0 112 56
00e0.1e3e.a119 forward Serial0 0 18 9

hostname R3
!
!
!
!
!
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip route-cache
 no ip mroute-cache
 bridge-group 1
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 ip address 30.30.30.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 clockrate 72000
 bridge-group 1
!
ip classless
no ip http server
!
!
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

R3#sh bridge

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX count TX count
00e0.f751.da7b forward Serial1 0 122 61
00e0.1e3e.a119 forward Ethernet0 4 23 14

R.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:32 GMT-3